Bug 290829 - Crash in kdeinit4
Summary: Crash in kdeinit4
Status: RESOLVED DUPLICATE of bug 286353
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-06 21:21 UTC by Ian Pilcher
Modified: 2012-01-06 21:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Pilcher 2012-01-06 21:21:11 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.6-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

Switching between one virtual desktop and a different virtual desktop.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7ffef03cc840 (LWP 27746))]

Thread 2 (Thread 0x7ffec7d71700 (LWP 27747)):
#0  0x00007ffeed049af3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffee95c2f88 in g_main_context_poll (n_fds=1, fds=0x7ffec0002400, priority=<optimized out>, timeout=-1, context=0x7ffec00009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7ffec00009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x00007ffee95c344c in g_main_context_iteration (context=0x7ffec00009a0, may_block=1) at gmain.c:3136
#4  0x00007ffeeed8bdb6 in QEventDispatcherGlib::processEvents (this=0x7ffec00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007ffeeed5c172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ffeeed5c3c7 in QEventLoop::exec (this=0x7ffec7d70d10, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007ffeeec5cb27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007ffeeed3be6f in QInotifyFileSystemWatcherEngine::run (this=0x29a77e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007ffeeec5fb6b in QThreadPrivate::start (arg=0x29a77e0) at thread/qthread_unix.cpp:298
#10 0x00007ffeee9cfd90 in start_thread (arg=0x7ffec7d71700) at pthread_create.c:309
#11 0x00007ffeed05248d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7ffef03cc840 (LWP 27746)):
[KCrash Handler]
#6  KWindowInfo::valid (this=0x4036000000000010, withdrawn_is_valid=true) at /usr/src/debug/kdelibs-4.7.4/kdeui/windowmanagement/kwindowinfo_x11.cpp:133
#7  0x00007ffecaf76ad6 in TaskManager::Task::isOnCurrentDesktop (this=0x300a570) at /usr/src/debug/kde-workspace-4.7.4/libs/taskmanager/task.cpp:211
#8  0x00007ffec4a19d44 in TaskSource::updateDesktop (this=0x3ae3d80, desktop=<optimized out>) at /usr/src/debug/kde-workspace-4.7.4/plasma/generic/dataengines/tasks/tasksource.cpp:161
#9  0x00007ffec4a1a07b in TaskSource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kde-workspace-4.7.4/x86_64-redhat-linux-gnu/plasma/generic/dataengines/tasks/tasksource.moc:57
#10 0x00007ffeeed70cd1 in QMetaObject::activate (sender=0x2dbbc30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffed0d1860) at kernel/qobject.cpp:3547
#11 0x00007ffecaf82c61 in TaskManager::TaskManager::desktopChanged (this=<optimized out>, _t1=8) at /usr/src/debug/kde-workspace-4.7.4/x86_64-redhat-linux-gnu/libs/taskmanager/taskmanager.moc:214
#12 0x00007ffecaf84843 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.7.4/x86_64-redhat-linux-gnu/libs/taskmanager/taskmanager.moc:104
#13 TaskManager::TaskManager::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kde-workspace-4.7.4/x86_64-redhat-linux-gnu/libs/taskmanager/taskmanager.moc:87
#14 0x00007ffeeed70cd1 in QMetaObject::activate (sender=0x21f4d90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffed0d1a90) at kernel/qobject.cpp:3547
#15 0x00007ffeefed662e in KWindowSystem::currentDesktopChanged (this=<optimized out>, _t1=8) at /usr/src/debug/kdelibs-4.7.4/x86_64-redhat-linux-gnu/kdeui/kwindowsystem.moc:136
#16 0x00007ffeefed8ca3 in KWindowSystemPrivate::x11Event (this=0x225ef30, ev=0x7fffed0d1ba0) at /usr/src/debug/kdelibs-4.7.4/kdeui/windowmanagement/kwindowsystem_x11.cpp:175
#17 0x00007ffeefdca116 in publicX11Event (e=0x7fffed0d1ba0, this=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/ksystemeventfilter.cpp:43
#18 KSystemEventFilterPrivate::filterEvent (this=0x225a430, message=0x7fffed0d1ba0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/ksystemeventfilter.cpp:102
#19 0x00007ffeedf7c916 in x11EventSourceDispatch (s=0x21730b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:145
#20 0x00007ffee95c2a7d in g_main_dispatch (context=0x2172c00) at gmain.c:2425
#21 g_main_context_dispatch (context=0x2172c00) at gmain.c:2995
#22 0x00007ffee95c3278 in g_main_context_iterate (context=0x2172c00, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#23 0x00007ffee95c344c in g_main_context_iteration (context=0x2172c00, may_block=1) at gmain.c:3136
#24 0x00007ffeeed8bd4f in QEventDispatcherGlib::processEvents (this=0x2158360, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007ffeedf7c61e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#26 0x00007ffeeed5c172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007ffeeed5c3c7 in QEventLoop::exec (this=0x7fffed0d1f70, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007ffeeed60dc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x00007ffed2c10243 in kdemain (argc=1, argv=0x2092790) at /usr/src/debug/kde-workspace-4.7.4/plasma/desktop/shell/main.cpp:120
#30 0x0000000000408254 in launch (argc=1, _name=0x20e5d98 "/usr/bin/plasma-desktop", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40adb6 "0") at /usr/src/debug/kdelibs-4.7.4/kinit/kinit.cpp:734
#31 0x00000000004093c4 in handle_launcher_request (sock=<optimized out>, who=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/kinit/kinit.cpp:1226
#32 0x00000000004098e4 in handle_requests (waitForPid=0) at /usr/src/debug/kdelibs-4.7.4/kinit/kinit.cpp:1419
#33 0x0000000000405207 in main (argc=4, argv=0x7fff00000001, envp=0x7fffed0d34a0) at /usr/src/debug/kdelibs-4.7.4/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 286353.

Possible duplicates by query: bug 290024, bug 289611, bug 289461, bug 286353.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-01-06 21:32:08 UTC

*** This bug has been marked as a duplicate of bug 286353 ***