Bug 270918 - It said it crashed just after I quit [@Meta::UmsHandler::~UmsHandler]
Summary: It said it crashed just after I quit [@Meta::UmsHandler::~UmsHandler]
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-14 07:34 UTC by el_gallo_azul
Modified: 2011-07-18 06:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description el_gallo_azul 2011-04-14 07:34:12 UTC
Application: amarok (2.3.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I ran Amarok to see if phonon had updated to play MP3s etc. It didn't look like it had so I selected 'Quit' using the menu. It then said it crashed.

-- Backtrace:
Application: Amarok (amarok), signal: Aborted
[Current thread is 1 (Thread 0xb64f8770 (LWP 1789))]

Thread 16 (Thread 0xb6290b70 (LWP 1790)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00c11df6 in poll () from /lib/libc.so.6
#2  0x02838a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x0282b43c in ?? () from /lib/libglib-2.0.so.0
#4  0x0282bba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x02cdd9c4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0x0285248f in ?? () from /lib/libglib-2.0.so.0
#7  0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#8  0x00c2069e in clone () from /lib/libc.so.6

Thread 15 (Thread 0xb3b0fb70 (LWP 1799)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00c2e0f3 in ?? () from /lib/libc.so.6
#2  0x00bc265f in ?? () from /lib/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 14 (Thread 0xaf234b70 (LWP 1821)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2ddf4 in pthread_cond_timedwait () from /lib/libc.so.6
#3  0x03d13b3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 13 (Thread 0xaea33b70 (LWP 1822)):
#0  0x0282b836 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#1  0x00a4a59f in QEventDispatcherGlib::processEvents (this=0x88422d0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#2  0x00a1a609 in QEventLoop::processEvents (this=0xaea33220, flags=) at kernel/qeventloop.cpp:149
#3  0x00a1aa8a in QEventLoop::exec (this=0xaea33220, flags=...) at kernel/qeventloop.cpp:201
#4  0x00916b7e in QThread::exec (this=0x883e460) at thread/qthread.cpp:490
#5  0x03b4081a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#6  0x00919df9 in QThreadPrivate::start (arg=0x883e460) at thread/qthread_unix.cpp:266
#7  0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#8  0x00c2069e in clone () from /lib/libc.so.6

Thread 12 (Thread 0xae232b70 (LWP 1823)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00c11df6 in poll () from /lib/libc.so.6
#2  0x02997562 in ?? () from /usr/lib/libpulse.so.0
#3  0x02983ab9 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x02985a73 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x02985b44 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x02997303 in ?? () from /usr/lib/libpulse.so.0
#7  0x04f5cbd5 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#9  0x00c2069e in clone () from /lib/libc.so.6

Thread 11 (Thread 0xa98ffb70 (LWP 1824)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x03d25b54 in ?? () from /usr/lib/libxine.so.1
#4  0x00000000 in ?? ()

Thread 10 (Thread 0xa90feb70 (LWP 1825)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x03d25b54 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 9 (Thread 0xa88fdb70 (LWP 1826)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x03d25b54 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 8 (Thread 0xa80fcb70 (LWP 1827)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x03d25b54 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 7 (Thread 0xa7207b70 (LWP 1897)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x0091a9c7 in wait (this=0x9394040, mutex=0x936ab18, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9394040, mutex=0x936ab18, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x02d59030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9394028, th=0x93717c8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x02d5c7dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x936ce18, th=0x93717c8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x02d5855b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9394028, th=0x93717c8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x02d5c8d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x936ce18, th=0x93717c8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x02d59533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9394028, th=0x93717c8, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x02d5c8f1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x936ce18, th=0x93717c8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0x02d59533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9394028, th=0x93717c8, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#12 0x02d5c8f1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x936ce18, th=0x93717c8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#13 0x02d59533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9394028, th=0x93717c8, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#14 0x02d5c8f1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x936ce18, th=0x93717c8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#15 0x02d59533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9394028, th=0x93717c8, previous=0x95bac80) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#16 0x02d5a95e in ThreadWeaver::ThreadRunHelper::run (this=0xa7207294, parent=0x9394028, th=0x93717c8) at ../../../threadweaver/Weaver/Thread.cpp:87
#17 0x02d5b07b in ThreadWeaver::Thread::run (this=0x93717c8) at ../../../threadweaver/Weaver/Thread.cpp:142
#18 0x00919df9 in QThreadPrivate::start (arg=0x93717c8) at thread/qthread_unix.cpp:266
#19 0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#20 0x00c2069e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xa5a7fb70 (LWP 1898)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb72103a5 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb7210481 in ?? () from /usr/lib/libQtWebKit.so.4
#5  0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#6  0x00c2069e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xa517eb70 (LWP 1901)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x0091a9c7 in wait (this=0x9394040, mutex=0x936ab18, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9394040, mutex=0x936ab18, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x02d59030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9394028, th=0x95a0ab0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x02d5c7dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x936ce18, th=0x95a0ab0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x02d5855b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9394028, th=0x95a0ab0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x02d5c8d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x936ce18, th=0x95a0ab0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x02d59533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9394028, th=0x95a0ab0, previous=0x9c2f500) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x02d5a95e in ThreadWeaver::ThreadRunHelper::run (this=0xa517e294, parent=0x9394028, th=0x95a0ab0) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x02d5b07b in ThreadWeaver::Thread::run (this=0x95a0ab0) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x00919df9 in QThreadPrivate::start (arg=0x95a0ab0) at thread/qthread_unix.cpp:266
#13 0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#14 0x00c2069e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa497db70 (LWP 1903)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x0091a9c7 in wait (this=0x9394040, mutex=0x936ab18, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9394040, mutex=0x936ab18, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x02d59030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9394028, th=0x95d3690) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x02d5c7dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x936ce18, th=0x95d3690) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x02d5855b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9394028, th=0x95d3690) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x02d5c8d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x936ce18, th=0x95d3690) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x02d59533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9394028, th=0x95d3690, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x02d5c8f1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x936ce18, th=0x95d3690) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0x02d59533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9394028, th=0x95d3690, previous=0x98fa918) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#12 0x02d5a95e in ThreadWeaver::ThreadRunHelper::run (this=0xa497d294, parent=0x9394028, th=0x95d3690) at ../../../threadweaver/Weaver/Thread.cpp:87
#13 0x02d5b07b in ThreadWeaver::Thread::run (this=0x95d3690) at ../../../threadweaver/Weaver/Thread.cpp:142
#14 0x00919df9 in QThreadPrivate::start (arg=0x95d3690) at thread/qthread_unix.cpp:266
#15 0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#16 0x00c2069e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa417cb70 (LWP 1904)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00f3d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00c2dd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x075eb877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x76ea1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x075eb8c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x76ea1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x00f38cc9 in start_thread () from /lib/libpthread.so.0
#6  0x00c2069e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa1b7fb70 (LWP 1906)):
#0  0x00f7d416 in __kernel_vsyscall ()
#1  0x00c2e0f3 in ?? () from /lib/libc.so.6
#2  0x00bc265f in ?? () from /lib/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb64f8770 (LWP 1789)):
[KCrash Handler]
#7  0x00f7d416 in __kernel_vsyscall ()
#8  0x00b7a941 in raise () from /lib/libc.so.6
#9  0x00b7de42 in abort () from /lib/libc.so.6
#10 0x00bb2305 in ?? () from /lib/libc.so.6
#11 0x00bbc501 in ?? () from /lib/libc.so.6
#12 0x00bbf695 in ?? () from /lib/libc.so.6
#13 0x00bc0f33 in malloc () from /lib/libc.so.6
#14 0x0091411d in qMalloc (size=512) at global/qmalloc.cpp:55
#15 0x0093ac38 in QListData::detach_grow (this=0xbff2a9fc, idx=0xbff2a934, num=1) at tools/qlist.cpp:85
#16 0x0069f5dc in QList<QString>::detach_helper_grow (this=0xbff2a9fc, i=2147483647, c=1) at /usr/include/qt4/QtCore/qlist.h:663
#17 0x0069f6fe in QList<QString>::append (this=0x0, t=...) at /usr/include/qt4/QtCore/qlist.h:496
#18 0x0071dafa in KDirWatchPrivate::removeEntries (this=0x91a7908, instance=0x8835320) at ../../kdecore/io/kdirwatch.cpp:1031
#19 0x0071df94 in KDirWatch::~KDirWatch (this=0x8835320, __in_chrg=<value optimized out>) at ../../kdecore/io/kdirwatch.cpp:1744
#20 0x03e04c43 in Meta::UmsHandler::~UmsHandler (this=0x88352a0, __in_chrg=<value optimized out>) at ../../../../../src/core-impl/collections/umscollection/handler/UmsHandler.cpp:124
#21 0x00a2e816 in QObjectPrivate::deleteChildren (this=0x8836af0) at kernel/qobject.cpp:1957
#22 0x00a35f30 in QObject::~QObject (this=0x93e3dc8, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#23 0x05b8822a in Collections::Collection::~Collection (this=0x93e3dc8, __in_chrg=<value optimized out>) at ../../../src/core/collections/Collection.cpp:79
#24 0x01260036 in Collections::MediaDeviceCollection::~MediaDeviceCollection (this=0x93e3dc8, __in_chrg=<value optimized out>) at ../../src/core-impl/collections/mediadevicecollection/MediaDeviceCollection.cpp:127
#25 0x03dfdf33 in Collections::UmsCollection::~UmsCollection (this=0x93e3dc8, __in_chrg=<value optimized out>) at ../../../../../src/core-impl/collections/umscollection/UmsCollection.cpp:81
#26 0x013a399e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (this=0x8cda1c0, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:322
#27 qDeleteAll<SmartPointerList<Collections::Collection> > (this=0x8cda1c0, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:330
#28 CollectionManager::~CollectionManager (this=0x8cda1c0, __in_chrg=<value optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:130
#29 0x0139fa9b in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:100
#30 0x015395da in App::~App (this=0xbff2ad2c, __in_chrg=<value optimized out>) at ../../src/App.cpp:287
#31 0x0804fbb3 in main (argc=1, argv=0xbff2b5a4) at ../../src/main.cpp:237

This bug may be a duplicate of or related to bug 268173.

Possible duplicates by query: bug 268173.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-04-14 12:17:45 UTC
Could you please upgrade to Amarok 2.4 or 2.4.1 beta aka 2.4.0.90 and try again?
Comment 2 Myriam Schweingruber 2011-07-17 22:14:35 UTC
Closing for lack of feedback. Feel free to reopen if you can still reproduce
this with Amarok 2.4.2 beta 1 or later and provide the necessary feedback.
Comment 3 el_gallo_azul 2011-07-18 05:18:14 UTC
Thanks but now it can be closed.

I use only Rhythmbox on Ubuntu now.
Comment 4 Myriam Schweingruber 2011-07-18 06:34:10 UTC
Setting status correctly. WONTFIX is a developer decision only.