Bug 297445 - Alt-Tab behavior - not really recently used
Summary: Alt-Tab behavior - not really recently used
Status: RESOLVED NOT A BUG
Alias: None
Product: kwin
Classification: Plasma
Component: core (show other bugs)
Version: 4.8.1
Platform: Ubuntu Linux
: NOR wishlist with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 342868 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-04 06:40 UTC by Victor Varvaryuk
Modified: 2020-06-18 06:00 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Varvaryuk 2012-04-04 06:40:53 UTC
I have this:
System Settings -> Window Behavior -> Task Switcher -> Sort order: Recently used

Now, if i minimize a window and then immediately press Alt-Tab, i am not switched to the just minimized window, though it was the most recently used.

And there is no other setting except Staking Order, which i don't need.

http://www.youtube.com/watch?v=mcClUyGlKAU

=======================
Related bug: https://bugs.kde.org/show_bug.cgi?id=61697
Related forum topic: http://forum.kde.org/viewtopic.php?f=111&t=99625

=======================
Would it be possible to make an option how minimizing a window affects stacking order?
Option1 (default): Minimizing a window moves to the end of the window list.
Option 2: Minimizing a window leaves it as the most recently used.
Comment 1 Martin Flöser 2012-04-04 16:59:14 UTC
Request is a response coming from forum thread http://forum.kde.org/viewtopic.php?f=111&t=99625

Let's take it back to the forum and use brainstorm to figure out whether this is a change users would like to have :-)
Comment 2 Victor Varvaryuk 2013-04-07 18:40:25 UTC
I agree that the logic of this wish might be subjective, but there is one objective point in its favour, which maybe wasn't made clear: being able to change Alt-Tab behaviour helps people coming to KDE from Windows. I am myself using KDE and WIndows in parallel, and for me its difficult to switch to different workflow in KDE, event if it's more logical.
Comment 3 emoxam 2013-07-04 09:28:37 UTC
I agree, don't lunix developers want to come users from windows ? So most behaviour things must be exactly as they are in windows. I can't understand whats wrong with alt+tab for a long time! Do not be stubborn let it be optioanl, i guess it's not so hard.
Comment 4 seishin 2014-09-26 08:58:28 UTC
I have made a patch in the KDE/4.11 branch for this and compiled a x64 binary that may be used as replacement:

https://github.com/katakumpo/kde-workspace#kde-workspace

the relevant commit is this one:
https://github.com/katakumpo/kde-workspace/commit/021ed7cf41e416ee3d93439c4f09489a38b3a35f

I assume this will not come to live here, but it may help others on their machines.
Comment 5 Martin Flöser 2014-09-26 09:07:50 UTC
> I assume this will not come to live here

as the code just deletes a currently used behavior: no. That would need 
exposing with an option at least.
Comment 6 Thomas Lübking 2015-01-15 12:09:04 UTC
*** Bug 342868 has been marked as a duplicate of this bug. ***
Comment 7 Henrique Sant'Anna 2018-06-30 17:19:23 UTC
Plasma 5.13.2 and this bug is still annoying people and there is still being requested for a solution where, at least, users could chose the behavior:
- If the minimized window will actually be sent to bottom of the stack (current plasma behavior); or
- If the last minimized window will be at the top of the stack (Microsoft Windows behavior, Gnome, xfce). That way users can select "the last used window" even if it was just minimized.

Another approach would be to offer another shortkey to change to the last used window. Microsoft Windows also have this feature, where you can use gesture on touchpad or touchscreen (slide from right border to inside) to do that. Android N also offers that feature by double tapping the multitask phone button.

KDE Plasma System Settings already haves a robust Task Switcher configuration, but it really misses that option where a minimized window is kept in top of the stack, just like a regular window.

Current discussion:
https://forum.kde.org/viewtopic.php?t=143414

Older topics:
https://forum.kde.org/viewtopic.php?t=99625
https://forum.kde.org/viewtopic.php?t=101211
Comment 8 Martin Flöser 2018-06-30 18:30:32 UTC
Please don't just reopen reports. Thank you.
Comment 9 enterprise.ekle 2020-06-18 06:00:26 UTC
i too would like this to be fixed!