Bug 297051 - contact crashed on execution
Summary: contact crashed on execution
Status: RESOLVED DUPLICATE of bug 290234
Alias: None
Product: plasma4
Classification: Plasma
Component: activities (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-29 15:16 UTC by stefan fischer
Modified: 2012-03-29 15:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefan fischer 2012-03-29 15:16:52 UTC
Application: kactivitymanagerd (1.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 2"
Qt Version: 4.8.0
Operating System: Linux 3.3.0-16-default x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I started contact or
started kmail

- Unusual behavior I noticed:
after the last update I did symbols in the left task bar side increased their size by 3 times

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Aktivitätenverwaltung (kactivitymanagerd), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4659447760 (LWP 2633))]

Thread 2 (Thread 0x7f464a15a700 (LWP 2641)):
[KCrash Handler]
#6  QString (other=..., this=0x7f464a159580) at ../../src/corelib/tools/qstring.h:725
#7  QDBusAbstractInterface::interface (this=0x7f4644002200) at qdbusabstractinterface.cpp:375
#8  0x00007f4653af7aba in ?? () from /usr/lib64/libsopranoclient.so.1
#9  0x00007f4653b0525c in Soprano::Client::DBusModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib64/libsopranoclient.so.1
#10 0x00007f4658495d6c in Nepomuk::MainModel::executeQuery (this=0x84e010, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/nepomukmainmodel.cpp:212
#11 0x00007f464a1628fc in ?? () from /usr/lib64/kde4/activitymanager_plugin_nepomuk.so
#12 0x00007f464a1695b8 in ?? () from /usr/lib64/kde4/activitymanager_plugin_nepomuk.so
#13 0x00007f4657d6655b in QThreadPrivate::start (arg=0x873a40) at thread/qthread_unix.cpp:298
#14 0x00007f465675bf05 in start_thread () from /lib64/libpthread.so.0
#15 0x00007f4656a4c10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4659447760 (LWP 2633)):
#0  0x00007f4656a45803 in select () from /lib64/libc.so.6
#1  0x00007f4657e8f7bf in qt_safe_select (nfds=5, fdread=0x7fff46ed1bc0, fdwrite=0x7fff46ed1c40, fdexcept=0x0, orig_timeout=0x7fff46ed1cc0) at kernel/qcore_unix.cpp:93
#2  0x00007f46564e0330 in QNativeSocketEnginePrivate::nativeSelect (this=0x87f750, timeout=<optimized out>, checkRead=<optimized out>, checkWrite=<optimized out>, selectForRead=0x7fff46ed1d6e, selectForWrite=0x7fff46ed1d6f) at socket/qnativesocketengine_unix.cpp:1115
#3  0x00007f46564de378 in QNativeSocketEngine::waitForReadOrWrite (this=<optimized out>, readyToRead=0x7fff46ed1d6e, readyToWrite=0x7fff46ed1d6f, checkRead=true, checkWrite=<optimized out>, msecs=600000, timedOut=0x0) at socket/qnativesocketengine.cpp:1000
#4  0x00007f46564d65e5 in QAbstractSocket::waitForReadyRead (this=0x87ae28, msecs=600000) at socket/qabstractsocket.cpp:1888
#5  0x00007f4653adccf8 in ?? () from /usr/lib64/libsopranoclient.so.1
#6  0x00007f4653ade803 in ?? () from /usr/lib64/libsopranoclient.so.1
#7  0x00007f4658495d6c in Nepomuk::MainModel::executeQuery (this=0x84e010, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/nepomukmainmodel.cpp:212
#8  0x00007f46584add33 in Nepomuk::Types::EntityPrivate::load (this=0x882270) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/entity.cpp:76
#9  0x00007f46584b193d in Nepomuk::Types::ClassPrivate::load (this=0x882270) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:54
#10 0x00007f46584accc9 in Nepomuk::Types::EntityPrivate::init (this=0x882270) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/entity.cpp:51
#11 0x00007f46584b2a72 in Nepomuk::Types::Class::isSubClassOf (this=<optimized out>, other=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:493
#12 0x00007f465848011f in Nepomuk::ResourceData::constHasType (this=0x87f080, uri=<optimized out>) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:255
#13 0x00007f4658482468 in Nepomuk::ResourceData::load (this=0x87f080) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:438
#14 0x00007f4658482c9c in Nepomuk::ResourceData::property (this=0x87f080, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:265
#15 0x00007f4658498f03 in Nepomuk::Resource::property (this=0x7fff46ed28d0, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resource.cpp:301
#16 0x00007f465849900c in Nepomuk::Resource::symbols (this=0x7fff46ed28d0) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resource.cpp:841
#17 0x0000000000408a97 in ?? ()
#18 0x0000000000415dc1 in ?? ()
#19 0x0000000000416286 in ?? ()
#20 0x000000000041662b in ?? ()
#21 0x00007f46581dff6b in QDBusConnectionPrivate::deliverCall (this=0x6443b0, object=0x85dae0, msg=..., metaTypes=..., slotIdx=12) at qdbusintegrator.cpp:947
#22 0x00007f46581e113d in QDBusConnectionPrivate::activateCall (this=0x6443b0, object=0x85dae0, flags=273, msg=...) at qdbusintegrator.cpp:857
#23 0x00007f46581e1a9b in QDBusConnectionPrivate::activateObject (this=0x6443b0, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#24 0x00007f46581e1b8b in QDBusActivateObjectEvent::placeMetaCall (this=0x7d9380) at qdbusintegrator.cpp:1537
#25 0x00007f4657e7c926 in QObject::event (this=0x7fff46ed38b0, e=<optimized out>) at kernel/qobject.cpp:1204
#26 0x00007f46571ecd84 in QApplication::event (this=0x7fff46ed38b0, e=0x7d9380) at kernel/qapplication.cpp:2532
#27 0x00007f46571e8e84 in notify_helper (e=0x7d9380, receiver=0x7fff46ed38b0, this=0x663d20) at kernel/qapplication.cpp:4550
#28 QApplicationPrivate::notify_helper (this=0x663d20, receiver=0x7fff46ed38b0, e=0x7d9380) at kernel/qapplication.cpp:4522
#29 0x00007f46571edd03 in QApplication::notify (this=0x7fff46ed38b0, receiver=0x7fff46ed38b0, e=0x7d9380) at kernel/qapplication.cpp:4411
#30 0x00007f4658960656 in KApplication::notify (this=0x7fff46ed38b0, receiver=0x7fff46ed38b0, event=0x7d9380) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#31 0x00007f4657e6389c in QCoreApplication::notifyInternal (this=0x7fff46ed38b0, receiver=0x7fff46ed38b0, event=0x7d9380) at kernel/qcoreapplication.cpp:876
#32 0x00007f4657e6713a in sendEvent (event=0x7d9380, receiver=0x7fff46ed38b0) at kernel/qcoreapplication.h:231
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6293d0) at kernel/qcoreapplication.cpp:1500
#34 0x00007f4657e924c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#35 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#36 0x00007f4652da858d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f4652da8d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f4652da8f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#39 0x00007f4657e928ef in QEventDispatcherGlib::processEvents (this=0x6290b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007f465728c2de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f4657e62682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f4657e628d7 in QEventLoop::exec (this=0x7fff46ed3840, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007f4657e67435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#44 0x0000000000406094 in ?? ()
#45 0x00007f465699223d in __libc_start_main () from /lib64/libc.so.6
#46 0x00000000004060e9 in _start ()

Possible duplicates by query: bug 294730, bug 293376.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-29 15:30:40 UTC

*** This bug has been marked as a duplicate of bug 290234 ***