Bug 296685 - Amarok crashes on startup
Summary: Amarok crashes on startup
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 16:15 UTC by nightwing666
Modified: 2012-03-26 06:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nightwing666 2012-03-24 16:15:52 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Amarok crashes on startup(kubuntu 11.10)
Removing .kde/share/config/amarokrc helps

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0758a1e7c0 (LWP 20547))]

Thread 8 (Thread 0x7f0743a8f700 (LWP 20559)):
#0  0x00007f075338d034 in __pthread_mutex_lock (mutex=0x1fad398) at pthread_mutex_lock.c:61
#1  0x0000003941c43e5d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x0000003941c44dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x0000003941c45429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f075628bc06 in QEventDispatcherGlib::processEvents (this=0x1fad150, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f075625b3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f075625b637 in QEventLoop::exec (this=0x7f0743a8ecd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f075615b067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f075623b17f in QInotifyFileSystemWatcherEngine::run (this=0x1f905d0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f075615e08b in QThreadPrivate::start (arg=0x1f905d0) at thread/qthread_unix.cpp:298
#10 0x00007f075066356c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007f075338aefc in start_thread (arg=0x7f0743a8f700) at pthread_create.c:304
#12 0x00007f0755e2459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f0740d64700 (LWP 20568)):
#0  0x00007fff597ff92c in clock_gettime ()
#1  0x00007f07526aa07b in __GI_clock_gettime (clock_id=1, tp=0x7f0740d63a40) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f07561b4724 in do_gettime (frac=0x7f0740d63a58, sec=0x7f0740d63a50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f075628c36d in QTimerInfoList::updateCurrentTime (this=0x2711fd0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f075628c6a3 in QTimerInfoList::timerWait (this=0x2711fd0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f075628b0dc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f0740d63b3c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f075628b185 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x0000003941c43ff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x0000003941c44dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x0000003941c45429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f075628bc06 in QEventDispatcherGlib::processEvents (this=0x271fbf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f075625b3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f075625b637 in QEventLoop::exec (this=0x7f0740d63cd0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f075615b067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f075623b17f in QInotifyFileSystemWatcherEngine::run (this=0x2730170) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f075615e08b in QThreadPrivate::start (arg=0x2730170) at thread/qthread_unix.cpp:298
#17 0x00007f075066356c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#18 0x00007f075338aefc in start_thread (arg=0x7f0740d64700) at pthread_create.c:304
#19 0x00007f0755e2459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f074013b700 (LWP 20569)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f075615e59b in wait (time=18446744073709551615, this=0x282e760) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x282e8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f07546aa864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x282e580, th=0x282ece0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f07546ace0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x282ece0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f07546abccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f074013ad20, parent=0x282e580, th=0x282ece0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f07546abd5b in ThreadWeaver::Thread::run (this=0x282ece0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f075615e08b in QThreadPrivate::start (arg=0x282ece0) at thread/qthread_unix.cpp:298
#8  0x00007f075066356c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f075338aefc in start_thread (arg=0x7f074013b700) at pthread_create.c:304
#10 0x00007f0755e2459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f073f93a700 (LWP 20570)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f075615e59b in wait (time=18446744073709551615, this=0x282e760) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x282e8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f07546aa864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x282e580, th=0x282cb00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f07546ace0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x282cb00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f07546abccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f073f939d20, parent=0x282e580, th=0x282cb00) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f07546abd5b in ThreadWeaver::Thread::run (this=0x282cb00) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f075615e08b in QThreadPrivate::start (arg=0x282cb00) at thread/qthread_unix.cpp:298
#8  0x00007f075066356c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f075338aefc in start_thread (arg=0x7f073f93a700) at pthread_create.c:304
#10 0x00007f0755e2459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f073f139700 (LWP 20571)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f075615e59b in wait (time=18446744073709551615, this=0x282e760) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x282e8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f07546aa864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x282e580, th=0x282d5f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f07546ace0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x282d5f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f07546abccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f073f138d20, parent=0x282e580, th=0x282d5f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f07546abd5b in ThreadWeaver::Thread::run (this=0x282d5f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f075615e08b in QThreadPrivate::start (arg=0x282d5f0) at thread/qthread_unix.cpp:298
#8  0x00007f075066356c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f075338aefc in start_thread (arg=0x7f073f139700) at pthread_create.c:304
#10 0x00007f0755e2459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f073e509700 (LWP 20572)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f075615e59b in wait (time=18446744073709551615, this=0x282e760) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x282e8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f07546aa864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x282e580, th=0x27d1290) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f07546ace0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#9  0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#10 0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#12 0x00007f07546ace24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x282f620, th=0x27d1290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#13 0x00007f07546abccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f073e508d20, parent=0x282e580, th=0x27d1290) at ../../../threadweaver/Weaver/Thread.cpp:87
#14 0x00007f07546abd5b in ThreadWeaver::Thread::run (this=0x27d1290) at ../../../threadweaver/Weaver/Thread.cpp:142
#15 0x00007f075615e08b in QThreadPrivate::start (arg=0x27d1290) at thread/qthread_unix.cpp:298
#16 0x00007f075066356c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#17 0x00007f075338aefc in start_thread (arg=0x7f073e509700) at pthread_create.c:304
#18 0x00007f0755e2459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f073c867700 (LWP 20575)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0753966042 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f0753966079 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f075066356c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f075338aefc in start_thread (arg=0x7f073c867700) at pthread_create.c:304
#5  0x00007f0755e2459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0758a1e7c0 (LWP 20547)):
[KCrash Handler]
#6  Context::ContextView::addCollapseAnimation (this=0x276a730, anim=0x2c6e700) at ../../src/context/ContextView.cpp:245
#7  0x00007f075791d3be in Context::Applet::collapse (this=0x2992680, on=<optimized out>) at ../../src/context/Applet.cpp:321
#8  0x00007f073d2b06e3 in Albums::dataUpdated (this=0x2992680, data=<optimized out>, name=<optimized out>) at ../../../../../src/context/applets/albums/Albums.cpp:157
#9  0x00007f073d2b1bf9 in Albums::dataUpdated (this=0x2992680, name=<optimized out>, data=...) at ../../../../../src/context/applets/albums/Albums.cpp:132
#10 0x00007f073d2b1f16 in Albums::qt_metacall (this=0x2992680, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff597eadf0) at ./Albums.moc:89
#11 0x00007f0756270be9 in QMetaObject::activate (sender=0x293e030, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff597eadf0) at kernel/qobject.cpp:3566
#12 0x00007f0753d8cf47 in Plasma::DataContainer::dataUpdated (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>) at ./datacontainer.moc:112
#13 0x00007f0753d8d46e in Plasma::DataContainer::checkForUpdate (this=0x293e030) at ../../plasma/datacontainer.cpp:295
#14 0x00007f0753d8ed9f in timerEvent (this=<optimized out>, event=<optimized out>) at ../../plasma/dataengine.cpp:387
#15 Plasma::DataEngine::timerEvent (this=<optimized out>, event=<optimized out>) at ../../plasma/dataengine.cpp:362
#16 0x00007f07562758d9 in QObject::event (this=0x282f6c0, e=<optimized out>) at kernel/qobject.cpp:1157
#17 0x00007f0756c50104 in notify_helper (e=0x7fff597eb530, receiver=0x282f6c0, this=0x14d70a0) at kernel/qapplication.cpp:4555
#18 QApplicationPrivate::notify_helper (this=0x14d70a0, receiver=0x282f6c0, e=0x7fff597eb530) at kernel/qapplication.cpp:4527
#19 0x00007f0756c54f83 in QApplication::notify (this=0x7fff597eb830, receiver=0x282f6c0, e=0x7fff597eb530) at kernel/qapplication.cpp:4416
#20 0x00007f07584249a6 in KApplication::notify (this=0x7fff597eb830, receiver=0x282f6c0, event=0x7fff597eb530) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007f075625c5fc in QCoreApplication::notifyInternal (this=0x7fff597eb830, receiver=0x282f6c0, event=0x7fff597eb530) at kernel/qcoreapplication.cpp:876
#22 0x00007f075628d9a2 in sendEvent (event=0x7fff597eb530, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QTimerInfoList::activateTimers (this=0x14a6c90) at kernel/qeventdispatcher_unix.cpp:611
#24 0x00007f075628b36d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#25 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#26 0x0000003941c44a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x0000003941c45258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x0000003941c45429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f075628bb9f in QEventDispatcherGlib::processEvents (this=0x12d3ad0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007f0756cf521e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f075625b3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f075625b637 in QEventLoop::exec (this=0x7fff597eb7c0, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007f07562606c7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#34 0x0000000000408e2e in main (argc=1, argv=0x7fff597edcb8) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 258741.

Possible duplicates by query: bug 293837, bug 293212, bug 292191, bug 291971, bug 290254.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-03-26 06:21:23 UTC
Please remove the ContextView animation line from the $HOME/.kde/share/config/amarokrc. This is a workaround.

*** This bug has been marked as a duplicate of bug 258741 ***