Bug 292191 - Amarok 2.5.0 crashes on startup
Summary: Amarok 2.5.0 crashes on startup
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 13:44 UTC by Gunter Ohrner
Modified: 2012-01-24 14:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gunter Ohrner 2012-01-22 13:44:22 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I started Amarok 2.5.0. I was able to start and use it twice, but now Amarok just crashes when trying to start, even before the main window appears.

The installed Amarok 2.5.0 was taken from the Kubuntu Backports PPA.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f20319e17a0 (LWP 15092))]

Thread 11 (Thread 0x7f2011a4e700 (LWP 15095)):
#0  0x00007f202e324773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f20266f403f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f20266e545c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f20266e5ac9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f20266e5b80 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f20266f3fef in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f2021db3c78 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.0.so
#7  0x00007f202ab2eefc in start_thread (arg=0x7f2011a4e700) at pthread_create.c:304
#8  0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f200f782700 (LWP 15097)):
#0  0x00007f2029088fad in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2029089dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f202908a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f202eca2f3e in QEventDispatcherGlib::processEvents (this=0x1599250, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f202ec76cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f202ec76ef7 in QEventLoop::exec (this=0x7f200f781db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f202eb8e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f202ec59cbf in QInotifyFileSystemWatcherEngine::run (this=0x1569d60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f202eb90d05 in QThreadPrivate::start (arg=0x1569d60) at thread/qthread_unix.cpp:331
#9  0x00007f202ab2eefc in start_thread (arg=0x7f200f782700) at pthread_create.c:304
#10 0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f2003fff700 (LWP 15098)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f202eb911ab in wait (time=18446744073709551615, this=0x15c2160) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x16e3340, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f202c0c1864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x16e2fc0, th=0x16e3770) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f202c0c3e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1613f50, th=0x16e3770) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f202c0c3e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1613f50, th=0x16e3770) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f202c0c2ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f2003ffee00, parent=0x16e2fc0, th=0x16e3770) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f202c0c2d5b in ThreadWeaver::Thread::run (this=0x16e3770) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f202eb90d05 in QThreadPrivate::start (arg=0x16e3770) at thread/qthread_unix.cpp:331
#9  0x00007f202ab2eefc in start_thread (arg=0x7f2003fff700) at pthread_create.c:304
#10 0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f20037fe700 (LWP 15099)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f202eb911ab in wait (time=18446744073709551615, this=0x15c2160) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x16e3340, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f202c0c1864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x16e2fc0, th=0x178e050) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f202c0c3e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1613f50, th=0x178e050) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f202c0c3e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1613f50, th=0x178e050) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f202c0c2ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f20037fde00, parent=0x16e2fc0, th=0x178e050) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f202c0c2d5b in ThreadWeaver::Thread::run (this=0x178e050) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f202eb90d05 in QThreadPrivate::start (arg=0x178e050) at thread/qthread_unix.cpp:331
#9  0x00007f202ab2eefc in start_thread (arg=0x7f20037fe700) at pthread_create.c:304
#10 0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f2000fc9700 (LWP 15100)):
#0  0x00007f2029088fe4 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2029089dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f202908a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f202eca2f3e in QEventDispatcherGlib::processEvents (this=0x18e9b50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f202ec76cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f202ec76ef7 in QEventLoop::exec (this=0x7f2000fc8db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f202eb8e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f202ec59cbf in QInotifyFileSystemWatcherEngine::run (this=0x18e5310) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f202eb90d05 in QThreadPrivate::start (arg=0x18e5310) at thread/qthread_unix.cpp:331
#9  0x00007f202ab2eefc in start_thread (arg=0x7f2000fc9700) at pthread_create.c:304
#10 0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f20003a0700 (LWP 15101)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f202eb911ab in wait (time=18446744073709551615, this=0x15c2160) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x16e3340, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f202c0c1864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x16e2fc0, th=0x18bada0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f202c0c3e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1613f50, th=0x18bada0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f202c0c3e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1613f50, th=0x18bada0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f202c0c2ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f200039fe00, parent=0x16e2fc0, th=0x18bada0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f202c0c2d5b in ThreadWeaver::Thread::run (this=0x18bada0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f202eb90d05 in QThreadPrivate::start (arg=0x18bada0) at thread/qthread_unix.cpp:331
#9  0x00007f202ab2eefc in start_thread (arg=0x7f20003a0700) at pthread_create.c:304
#10 0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f1fffb9f700 (LWP 15102)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f202eb911ab in wait (time=18446744073709551615, this=0x15c2160) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x16e3340, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f202c0c1864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x16e2fc0, th=0x196f7d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f202c0c3e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1613f50, th=0x196f7d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f202c0c2ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f1fffb9ee00, parent=0x16e2fc0, th=0x196f7d0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f202c0c2d5b in ThreadWeaver::Thread::run (this=0x196f7d0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f202eb90d05 in QThreadPrivate::start (arg=0x196f7d0) at thread/qthread_unix.cpp:331
#8  0x00007f202ab2eefc in start_thread (arg=0x7f1fffb9f700) at pthread_create.c:304
#9  0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f1ffeb37700 (LWP 15103)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2025ae4c2c in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f202649b220) at wtf/FastMalloc.cpp:2495
#2  0x00007f2025ae4d59 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f202ab2eefc in start_thread (arg=0x7f1ffeb37700) at pthread_create.c:304
#4  0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1ffe236700 (LWP 15104)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f1ffe235b20 in ?? ()
#2  0x00007fff5e35c7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f1ffbf6f700 (LWP 15107)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f202b10afe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f202b10b019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f202ab2eefc in start_thread (arg=0x7f1ffbf6f700) at pthread_create.c:304
#4  0x00007f202e33089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f20319e17a0 (LWP 15092)):
[KCrash Handler]
#6  QAbstractAnimation::state (this=0x61) at animation/qabstractanimation.cpp:510
#7  0x00007f20306637fa in Context::ContextView::addCollapseAnimation (this=0x190c6b0, anim=0x1d0de60) at ../../src/context/ContextView.cpp:245
#8  0x00007f20306603be in Context::Applet::collapse (this=0x199dda0, on=<optimized out>) at ../../src/context/Applet.cpp:321
#9  0x00007f1ffed6a6e3 in Albums::dataUpdated (this=0x199dda0, data=<optimized out>, name=<optimized out>) at ../../../../../src/context/applets/albums/Albums.cpp:157
#10 0x00007f1ffed6bbf9 in Albums::dataUpdated (this=0x199dda0, name=<optimized out>, data=...) at ../../../../../src/context/applets/albums/Albums.cpp:132
#11 0x00007f1ffed6bf16 in Albums::qt_metacall (this=0x199dda0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5e2950d0) at ./Albums.moc:89
#12 0x00007f202ec8aeba in QMetaObject::activate (sender=0x198a770, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5e2950d0) at kernel/qobject.cpp:3278
#13 0x00007f202b531337 in Plasma::DataContainer::dataUpdated (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>) at ./datacontainer.moc:112
#14 0x00007f202b53185e in Plasma::DataContainer::checkForUpdate (this=0x198a770) at ../../plasma/datacontainer.cpp:295
#15 0x00007f202b53318f in timerEvent (this=<optimized out>, event=<optimized out>) at ../../plasma/dataengine.cpp:387
#16 Plasma::DataEngine::timerEvent (this=<optimized out>, event=<optimized out>) at ../../plasma/dataengine.cpp:362
#17 0x00007f202ec8e789 in QObject::event (this=0x19fb710, e=<optimized out>) at kernel/qobject.cpp:1181
#18 0x00007f202f678424 in notify_helper (e=0x7fff5e295670, receiver=0x19fb710, this=0xebc4c0) at kernel/qapplication.cpp:4486
#19 QApplicationPrivate::notify_helper (this=0xebc4c0, receiver=0x19fb710, e=0x7fff5e295670) at kernel/qapplication.cpp:4458
#20 0x00007f202f67d291 in QApplication::notify (this=0x7fff5e295970, receiver=0x19fb710, e=0x7fff5e295670) at kernel/qapplication.cpp:4365
#21 0x00007f20313eb466 in KApplication::notify (this=0x7fff5e295970, receiver=0x19fb710, event=0x7fff5e295670) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007f202ec77afc in QCoreApplication::notifyInternal (this=0x7fff5e295970, receiver=0x19fb710, event=0x7fff5e295670) at kernel/qcoreapplication.cpp:787
#23 0x00007f202eca4d62 in sendEvent (event=0x7fff5e295670, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#24 QTimerInfoList::activateTimers (this=0xea06f0) at kernel/qeventdispatcher_unix.cpp:603
#25 0x00007f202eca2514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#26 0x00007f2029089a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f202908a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f202908a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f202eca2ed6 in QEventDispatcherGlib::processEvents (this=0xd18f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007f202f72007e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f202ec76cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f202ec76ef7 in QEventLoop::exec (this=0x7fff5e295900, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007f202ec7b789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#34 0x0000000000408e2e in main (argc=1, argv=0x7fff5e297df8) at ../../src/main.cpp:303

Reported using DrKonqi
Comment 1 Gunter Ohrner 2012-01-22 15:14:44 UTC
I could start Amarok again after removing the embedded MySQL database and rebuilding the whole collection. :-/
Comment 2 Myriam Schweingruber 2012-01-24 14:51:57 UTC
That was not needed, simply removing the configuration files would have been enough.

*** This bug has been marked as a duplicate of bug 258741 ***