Bug 296288 - Amarok crashes when ripping a CD
Summary: Amarok crashes when ripping a CD
Status: RESOLVED DUPLICATE of bug 256585
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-18 17:28 UTC by Autopilot
Modified: 2012-03-19 09:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Autopilot 2012-03-18 17:28:57 UTC
Application: amarok (2.4.3)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Put in music CD and selected "copy to local library" in OGG Vorbis format.  Amarok froze and gave no indication that it had crashed.-

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4e1de0b760 (LWP 3073))]

Thread 10 (Thread 0x7f4dff40c700 (LWP 3294)):
#0  0x00007f4e1a769423 in poll () from /lib64/libc.so.6
#1  0x00007f4e120a720f in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007f4e1209861c in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007f4e12098c89 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007f4e12098d40 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007f4e120a71bf in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007f4e0d908248 in ?? () from /usr/lib64/libpulsecommon-1.1.so
#7  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f4df496d700 (LWP 3377)):
#0  0x00007f4e1a769423 in poll () from /lib64/libc.so.6
#1  0x00007f4e14437a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f4e14437f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f4e1bd74576 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f4e1bd48a22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f4e1bd48c1f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f4e1bc605df in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f4e1bd2baef in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f4e1bc63025 in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f4df2641700 (LWP 3519)):
#0  0x00007f4e1a769423 in poll () from /lib64/libc.so.6
#1  0x00007f4e14437a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f4e14437f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f4e1bd74576 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f4e1bd48a22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f4e1bd48c1f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f4e1bc605df in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f4e1bc63025 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f4df0fc5700 (LWP 3530)):
#0  0x00007f4e188d8e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4e1bc634bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f4e17cc0104 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xd6db90, th=0xdf61c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WeaverImpl.cpp:365
#3  0x00007f4e17cc26ab in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0xdf61c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:71
#4  0x00007f4e17cc156f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4df0fc4e40, parent=0xd6db90, th=0xdf61c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:87
#5  0x00007f4e17cc15fb in ThreadWeaver::Thread::run (this=0xdf61c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:142
#6  0x00007f4e1bc63025 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f4defc33700 (LWP 3541)):
#0  0x00007f4e188d8e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4e1bc634bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f4e17cc0104 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xd6db90, th=0x11ba3e0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WeaverImpl.cpp:365
#3  0x00007f4e17cc26ab in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11ba3e0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:71
#4  0x00007f4e17cc156f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4defc32e40, parent=0xd6db90, th=0x11ba3e0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:87
#5  0x00007f4e17cc15fb in ThreadWeaver::Thread::run (this=0x11ba3e0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:142
#6  0x00007f4e1bc63025 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f4def432700 (LWP 3542)):
#0  0x00007f4e188d8e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4e1bc634bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f4e17cc0104 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xd6db90, th=0x11bca00) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WeaverImpl.cpp:365
#3  0x00007f4e17cc26ab in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11bca00) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:71
#4  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11bca00) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#5  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11bca00) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f4e17cc156f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4def431e40, parent=0xd6db90, th=0x11bca00) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f4e17cc15fb in ThreadWeaver::Thread::run (this=0x11bca00) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f4e1bc63025 in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f4deea26700 (LWP 3547)):
#0  0x00007f4e188d8e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4e1bc634bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f4e17cc0104 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xd6db90, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WeaverImpl.cpp:365
#3  0x00007f4e17cc26ab in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:71
#4  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#5  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#9  0x00007f4e17cc26c4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xdc01f0, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/WorkingHardState.cpp:74
#10 0x00007f4e17cc156f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4deea25e40, parent=0xd6db90, th=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:87
#11 0x00007f4e17cc15fb in ThreadWeaver::Thread::run (this=0x11820c0) at /usr/src/debug/kdelibs-4.7.2/threadweaver/Weaver/Thread.cpp:142
#12 0x00007f4e1bc63025 in ?? () from /usr/lib64/libQtCore.so.4
#13 0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#14 0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f4dedbe3700 (LWP 3616)):
#0  0x00007f4e188d8e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4e112779dc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f4e11277b09 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f4dec8cc700 (LWP 3734)):
#0  0x00007f4e188d8e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4e16ce2852 in ?? () from /usr/lib64/libQtScript.so.4
#2  0x00007f4e16ce2889 in ?? () from /usr/lib64/libQtScript.so.4
#3  0x00007f4e188d4f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f4e1a77253d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4e1de0b760 (LWP 3073)):
[KCrash Handler]
#6  0x00007f4e1bca1021 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f4e1bca8382 in QString::split(QChar const&, QString::SplitBehavior, Qt::CaseSensitivity) const () from /usr/lib64/libQtCore.so.4
#8  0x00007f4dfe35f1ed in ?? () from /usr/lib64/kde4/amarok_collection-audiocdcollection.so
#9  0x00007f4dfe36128d in ?? () from /usr/lib64/kde4/amarok_collection-audiocdcollection.so
#10 0x00007f4dfe363b1c in ?? () from /usr/lib64/kde4/amarok_collection-audiocdcollection.so
#11 0x00007f4e1bd5c59a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#12 0x00007f4e1c1b75e2 in KJob::result (this=<optimized out>, _t1=0x1435b30) at /usr/src/debug/kdelibs-4.7.2/build/kdecore/kjob.moc:194
#13 0x00007f4e1c1b7620 in KJob::emitResult (this=0x1435b30) at /usr/src/debug/kdelibs-4.7.2/kdecore/jobs/kjob.cpp:312
#14 0x00007f4e182aff24 in KIO::SimpleJob::slotFinished (this=0x1435b30) at /usr/src/debug/kdelibs-4.7.2/kio/kio/job.cpp:494
#15 0x00007f4e182b78fd in KIO::TransferJob::slotFinished (this=0x1435b30) at /usr/src/debug/kdelibs-4.7.2/kio/kio/job.cpp:1081
#16 0x00007f4e182b6261 in KIO::TransferJob::qt_metacall (this=0x1435b30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff89cdc630) at /usr/src/debug/kdelibs-4.7.2/build/kio/jobclasses.moc:369
#17 0x00007f4e182b6530 in KIO::StoredTransferJob::qt_metacall (this=0x1435b30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff89cdc630) at /usr/src/debug/kdelibs-4.7.2/build/kio/jobclasses.moc:480
#18 0x00007f4e1bd5c59a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#19 0x00007f4e1835d091 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at /usr/src/debug/kdelibs-4.7.2/kio/kio/slaveinterface.cpp:172
#20 0x00007f4e18359f45 in KIO::SlaveInterface::dispatch (this=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kio/kio/slaveinterface.cpp:88
#21 0x00007f4e1834d0fe in KIO::Slave::gotInput (this=0xd88ba0) at /usr/src/debug/kdelibs-4.7.2/kio/kio/slave.cpp:344
#22 0x00007f4e1834d85c in KIO::Slave::qt_metacall (this=0xd88ba0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff89cdca60) at /usr/src/debug/kdelibs-4.7.2/build/kio/slave.moc:82
#23 0x00007f4e1bd5c59a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#24 0x00007f4e182809b7 in dequeue (this=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kio/kio/connection.cpp:82
#25 KIO::ConnectionPrivate::dequeue (this=0x14a38e0) at /usr/src/debug/kdelibs-4.7.2/kio/kio/connection.cpp:71
#26 0x00007f4e18280a5d in KIO::Connection::qt_metacall (this=0x187b5b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x19c25e0) at /usr/src/debug/kdelibs-4.7.2/build/kio/connection.moc:79
#27 0x00007f4e1bd6014a in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007f4e1b118be4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#29 0x00007f4e1b11da71 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x00007f4e1d803e36 in KApplication::notify (this=0x7fff89cdd4b0, receiver=0x187b5b0, event=0x19ab520) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#31 0x00007f4e1bd4981c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#32 0x00007f4e1bd4cbf8 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#33 0x00007f4e1bd740b3 in ?? () from /usr/lib64/libQtCore.so.4
#34 0x00007f4e1443758d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f4e14437d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f4e14437f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f4e1bd7450f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007f4e1b1bbf2e in ?? () from /usr/lib64/libQtGui.so.4
#39 0x00007f4e1bd48a22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#40 0x00007f4e1bd48c1f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f4e1bd4cde7 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#42 0x00000000004093ce in ?? ()
#43 0x00007f4e1a6ba23d in __libc_start_main () from /lib64/libc.so.6
#44 0x000000000040bf9d in _start ()

Possible duplicates by query: bug 290542.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-03-19 09:46:46 UTC

*** This bug has been marked as a duplicate of bug 256585 ***