Bug 290542 - Amarok crashes after trying to open audio CD
Summary: Amarok crashes after trying to open audio CD
Status: RESOLVED DUPLICATE of bug 256585
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-03 22:48 UTC by Nick
Modified: 2012-01-03 22:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2012-01-03 22:48:31 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Using the device notifier widget I tried to open an audio CD through one of the options using Amarok. Amarok starts, the window opens but then immediately crashes.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ffc300987a0 (LWP 3880))]

Thread 10 (Thread 0x7ffc108d8700 (LWP 3887)):
#0  0x00007ffc2c9d2773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffc24da203f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007ffc24d9345c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007ffc24d93ac9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007ffc24d93b80 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007ffc24da1fef in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007ffc20461c78 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.0.so
#7  0x00007ffc291dcefc in start_thread (arg=0x7ffc108d8700) at pthread_create.c:304
#8  0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7ffc0cb4d700 (LWP 3889)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007ffc0cb4cad0 in ?? ()
#2  0x00007fff9f9fa7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 8 (Thread 0x7ffc03a15700 (LWP 3891)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffc2d23f1ab in wait (time=18446744073709551615, this=0x2080260) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2080480, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ffc2a76f864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x20800d0, th=0x1fa8350) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ffc2a771e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x207e470, th=0x1fa8350) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ffc2a771e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x207e470, th=0x1fa8350) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007ffc2a770ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7ffc03a14e00, parent=0x20800d0, th=0x1fa8350) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007ffc2a770d5b in ThreadWeaver::Thread::run (this=0x1fa8350) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007ffc2d23ed05 in QThreadPrivate::start (arg=0x1fa8350) at thread/qthread_unix.cpp:331
#9  0x00007ffc291dcefc in start_thread (arg=0x7ffc03a15700) at pthread_create.c:304
#10 0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7ffc03214700 (LWP 3892)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffc2d23f1ab in wait (time=18446744073709551615, this=0x2080260) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2080480, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ffc2a76f864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x20800d0, th=0x7ffbfc0009a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ffc2a771e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x207e470, th=0x7ffbfc0009a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ffc2a770ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7ffc03213e00, parent=0x20800d0, th=0x7ffbfc0009a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ffc2a770d5b in ThreadWeaver::Thread::run (this=0x7ffbfc0009a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ffc2d23ed05 in QThreadPrivate::start (arg=0x7ffbfc0009a0) at thread/qthread_unix.cpp:331
#8  0x00007ffc291dcefc in start_thread (arg=0x7ffc03214700) at pthread_create.c:304
#9  0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ffc02a13700 (LWP 3893)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffc2d23f1ab in wait (time=18446744073709551615, this=0x2080260) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2080480, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ffc2a76f864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x20800d0, th=0x7ffbfc001a40) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ffc2a771e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x207e470, th=0x7ffbfc001a40) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ffc2a770ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7ffc02a12e00, parent=0x20800d0, th=0x7ffbfc001a40) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ffc2a770d5b in ThreadWeaver::Thread::run (this=0x7ffbfc001a40) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ffc2d23ed05 in QThreadPrivate::start (arg=0x7ffbfc001a40) at thread/qthread_unix.cpp:331
#8  0x00007ffc291dcefc in start_thread (arg=0x7ffc02a13700) at pthread_create.c:304
#9  0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7ffc02212700 (LWP 3894)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffc2d23f1ab in wait (time=18446744073709551615, this=0x2080260) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2080480, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ffc2a76f864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x20800d0, th=0x1faa010) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ffc2a771e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x207e470, th=0x1faa010) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ffc2a770ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7ffc02211e00, parent=0x20800d0, th=0x1faa010) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ffc2a770d5b in ThreadWeaver::Thread::run (this=0x1faa010) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ffc2d23ed05 in QThreadPrivate::start (arg=0x1faa010) at thread/qthread_unix.cpp:331
#8  0x00007ffc291dcefc in start_thread (arg=0x7ffc02212700) at pthread_create.c:304
#9  0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ffc017f4700 (LWP 3895)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffc24192c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007ffc24192d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007ffc291dcefc in start_thread (arg=0x7ffc017f4700) at pthread_create.c:304
#4  0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ffc00ef3700 (LWP 3896)):
#0  0x00007ffc2c9d2773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffc27737f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffc27738429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffc2d350f3e in QEventDispatcherGlib::processEvents (this=0x2017670, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ffc2d324cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ffc2d324ef7 in QEventLoop::exec (this=0x7ffc00ef2de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ffc2d23c27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ffc2d23ed05 in QThreadPrivate::start (arg=0x206ff80) at thread/qthread_unix.cpp:331
#8  0x00007ffc291dcefc in start_thread (arg=0x7ffc00ef3700) at pthread_create.c:304
#9  0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffbfb5e9700 (LWP 3899)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffc297b8fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007ffc297b9019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007ffc291dcefc in start_thread (arg=0x7ffbfb5e9700) at pthread_create.c:304
#4  0x00007ffc2c9de89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffc300987a0 (LWP 3880)):
[KCrash Handler]
#6  findChar (str=0x0, len=751399448, ch=..., from=0, cs=Qt::CaseSensitive) at tools/qstring.cpp:318
#7  0x00007ffc2d284282 in QString::split (this=0x7fff9f8568d0, sep=..., behavior=QString::KeepEmptyParts, cs=Qt::CaseSensitive) at tools/qstring.cpp:6086
#8  0x00007ffc0f594a2d in Collections::AudioCdCollection::updateProxyTracks (this=0x1c68b90) at ../../../../../src/core-impl/collections/audiocd/AudioCdCollection.cpp:576
#9  0x00007ffc0f5967a4 in Collections::AudioCdCollection::noInfoAvailable (this=0x1c68b90) at ../../../../../src/core-impl/collections/audiocd/AudioCdCollection.cpp:496
#10 0x00007ffc0f598bb0 in Collections::AudioCdCollection::infoFetchComplete (this=0x1c68b90, job=0x3217eb0) at ../../../../../src/core-impl/collections/audiocd/AudioCdCollection.cpp:158
#11 0x00007ffc0f59936c in Collections::AudioCdCollection::qt_metacall (this=0x1c68b90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9f8575f0) at ./AudioCdCollection.moc:127
#12 0x00007ffc2d338eba in QMetaObject::activate (sender=0x3217eb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9f8575f0) at kernel/qobject.cpp:3278
#13 0x00007ffc2d78b622 in KJob::result (this=<optimized out>, _t1=0x3217eb0) at ./kjob.moc:194
#14 0x00007ffc2d78b660 in KJob::emitResult (this=0x3217eb0) at ../../kdecore/jobs/kjob.cpp:312
#15 0x00007ffc2ad54d94 in KIO::SimpleJob::slotFinished (this=0x3217eb0) at ../../kio/kio/job.cpp:494
#16 0x00007ffc2ad5c94d in KIO::TransferJob::slotFinished (this=0x3217eb0) at ../../kio/kio/job.cpp:1081
#17 0x00007ffc2ad5b2b1 in KIO::TransferJob::qt_metacall (this=0x3217eb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9f8579d0) at ./jobclasses.moc:369
#18 0x00007ffc2ad5b580 in KIO::StoredTransferJob::qt_metacall (this=0x3217eb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9f8579d0) at ./jobclasses.moc:480
#19 0x00007ffc2d338eba in QMetaObject::activate (sender=0x2f0cb30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#20 0x00007ffc2ae03081 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#21 0x00007ffc2adfff35 in KIO::SlaveInterface::dispatch (this=0x2f0cb30) at ../../kio/kio/slaveinterface.cpp:88
#22 0x00007ffc2adf30fe in KIO::Slave::gotInput (this=0x2f0cb30) at ../../kio/kio/slave.cpp:344
#23 0x00007ffc2adf385c in KIO::Slave::qt_metacall (this=0x2f0cb30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9f857e00) at ./slave.moc:82
#24 0x00007ffc2d338eba in QMetaObject::activate (sender=0x1d9d780, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#25 0x00007ffc2ad25827 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#26 KIO::ConnectionPrivate::dequeue (this=0x2ce3fc0) at ../../kio/kio/connection.cpp:71
#27 0x00007ffc2ad258cd in KIO::Connection::qt_metacall (this=0x1d9d780, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2c03a80) at ./connection.moc:79
#28 0x00007ffc2d33ca5e in QObject::event (this=0x1d9d780, e=<optimized out>) at kernel/qobject.cpp:1217
#29 0x00007ffc2dd26424 in notify_helper (e=0x32539c0, receiver=0x1d9d780, this=0x157a690) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x157a690, receiver=0x1d9d780, e=0x32539c0) at kernel/qapplication.cpp:4458
#31 0x00007ffc2dd2b291 in QApplication::notify (this=0x7fff9f8586b0, receiver=0x1d9d780, e=0x32539c0) at kernel/qapplication.cpp:4365
#32 0x00007ffc2fa99466 in KApplication::notify (this=0x7fff9f8586b0, receiver=0x1d9d780, event=0x32539c0) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007ffc2d325afc in QCoreApplication::notifyInternal (this=0x7fff9f8586b0, receiver=0x1d9d780, event=0x32539c0) at kernel/qcoreapplication.cpp:787
#34 0x00007ffc2d32951f in sendEvent (event=0x32539c0, receiver=0x1d9d780) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x13d0430) at kernel/qcoreapplication.cpp:1428
#36 0x00007ffc2d350a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#37 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#38 0x00007ffc27737a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007ffc27738258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007ffc27738429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007ffc2d350ed6 in QEventDispatcherGlib::processEvents (this=0x13d1f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#42 0x00007ffc2ddce07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007ffc2d324cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007ffc2d324ef7 in QEventLoop::exec (this=0x7fff9f858640, flags=...) at kernel/qeventloop.cpp:201
#45 0x00007ffc2d329789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x0000000000408e2e in main (argc=2, argv=0x7fff9f85ab38) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 263768.

Possible duplicates by query: bug 263768.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-01-03 22:52:26 UTC

*** This bug has been marked as a duplicate of bug 256585 ***