Bug 296085 - Crash after wireless kill swtich deactivated manually
Summary: Crash after wireless kill swtich deactivated manually
Status: RESOLVED DUPLICATE of bug 284052
Alias: None
Product: Network Management
Classification: Unclassified
Component: KDED Module (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-15 17:10 UTC by Xavier Callejas
Modified: 2012-04-18 00:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Callejas 2012-03-15 17:10:04 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.8.1 (4.8.1) "release 481"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I have a Thinkpad T61 running openSUSE 12.1, it has a swtich for turning on/off wireless radio (bluetooth and wifi), every time I turn it off KDE service crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Servicio de KDE (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fdd8f80e760 (LWP 2418))]

Thread 2 (Thread 0x7fdd75ee2700 (LWP 2425)):
#0  0x00007fff5cbff8de in ?? ()
#1  0x00007fdd89e88e91 in clock_gettime () from /lib64/librt.so.1
#2  0x00007fdd8e38ea24 in do_gettime (frac=0x7fdd75ee1b78, sec=0x7fdd75ee1b70) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fdd8e4650bd in QTimerInfoList::updateCurrentTime (this=0x7fdd700020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fdd8e4653f3 in QTimerInfoList::timerWait (this=0x7fdd700020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fdd8e463e2c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fdd75ee1c5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fdd8e463ed5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fdd89bd3b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fdd89bd492d in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fdd89bd4f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fdd8e464956 in QEventDispatcherGlib::processEvents (this=0x7fdd700008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fdd8e434682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fdd8e4348d7 in QEventLoop::exec (this=0x7fdd75ee1df0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fdd8e335537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fdd8e41448f in QInotifyFileSystemWatcherEngine::run (this=0x8960f0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fdd8e33855b in QThreadPrivate::start (arg=0x8960f0) at thread/qthread_unix.cpp:298
#17 0x00007fdd8e0a0f05 in start_thread () from /lib64/libpthread.so.0
#18 0x00007fdd8ce0063d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fdd8f80e760 (LWP 2418)):
[KCrash Handler]
#6  0x00007fdd8e447c90 in QObject::property (this=0x891040, name=0x7fdd8b1c5510 "_qdbus_slotCache") at kernel/qobject.cpp:3750
#7  0x00007fdd8b185d19 in QDBusConnectionPrivate::activateCall (this=0x88b670, object=0x891040, flags=273, msg=...) at qdbusintegrator.cpp:807
#8  0x00007fdd8b186a9b in QDBusConnectionPrivate::activateObject (this=0x88b670, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#9  0x00007fdd8b186b8b in QDBusActivateObjectEvent::placeMetaCall (this=0x7d6e00) at qdbusintegrator.cpp:1537
#10 0x00007fdd8e44e926 in QObject::event (this=0x843130, e=<optimized out>) at kernel/qobject.cpp:1204
#11 0x00007fdd8d59de84 in notify_helper (e=0x7d6e00, receiver=0x843130, this=0x6a05d0) at kernel/qapplication.cpp:4550
#12 QApplicationPrivate::notify_helper (this=0x6a05d0, receiver=0x843130, e=0x7d6e00) at kernel/qapplication.cpp:4522
#13 0x00007fdd8d5a2d03 in QApplication::notify (this=0x7fff5cacf8f0, receiver=0x843130, e=0x7d6e00) at kernel/qapplication.cpp:4411
#14 0x00007fdd8f1f5656 in KApplication::notify (this=0x7fff5cacf8f0, receiver=0x843130, event=0x7d6e00) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#15 0x00007fdd8e43589c in QCoreApplication::notifyInternal (this=0x7fff5cacf8f0, receiver=0x843130, event=0x7d6e00) at kernel/qcoreapplication.cpp:876
#16 0x00007fdd8e43913a in sendEvent (event=0x7d6e00, receiver=0x843130) at kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6153d0) at kernel/qcoreapplication.cpp:1500
#18 0x00007fdd8e4644c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#20 0x00007fdd89bd458d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fdd89bd4d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fdd89bd4f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fdd8e4648ef in QEventDispatcherGlib::processEvents (this=0x616770, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007fdd8d6412de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007fdd8e434682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fdd8e4348d7 in QEventLoop::exec (this=0x7fff5cacf880, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007fdd8e439435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x00007fdd7cd5d495 in kdemain () from /usr/lib64/libkdeinit4_kded4.so
#29 0x00000000004088e4 in _start ()

Possible duplicates by query: bug 293507, bug 291344, bug 284052.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2012-03-15 20:20:38 UTC
This can be a duplicate of #284052
Comment 2 Lamarque V. Souza 2012-04-14 21:29:30 UTC
Which Bluedevil version do you have installed?
Comment 3 Lamarque V. Souza 2012-04-18 00:11:00 UTC

*** This bug has been marked as a duplicate of bug 284052 ***