Bug 295217 - KMail renders GPG error message into mail body
Summary: KMail renders GPG error message into mail body
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: crypto (show other bugs)
Version: 4.9.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-02 15:41 UTC by Elias Probst
Modified: 2013-10-30 00:21 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12


Attachments
Screenshot showing the GPG error message rendered into the mail body (8.91 KB, image/png)
2012-03-02 15:41 UTC, Elias Probst
Details
Screenshot showing the described error message in KDE 4.9.2 (75.20 KB, image/png)
2012-10-29 11:58 UTC, Elias Probst
Details
raw gpg signed mail to test/reproduce issue (3.82 KB, application/mbox)
2012-10-30 18:07 UTC, Elias Probst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2012-03-02 15:41:12 UTC
Created attachment 69241 [details]
Screenshot showing the GPG error message rendered into the mail body

I had issues with GnuPG not being able to connect to a keyserver.
The resulting error message was rendered into the message body of the signed mail instead of being displayed in the header where the signature information is shown or as an separate error dialog box.

See the screenshot.

The raw view of the mail looked correct, so I don't mistake this for an error message already being rendered into the original mail itself.

Using KDE 4.8.0 and GnuPG 2.0.17.
Comment 1 Elias Probst 2012-10-29 11:58:21 UTC
Created attachment 74865 [details]
Screenshot showing the described error message in KDE 4.9.2

It happened again using KDE 4.9.2.

See attached screenshot.
Comment 2 Laurent Montel 2012-10-30 16:00:26 UTC
I need email test example to reproduce it.
Comment 3 Elias Probst 2012-10-30 18:07:39 UTC
Created attachment 74885 [details]
raw gpg signed mail to test/reproduce issue

To reproduce it, any GPG signed message does the job.
I've attached the one I showed in the last screenshot.

To reproduce it, you need a keyserver in your list which cannot be resolved:
→ Open ~/.gnupg/gpg.conf
→ Set the 'keyserver' to 'hkp://test.foo'
→ Open the attached mail
Comment 4 Laurent Montel 2012-10-30 18:34:47 UTC
Ok will look at it.
Regards.
Comment 5 Laurent Montel 2012-10-31 11:15:49 UTC
For the moment I can't reproduce it but continue to investigate.
Comment 6 Allen Winter 2013-03-30 15:42:23 UTC
CC: Sandro
Comment 7 Sandro Knauß 2013-03-30 18:04:05 UTC
This occures, when using inline sined/encrypted messages. Only for inline messages kgpg is used to decrypt the message. The problem is that kgpg uses stdin/stdout for communication to kmail, so every failure etc. will be interpret as output.
Comment 8 Sandro Knauß 2013-10-30 00:21:14 UTC
Git commit 25f0b41941e093071cf9cee624b24f30a71047a1 by Sandro Knauß.
Committed on 15/10/2013 at 16:44.
Pushed by knauss into branch 'master'.

use gpgme instead of kpgp for decrypting PGP Inline messages

REVIEW: 113348
Related: bug 247657, bug 291890
FIXED-IN: 4.12

M  +200  -149  messageviewer/viewer/objecttreeparser.cpp

http://commits.kde.org/kdepim/25f0b41941e093071cf9cee624b24f30a71047a1