Bug 247657 - kwatchgnupg breaks gpg parsing of kmail
Summary: kwatchgnupg breaks gpg parsing of kmail
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: 1.13.5
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-13 16:14 UTC by Thomas Zell
Modified: 2013-10-30 00:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.12


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Zell 2010-08-13 16:14:14 UTC
Version:           1.13.5 (using KDE 4.4.5) 
OS:                Linux

When starting kwatchgnupg it adds a line
log-file socket:///home/user/.gnupg/log-socket
to ~/.gnupg/gpg.conf

This makes gpg print the error message "cannot connect to home/user/.gnupg/log-socket" which in turn confuses kmail when parsing its output.

From then on messages which are inline encrypted with gpg will not have a blue (nor green) frame around them nor any encrypted/signed icons in the message list.

Reproducible: Always

Steps to Reproduce:
1) Start kwatchgnupg
2) Look at message in kmail which is inline encrypted or signed inline.
Comment 1 Thomas Zell 2010-08-13 16:17:53 UTC
The problem persists until I manually delete the log-file line from gpg.conf

Thanks to Raimar Sandner for pointing me to the cause of the problem:
http://homepage.uibk.ac.at/~c705283/archives/2009/05/24/kmail_inline_openpgp_silent_failure/index.html

(am actually using KDE 4.5)
Comment 2 Thomas Zell 2012-01-26 18:51:33 UTC
This still happens with KDE 4.8.0 ...
Comment 3 Thomas Zell 2012-01-26 18:54:32 UTC
*** Bug 291890 has been marked as a duplicate of this bug. ***
Comment 4 quazgar 2012-01-27 19:08:39 UTC
I can confirm this bug (see bug 291890) and the described workaround.
Comment 5 Thomas Zell 2012-04-04 19:12:07 UTC
still exists in kmail2

*** This bug has been marked as a duplicate of bug 291890 ***
Comment 6 Sandro Knauß 2013-10-30 00:21:14 UTC
Git commit 25f0b41941e093071cf9cee624b24f30a71047a1 by Sandro Knauß.
Committed on 15/10/2013 at 16:44.
Pushed by knauss into branch 'master'.

use gpgme instead of kpgp for decrypting PGP Inline messages

REVIEW: 113348
Related: bug 291890, bug 295217
FIXED-IN: 4.12

M  +200  -149  messageviewer/viewer/objecttreeparser.cpp

http://commits.kde.org/kdepim/25f0b41941e093071cf9cee624b24f30a71047a1