Bug 294699 - Amarok closed unexpectedly
Summary: Amarok closed unexpectedly
Status: RESOLVED DUPLICATE of bug 281312
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-23 16:33 UTC by Ivan Ramos
Modified: 2012-02-23 17:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Ramos 2012-02-23 16:33:01 UTC
Application: amarok (2.4.3)
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Teh crash happen after the load of the k desktop. The k window software load slowly. This happen after i leave amorok load in the desktop and turn it off. Today, while i load the k winddows part of the starting software didn't load until the message of amarok telling me. That My SQl did'not allow it.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb60e8720 (LWP 2293))]

Thread 2 (Thread 0xb0a27b70 (LWP 2519)):
[KCrash Handler]
#7  0x0388c42e in DirWatchJob::run (this=0x861a9a0) at ../../../../../../src/core-impl/collections/db/ScanManager.cpp:377
#8  0x00e4c47d in ThreadWeaver::JobRunHelper::runTheJob (this=0xb0a2727c, th=0x8228860, job=0x861a9a0) at ../../../threadweaver/Weaver/Job.cpp:106
#9  0x00e4c5e3 in ThreadWeaver::Job::execute (this=0x861a9a0, th=0x8228860) at ../../../threadweaver/Weaver/Job.cpp:135
#10 0x00e4bae2 in ThreadWeaver::ThreadRunHelper::run (this=0xb0a27304, parent=0x8676b80, th=0x8228860) at ../../../threadweaver/Weaver/Thread.cpp:95
#11 0x00e4bbca in ThreadWeaver::Thread::run (this=0x8228860) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x042fd7b3 in QThreadPrivate::start (arg=0x8228860) at thread/qthread_unix.cpp:331
#13 0x00e5dd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x00ceb0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb60e8720 (LWP 2293)):
#0  0x00eed578 in _fini () from /usr/lib/libamarokcore.so.1
#1  0x00c07dad in ?? () from /lib/ld-linux.so.2
#2  0x00c4b981 in ?? () from /lib/i386-linux-gnu/libc.so.6
#3  0x00c4ba0d in exit () from /lib/i386-linux-gnu/libc.so.6
#4  0x04775e68 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:781
#5  0x00734a39 in KApplication::xioErrhandler (this=0xbf968254, dpy=0x81ddd50) at ../../kdeui/kernel/kapplication.cpp:419
#6  0x00734a74 in kde_xio_errhandler (dpy=0x81ddd50) at ../../kdeui/kernel/kapplication.cpp:126
#7  0x0014ae14 in _XIOError () from /usr/lib/i386-linux-gnu/libX11.so.6
#8  0x0014849f in _XEventsQueued () from /usr/lib/i386-linux-gnu/libX11.so.6
#9  0x00138c88 in XEventsQueued () from /usr/lib/i386-linux-gnu/libX11.so.6
#10 0x047b5c45 in x11EventSourceCheck (s=0x80fe1c0) at kernel/qguieventdispatcher_glib.cpp:85
#11 0x01bb7f24 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#12 0x01bb88f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#13 0x01bb8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#14 0x04426ada in QEventDispatcherGlib::processEvents (this=0x80c9218, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#15 0x047b5e7a in QGuiEventDispatcherGlib::processEvents (this=0x80c9218, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#16 0x043f71dd in QEventLoop::processEvents (this=0xbf9677b0, flags=...) at kernel/qeventloop.cpp:149
#17 0x043f7421 in QEventLoop::exec (this=0xbf9677b0, flags=...) at kernel/qeventloop.cpp:201
#18 0x04c35819 in QDialog::exec (this=0x8618b38) at dialogs/qdialog.cpp:552
#19 0x0068db74 in KMessageBox::createKMessageBox (dialog=0x8618b38, icon=..., text=..., strlist=..., ask=..., checkboxReturn=0x0, options=..., details=..., notifyType=QMessageBox::Critical) at ../../kdeui/dialogs/kmessagebox.cpp:344
#20 0x0068e408 in KMessageBox::createKMessageBox (dialog=0x8618b38, icon=QMessageBox::Critical, text=..., strlist=..., ask=..., checkboxReturn=0x0, options=..., details=...) at ../../kdeui/dialogs/kmessagebox.cpp:159
#21 0x0068f095 in KMessageBox::errorListWId (parent_id=0, text=..., strlist=..., caption=..., options=...) at ../../kdeui/dialogs/kmessagebox.cpp:854
#22 0x0068f2c3 in KMessageBox::error (parent=0x81c70e8, text=..., caption=..., options=...) at ../../kdeui/dialogs/kmessagebox.cpp:821
#23 0x038929f7 in Collections::SqlCollection::SqlCollection (this=0x8617998, id=..., prettyName=..., storage=0x81c87e0) at ../../../../../../src/core-impl/collections/db/sql/SqlCollection.cpp:175
#24 0x03894bbc in Collections::SqlCollectionFactory::createSqlCollection (this=0xbf967c1f, id=..., prettyName=..., storage=0x81c87e0) at ../../../../../../src/core-impl/collections/db/sql/SqlCollectionFactory.cpp:31
#25 0x05c3b8cc in Collections::MySqlServerCollectionFactory::init (this=0x86089e0) at ../../../../../../../src/core-impl/collections/db/sql/mysqlservercollection/MySqlServerCollection.cpp:41
#26 0x012d8167 in CollectionManager::loadPlugins (this=0x8562e48, factories=...) at ../../src/core-impl/collections/support/CollectionManager.cpp:202
#27 0x012dc17d in CollectionManager::init (this=0x8562e48, factories=...) at ../../src/core-impl/collections/support/CollectionManager.cpp:170
#28 0x01453583 in Plugins::PluginManager::init (this=0x81cad18) at ../../src/PluginManager.cpp:82
#29 0x014548a1 in Plugins::PluginManager::PluginManager (this=0x81cad18, parent=0x0) at ../../src/PluginManager.cpp:64
#30 0x01454a7e in Plugins::PluginManager::instance () at ../../src/PluginManager.cpp:43
#31 0x01435724 in pluginManager () at ../../src/PluginManager.h:76
#32 MainWindow::MainWindow (this=0x81c70e8) at ../../src/MainWindow.cpp:139
#33 0x0140ae7e in App::continueInit (this=0xbf968254) at ../../src/App.cpp:542
#34 0x0140c738 in App::App (this=0xbf968254) at ../../src/App.cpp:185
#35 0x0804ffb0 in main (argc=) at ../../src/main.cpp:287

Possible duplicates by query: bug 289891, bug 281312.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-02-23 17:30:47 UTC

*** This bug has been marked as a duplicate of bug 281312 ***