Bug 289891 - Amarok- 2.5 -kein Start möglich
Summary: Amarok- 2.5 -kein Start möglich
Status: RESOLVED DUPLICATE of bug 281312
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-27 00:08 UTC by Uwe
Modified: 2011-12-27 19:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe 2011-12-27 00:08:57 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.7.4 (4.7.4) "release 11"
Qt Version: 4.7.4
Operating System: Linux 3.1.4-1-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Habe Amarok nach update starten wollen, hat sich jedes mal sofort wieder aufgehängt

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff634827760 (LWP 13438))]

Thread 6 (Thread 0x7ff61100a700 (LWP 13447)):
#0  0x00007ff62f2f61eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff61aa10341 in ?? () from /usr/lib64/libxine.so.1
#2  0x00007ff62f2f1f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007ff63118f53d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7ff610809700 (LWP 13448)):
#0  0x00007ff631186423 in poll () from /lib64/libc.so.6
#1  0x00007ff62b064a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff62b064f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff632791576 in QEventDispatcherGlib::processEvents (this=0x7ff60c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff632765a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff632765c1f in QEventLoop::exec (this=0x7ff610808dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff63267d5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ff61ac988c4 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#8  0x00007ff632680025 in QThreadPrivate::start (arg=0x93ec90) at thread/qthread_unix.cpp:331
#9  0x00007ff62f2f1f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff63118f53d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7ff60bdfc700 (LWP 13449)):
#0  0x00007ff62f2f5e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff61aa218d3 in ?? () from /usr/lib64/libxine.so.1
#2  0x00007ff62f2f1f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007ff63118f53d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7ff60b1e6700 (LWP 13450)):
#0  0x00007ff62f2f5e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff61aa218d3 in ?? () from /usr/lib64/libxine.so.1
#2  0x00007ff62f2f1f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007ff63118f53d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff60515b700 (LWP 13686)):
[KCrash Handler]
#6  0x00007ff609adbe4b in DirWatchJob::run (this=0xb3cb40) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/ScanManager.cpp:372
#7  0x00007ff62e6dcd31 in ThreadWeaver::JobRunHelper::runTheJob (this=0x7ff60515adc0, th=0xcd1ea0, job=0xb3cb40) at /usr/src/debug/kdelibs-4.7.4/threadweaver/Weaver/Job.cpp:106
#8  0x00007ff62e6dce5c in ThreadWeaver::Job::execute (this=0xb3cb40, th=0xcd1ea0) at /usr/src/debug/kdelibs-4.7.4/threadweaver/Weaver/Job.cpp:135
#9  0x00007ff62e6dc53f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff60515ae40, parent=0xddd2b0, th=0xcd1ea0) at /usr/src/debug/kdelibs-4.7.4/threadweaver/Weaver/Thread.cpp:95
#10 0x00007ff62e6dc5fb in ThreadWeaver::Thread::run (this=0xcd1ea0) at /usr/src/debug/kdelibs-4.7.4/threadweaver/Weaver/Thread.cpp:142
#11 0x00007ff632680025 in QThreadPrivate::start (arg=0xcd1ea0) at thread/qthread_unix.cpp:331
#12 0x00007ff62f2f1f05 in start_thread () from /lib64/libpthread.so.0
#13 0x00007ff63118f53d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff634827760 (LWP 13438)):
#0  0x00007ff62f2f61eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff63267f308 in thread_sleep (ti=0x7fff9e8ada00) at thread/qthread_unix.cpp:493
#2  0x00007ff63267f740 in QThread::msleep (msecs=<optimized out>) at thread/qthread_unix.cpp:519
#3  0x00007ff61acb1312 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#4  0x00007ff61acb1459 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#5  0x00007ff62df6ea57 in ?? () from /usr/lib64/libphonon.so.4
#6  0x00007ff62df6ebe9 in ?? () from /usr/lib64/libphonon.so.4
#7  0x00007ff6310ed9a1 in __run_exit_handlers () from /lib64/libc.so.6
#8  0x00007ff6310eda25 in exit () from /lib64/libc.so.6
#9  0x00007ff631ba1d78 in ?? () from /usr/lib64/libQtGui.so.4
#10 0x00007ff634231468 in KApplication::xioErrhandler (this=0x7fff9e8af170, dpy=0x7b9ae0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:419
#11 0x00007ff632fbe51e in _XIOError () from /usr/lib64/libX11.so.6
#12 0x00007ff632fbbe2d in _XEventsQueued () from /usr/lib64/libX11.so.6
#13 0x00007ff632fac81f in XEventsQueued () from /usr/lib64/libX11.so.6
#14 0x00007ff631bd8dcc in ?? () from /usr/lib64/libQtGui.so.4
#15 0x00007ff62b064264 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#16 0x00007ff62b064ab2 in ?? () from /usr/lib64/libglib-2.0.so.0
#17 0x00007ff62b064f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#18 0x00007ff63279150f in QEventDispatcherGlib::processEvents (this=0x61b280, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#19 0x00007ff631bd8f9e in ?? () from /usr/lib64/libQtGui.so.4
#20 0x00007ff632765a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#21 0x00007ff632765c1f in QEventLoop::exec (this=0x7fff9e8add50, flags=...) at kernel/qeventloop.cpp:201
#22 0x00007ff631fe7f86 in QDialog::exec() () from /usr/lib64/libQtGui.so.4
#23 0x00007ff63419afea in KMessageBox::createKMessageBox (dialog=0xcfe940, icon=<optimized out>, text=..., strlist=<optimized out>, ask=..., checkboxReturn=0x0, options=..., details=..., notifyType=QMessageBox::Critical) at /usr/src/debug/kdelibs-4.7.4/kdeui/dialogs/kmessagebox.cpp:344
#24 0x00007ff63419b81b in KMessageBox::createKMessageBox (dialog=0xcfe940, icon=QMessageBox::Critical, text=..., strlist=..., ask=..., checkboxReturn=0x0, options=..., details=...) at /usr/src/debug/kdelibs-4.7.4/kdeui/dialogs/kmessagebox.cpp:159
#25 0x00007ff63419c45b in KMessageBox::errorListWId (parent_id=0, text=..., strlist=..., caption=..., options=...) at /usr/src/debug/kdelibs-4.7.4/kdeui/dialogs/kmessagebox.cpp:854
#26 0x00007ff63419c615 in KMessageBox::error (parent=<optimized out>, text=..., caption=..., options=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/kdeui/dialogs/kmessagebox.cpp:821
#27 0x00007ff609ae1e3a in Collections::SqlCollection::SqlCollection (this=<optimized out>, id=..., prettyName=<optimized out>, storage=0xcf3910) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/SqlCollection.cpp:176
#28 0x00007ff609ae3b3f in Collections::SqlCollectionFactory::createSqlCollection (this=<optimized out>, id=..., prettyName=..., storage=0xcf3910) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/SqlCollectionFactory.cpp:31
#29 0x00007ff609d41eaa in Collections::MySqlEmbeddedCollectionFactory::init (this=0xcd6520) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/mysqlecollection/MySqlEmbeddedCollection.cpp:35
#30 0x00007ff6336dcc09 in CollectionManager::loadPlugins (this=0x78cb00, factories=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:207
#31 0x00007ff6336e0184 in CollectionManager::init (this=0x78cb00, factories=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:175
#32 0x00007ff63385014a in Plugins::PluginManager::init (this=0x78d000) at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:82
#33 0x00007ff633851399 in Plugins::PluginManager::PluginManager (this=0x78d000, parent=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:64
#34 0x00007ff633851567 in Plugins::PluginManager::instance () at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:43
#35 0x00007ff63383308d in pluginManager () at /usr/src/debug/amarok-2.5.0/src/PluginManager.h:76
#36 MainWindow::MainWindow (this=0x7905c0) at /usr/src/debug/amarok-2.5.0/src/MainWindow.cpp:139
#37 0x00007ff63380b0df in App::continueInit (this=0x7fff9e8af170) at /usr/src/debug/amarok-2.5.0/src/App.cpp:545
#38 0x00007ff63380c79c in App::App (this=0x7fff9e8af170) at /usr/src/debug/amarok-2.5.0/src/App.cpp:185
#39 0x0000000000409085 in main (argc=1, argv=0x7fff9e8b15f8) at /usr/src/debug/amarok-2.5.0/src/main.cpp:301

Possible duplicates by query: bug 281312.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-12-27 19:41:10 UTC
English, please!

*** This bug has been marked as a duplicate of bug 281312 ***