Bug 293305 - moun don't opern
Summary: moun don't opern
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: 1.2.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 16:09 UTC by stropeo
Modified: 2012-02-04 16:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stropeo 2012-02-04 16:09:03 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
the moun software application crashed when I'clik the icon

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78c2930 (LWP 1885))]

Thread 2 (Thread 0xb586cb70 (LWP 1889)):
#0  0x089cfd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0086e7d5 in do_gettime (frac=0xb586c020, sec=0xb586c018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x009414b6 in QTimerInfoList::updateCurrentTime (this=0xa1fb87c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0094180a in QTimerInfoList::timerWait (this=0xa1fb87c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00940053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb586c12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x009400ed in timerSourcePrepare (source=0xa1fb848, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x08aa988c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x08aaa637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x08aaac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00940b37 in QEventDispatcherGlib::processEvents (this=0xa0f41c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x009111dd in QEventLoop::processEvents (this=0xb586c2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00911421 in QEventLoop::exec (this=0xb586c2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0081490b in QThread::exec (this=0xa1f2688) at thread/qthread.cpp:498
#14 0x008f1e2d in QInotifyFileSystemWatcherEngine::run (this=0xa1f2688) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x008177b3 in QThreadPrivate::start (arg=0xa1f2688) at thread/qthread_unix.cpp:331
#16 0x025abd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x070a60ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78c2930 (LWP 1885)):
[KCrash Handler]
#7  0x0086be11 in QtPrivate::QStringList_contains (that=0xbfd217b4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd217b4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa0a8910) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa0a8910, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd219d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00918b7d in metacall (argv=0xbfd219d4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa0a8910) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa0a8910, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd219d4) at kernel/qmetaobject.cpp:232
#13 0x00927a6a in QMetaObject::activate (sender=0x9fa3478, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9fa3478) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9fa3478, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd21b18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00918b7d in metacall (argv=0xbfd21b18, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9fa3478) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9fa3478, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd21b18) at kernel/qmetaobject.cpp:232
#18 0x00927a6a in QMetaObject::activate (sender=0xa0a8910, m=0x80950c0, local_signal_index=0, argv=0xbfd21b18) at kernel/qobject.cpp:3278
#19 0x00ad77c5 in MuonMainWindow::backendReady (this=0xa0a8910, _t1=0xa1105c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00ad7933 in MuonMainWindow::initObject (this=0xa0a8910) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa0a8910) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa0a8910, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd21c44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00918b7d in metacall (argv=0xbfd21c44, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa0a8910) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa0a8910, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd21c44) at kernel/qmetaobject.cpp:232
#25 0x00927a6a in QMetaObject::activate (sender=0xa0f5298, m=0xa48238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0092f375 in QSingleShotTimer::timeout (this=0xa0f5298) at .moc/release-shared/qtimer.moc:82
#27 0x0092f42c in QSingleShotTimer::timerEvent (this=0xa0f5298) at kernel/qtimer.cpp:308
#28 0x0092a994 in QObject::event (this=0xa0f5298, e=0xbfd2203c) at kernel/qobject.cpp:1181
#29 0x0355ad84 in notify_helper (e=0xbfd2203c, receiver=0xa0f5298, this=0x9fa42e0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9fa42e0, receiver=0xa0f5298, e=0xbfd2203c) at kernel/qapplication.cpp:4458
#31 0x03560133 in QApplication::notify (this=0xbfd2203c, receiver=0xa0f5298, e=0xbfd2203c) at kernel/qapplication.cpp:3886
#32 0x00d11971 in KApplication::notify (this=0xbfd22350, receiver=0xa0f5298, event=0xbfd2203c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0091219e in QCoreApplication::notifyInternal (this=0xbfd22350, receiver=0xa0f5298, event=0xbfd2203c) at kernel/qcoreapplication.cpp:787
#34 0x00942c10 in sendEvent (event=0xbfd2203c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9fa8834) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00940122 in timerSourceDispatch (source=0x9fa8800) at kernel/qeventdispatcher_glib.cpp:184
#37 0x08aaa25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x08aaa990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x08aaac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00940ada in QEventDispatcherGlib::processEvents (this=0x9f87238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03612e7a in QGuiEventDispatcherGlib::processEvents (this=0x9f87238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009111dd in QEventLoop::processEvents (this=0xbfd222b4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00911421 in QEventLoop::exec (this=0xbfd222b4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0091619d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03558924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 293300.

Possible duplicates by query: bug 293300, bug 293258, bug 293257, bug 293256, bug 293245.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-04 16:19:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***