Bug 293045 - Networkmaneger plasmoid shows an error when editing Mobile interface(Huawei 367)
Summary: Networkmaneger plasmoid shows an error when editing Mobile interface(Huawei 367)
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: Control Module (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
: 293117 311836 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-01 13:06 UTC by Roman
Modified: 2012-12-17 16:53 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example of bug and message shown. (73.00 KB, image/png)
2012-02-01 13:06 UTC, Roman
Details
Package list (78.30 KB, text/plain)
2012-02-05 17:51 UTC, Roman
Details
Gui bug (319.28 KB, image/png)
2012-05-31 13:17 UTC, Roman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman 2012-02-01 13:06:02 UTC
Created attachment 68398 [details]
Example of bug and message shown.

Version:           unspecified (using KDE 4.8.0) 
OS:                Linux

Error appears trying to edit mobile interface and functions "system connection" and "connect automaticaly" doesn't work.

Reproducible: Always

Steps to Reproduce:
Place 3G Modem(in my case Huawei E367), and edit interface setting with KDE plasmoid for network Manager.(OpenSuSE 12.1 64 bit)

Actual Results:  
Error appears and no automatical connection working

Expected Results:  
Should show no errors and automaticaly connect when device appears.

On KDE 4.7.4 it was a bug + no auto connect, but on KDE 4.8 cann't edit interface at all.
Comment 1 Lamarque V. Souza 2012-02-04 16:34:48 UTC
Do you have the password field in the connection's edit dialog filled? If not then that is the cause of the message.

Which Plasma NM version do you use? The version is in the tab called "Other".
Comment 2 Roman 2012-02-04 17:40:42 UTC
Version number: 0.90_rc3(nm09 20111209). Plasmoid was installed from OpenSuSE repositories. And, about password. I cann't change settings. Cause trying to edit connection shows error I showed before(screenshot) and connection setting doesn't open. Currently SIM card configured not to ask password(that's the only option to be able to use this connection, because I cann't edit it). And on previous version of KDE, I configured networkmanager not to request password and SIM card not to require it. So, actually, it should show no errors. And at the moment, I'm connected with this interface.
Comment 3 Lamarque V. Souza 2012-02-04 21:52:29 UTC
Nobody has implemented the option to mark the password field as "Not required" for GSM connections. That option only exists for the PIN, so if the password is empty then that warning message is normal. What is not normal is the fact that you cannot open the edit dialog. OpenSuse passed through some problems with polkit that maybe cause this problem.

You can check if the password is empty by looking in to the file /etc/NetworkManager/system-connections/<connection name>.
Comment 4 Roman 2012-02-05 09:47:57 UTC
Here is that file(completely as it is)
------------------

[connection]
id=Tele2
uuid=181e14fd-ade3-4c29-b467-59c4a675d5ee
type=gsm
timestamp=1327986304

[ipv6]
method=ignore

[ipv4]
method=manual
dns=4.2.2.1;4.2.2.2;4.2.2.3;4.2.2.4;4.2.2.5;4.2.2.6;
dns-search=4.2.2.1;4.2.2.2;4.2.2.3;4.2.2.4;4.2.2.5;4.2.2.6;
addresses1=83.178.59.173;32;10.64.64.64;

[gsm]
number=*99#
apn=internet.tele2.ee
network-type=0
pin-flags=4
home-only=true
-------------------------------

Also, I cann't add new mobile connection after upgrading to KDE 4.8.0. NetworkManager works fine with the same settings in Gnome 3.2, but crashes in KDE 4.8.0 on the same OS. In KDE 4.7.4 I was able at least to edit or create a new mobile connection, in KDE 4.8.0 it's impossible for me. Well, if, it's not a bug, then, how to solve it? and why it worked in KDE 4.7.4 and Gnome 3.2, but crashes in KDE 4.8.0?
Comment 5 Lamarque V. Souza 2012-02-05 12:31:17 UTC
The entries username and password-flags are missing from the [gsm] session, that explains the message "No agents were available for this request". You can try adding them and restarting NetworkManager to see if it solves the crash problem. Make the [gsm] session looks like this:

[gsm]
number=*99#
apn=internet.tele2.ee
network-type=0
pin-flags=4
home-only=true
username=something
password-flags=1

The password is not saved yet so the message "No agent were available to for this request" is going to appear next time you try to edit the connection. If the edit dialog appears then fill the user name and password fields. The "No agents..." message should not appear anymore.

I tested your configuratino with my Plasma NM and it did not crash, it only shows the message "No agents..." and opens the edit dialog. I do not know why it crashes with you. Please send me the file packages.txt generated with the command below:

rpm -qa > packages.txt
Comment 6 Roman 2012-02-05 17:51:40 UTC
Created attachment 68534 [details]
Package list

Here you are...
Comment 7 Roman 2012-02-05 17:56:11 UTC
And one more thing... I also don't know, why "connect automaticaly" and "system connection" is being ignored... Always have to press "connect"...
Comment 8 Lamarque V. Souza 2012-02-05 18:23:32 UTC
Your connection is system connection according to the configuration you posted in comment #4. It is also set as autoconnect according to the configuration, but it is NetworkManager that starts the auto-connect connections, Plasma NM just save the configuration. By the way, you are using a release candidate version of NetworkManager. I have seen bugs related to this particular version, like not saving secrets. I suggest that you upgrade your NetworkManager version to 0.9.2.0 (at least) and see if that solves the problem for you.
Comment 9 Roman 2012-02-06 07:11:01 UTC
Well, after update, it's now possible to edit connection. I was unable to set username and password(I guess, that this username and pass should be given by provider, but it my case, provider uses connection without username and pass). Setting random username and pass causes plasmoid to stop responding on attempt to connect.

And still, no autoconnect working.
Comment 10 Roman 2012-02-06 07:22:50 UTC
OK, I guess you can mark it as solved or wrong bug... Possibly, that's OpenSuSE bug, cause seems I'm the only one who has that bug.
Comment 11 Lamarque V. Souza 2012-02-07 01:27:09 UTC
According to /usr/share/mobile-broadband-provider-info/serviceproviders.xml you should use wap as username and password. I have looked at OpenSuse's buzilla and there is no bug similar to yours. Can you try creating another connection and see if it works? You do not need to delete the existing connection.
Comment 12 Roman 2012-02-07 09:17:30 UTC
So, I tried it out. It now began trying to autoconnect and show no more that error. BUT it failed to connect!!! It showed me every time in loop password and settings request. I called my provider and they made it clear that NO USER and NO PASS should be used. So, that's a software bug(programmers also should count on situation, when no username or password should be provided).
Comment 13 Lamarque V. Souza 2012-02-07 10:37:24 UTC
Git commit 813be70e01a3fa8de4c6541d7e999c8c9c17b793 by Lamarque V. Souza.
Committed on 07/02/2012 at 11:36.
Pushed by lvsouza into branch 'master'.

Mark GSM password as NotRequired if it is empty.

M  +11   -2    kded/settingsnm08/gsmpersistence.cpp
M  +5    -1    libs/ui/gsmwidget.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/813be70e01a3fa8de4c6541d7e999c8c9c17b793
Comment 14 Lamarque V. Souza 2012-02-07 10:39:44 UTC
Git commit 448f167a2a9f5276a8e991e86338afe001f9b1ad by Lamarque V. Souza.
Committed on 07/02/2012 at 11:36.
Pushed by lvsouza into branch 'nm09'.

Mark GSM password as NotRequired if it is empty.

M  +11   -2    kded/settingsnm08/gsmpersistence.cpp
M  +5    -1    libs/ui/gsmwidget.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/448f167a2a9f5276a8e991e86338afe001f9b1ad
Comment 15 Lamarque V. Souza 2012-02-07 10:42:18 UTC
(In reply to comment #12)
> So, I tried it out. It now began trying to autoconnect and show no more that
> error. BUT it failed to connect!!! It showed me every time in loop password and
> settings request. I called my provider and they made it clear that NO USER and
> NO PASS should be used. So, that's a software bug(programmers also should count
> on situation, when no username or password should be provided).

The commit above should make NetworkManager not ask for the password if it is empty.
Comment 16 Roman 2012-02-07 15:20:57 UTC
OK.
Comment 17 Lamarque V. Souza 2012-02-07 15:27:45 UTC
(In reply to comment #15)
> (In reply to comment #12)
> > So, I tried it out. It now began trying to autoconnect and show no more that
> > error. BUT it failed to connect!!! It showed me every time in loop password and
> > settings request. I called my provider and they made it clear that NO USER and
> > NO PASS should be used. So, that's a software bug(programmers also should count
> > on situation, when no username or password should be provided).
> 
> The commit above should make NetworkManager not ask for the password if it is
> empty.

Ah, you need to re-create the connection for the commit take effect.
Comment 18 Roman 2012-02-07 15:31:11 UTC
I see. I guess current bug report can be marked as solved or to be removed.
Comment 19 Lamarque V. Souza 2012-02-12 13:30:00 UTC
*** Bug 293117 has been marked as a duplicate of this bug. ***
Comment 20 Roman 2012-02-20 03:02:01 UTC
Hi again. Found a perfect 100% working solution.

1) Install the latest NetworkManager (0.9.2)
2) Install the latest NetworkManager-gnome packege (0.9.2)
3) Remove NetworkManager-kde4-libs and all stuff, that depends on it( for example plasmoid-networkmanager will be also deleted). That's a garbage from KDE team "ReleaseCandidate" that is absolutely unusable, buggy and crashes after every second-third 3G network reconnection.
4) Go to "Presonal Settings" => "Startup and Shutdown", add record "script" => "nm-applet"
5) Enjoy stable NetworkManager work without KDE buggy stuff.

PS. Don't know where to write it, but I wish veeeeery much Plasma project to die. It's so slow, buggy, annoying, memory eating stuff... More over, it uses python shit, that never been, and never will be fast and memory friendly. KDE 3.5 was the last perfect release. 4.X series are real shit, the only reason I use it, is tray available( Gnome doesn't have it anymore) and KDevelop. C/C++ software will be much faster, then any even well written python shit.

Didn't want to heart anyone, just an oppinion. Thanks! My problem is solved by removing KDE part of NetworkManager.
Comment 21 Roman 2012-02-20 03:09:49 UTC
By the way... Doing stuff written above, I got +25% of network speed. 19 Mpbs instead of 15 Mbps. On original KDE NetworkManager plasmoid is was very buggy, slow and one more funny story... don't know even why it's so... with kde plasmoid, after standby it was 75% chance to get 1 Mbps speed limit. 

Personally to Lamarque V. Souza:
After replacing plasmoid to nm-aplett, 3G network autoconnect works 100% fine. With KDE api and plasmoid it never did. So, search a bug in KDE part.
Comment 22 Lamarque V. Souza 2012-02-20 19:10:50 UTC
It's a big disappointment your tone. It is difficult to develop and bugfix a software without proper resources like is the case with Plasma NM. I try to do my best, although I recognise sometimes it is not enough. I work alone with Plasma NM, I am not paid to do this work and because of that I cannot spend more time with Plasma NM. I was trying to help you, but it seems you do not deserve any help.
Comment 23 Roman 2012-02-20 19:29:46 UTC
(In reply to comment #22)
> It's a big disappointment your tone. It is difficult to develop and bugfix a
> software without proper resources like is the case with Plasma NM. I try to do
> my best, although I recognise sometimes it is not enough. I work alone with
> Plasma NM, I am not paid to do this work and because of that I cannot spend
> more time with Plasma NM. I was trying to help you, but it seems you do not
> deserve any help.

I'm really sorry for my tone... And more over, I didn't say, that it's plasmoid's bug. There are many libraries coming as dependencies for it. For example, NetworkManager-kde4-libs and so on. It's really hard to find out where exactly bug is. Being alone is not really good thing... I'm also a programmer(specialise at C/C++ programming). And... If you wish to make it better, I guess, I could join you(a few week later, I'm busy with my main job at the moment). My offer is to revive KNetworkManager. It was quite stable the days it existed. Lamarque V. Souza, I really appologise for what I've said... I'm working as a programmer in my main job... and just out of nerves, when entire KDE 4.8.0 release starts bugging and crashing on every move. About Plazma, it's my private opinion, it's beautifull, but it's slow and it's hard to make addon plasmoids to work, cause never know, what python packages required. With C++ it's much easier, it shows dependency faults and it's easy to find a solution.

And one strange thing I noticed, that I installed plasmoid 0.9.2, but is shows 0.9 RC4. It's strange to me. And I'm sorry once again, I have unfortinately no time for fiding out where bug comes from... I don't care, how pretty or ugly design and graphics look like, I simply need internet to work. I tried everything I could, but it had no much success. I didn't say, that it's your fault. For example, KMess 2.0.6.1 work 100% stable with KDE 4.7.4, but the same crash after network reconnection attempt. Lancelot also shows many D-Bus errors, KMix doesn't store volume levels, Amarok does not work with Xine backend and so on. All I tried to say, that KDE 4.8.0 is unfortunaly very unstable and it's hard to find out where bugs come from. I guess, bugs are somewhere deep in KDE core.

Forgive me, if you can and thanks for your work. Have to admit also, that I reported not the only one bug, but you're the only one who replied. I should say thing I said...
Comment 24 Lamarque V. Souza 2012-02-21 15:01:09 UTC
As a friend of mine once said: you can even write an e-mail (or post) with that content, afterwards read through it, think about what you wrote and delete the whole text.

Plasma NM does not have extense dependencies, only KDE SC 4.6.0, NetworkManager 0.9.0, ModemManager 0.4, and dbus. All other things (VPN client libraries/programs, mobile-broadband-provider-info database) are optional. NetworkManager-kde4-libs is probably for the old monolithic version, which OpenSuse insist it keep in their repositories. I also do like the way OpenSuse split Plasma NM into several sub-packages, that can cause a dependency nightmare, specially if the user had configured several repos with different Plasma NM versions in each of them.

The old monolithic KNetworkManager and the plasmoid versions share about 80% of the source code. That said, all the problems you currently have with the plasmoid version would still happen if the monolithic version were still being maintained. And there is the infamous isSeparator crash bug in the old monolithic version that is in fact a bug in Qt itself (and has never been fixed). KNetworkManager used to be stable because several people used to work on it, which was not true anymore when I started to work in KNetworkManager (yes, I started to work with it before I switched to the plasmoid version).

I advised you not to use Python plasmoids at all. There are too many of them with bugs by what I can see in bugs.kde.org and unfortunately any plasmoid can crash or slow down the entire desktop if not properly written.

There is no plasmoid 0.9.2.0, that is the NetworkManager version. The latest Plasma NM version I have released is 0.8.99 (also known as 0.9.0_rc4). Look in the kcm (k control module) in the tab called "Other" to see the Plasma NM version. OpenSuse uses 0.9.2 as the package version for Plasma NM since before I started releasing Plasma NM tar balls. That is one thing that needs to be fixed, but I doubt OpenSuse is going to start using the official Plasma NM version numbers until we reach the 0.9.2 version. I do not see a official Plasma NM 0.9.2 in less than one year.

Do you have Qt 4.8.0 installed? I have seen some wierd bugs that only happens with Qt 4.8.0. There is one such bugs in Plasma NM. I use Gentoo and compile all my programs and everything here were rock stable right after I compiled KDE SC 4.8.0. I was really surprised with the absolutely zero problems after the upgrade. I think maybe your problems is because the programs you mentioned were not compiled against KDE SC 4.8.0 (both KMess and Lancelot are not part of KDE SC). I do not have problems with kmix, buuuuuut I do not use pulseaudio at all. I used to use xine phonon backend with zero problems too, buuuuut again: I do not use pulseaudio at all. Today I use vlc phonon backend because the xine backend is deprecated for more than one year. OpenSuse should have changed to vlc or gstreamer backend and removed the xine backend long ago. If you have the vlc backend installed try using it instead of xine.

I do not have any instabilities like you have, so I not sure if the problems are really in KDE software.
Comment 25 Roman 2012-02-21 15:57:04 UTC
(In reply to comment #24)
> As a friend of mine once said: you can even write an e-mail (or post) with that
> content, afterwards read through it, think about what you wrote and delete the
> whole text.
> 
> Plasma NM does not have extense dependencies, only KDE SC 4.6.0, NetworkManager
> 0.9.0, ModemManager 0.4, and dbus. All other things (VPN client
> libraries/programs, mobile-broadband-provider-info database) are optional.
> NetworkManager-kde4-libs is probably for the old monolithic version, which
> OpenSuse insist it keep in their repositories. I also do like the way OpenSuse
> split Plasma NM into several sub-packages, that can cause a dependency
> nightmare, specially if the user had configured several repos with different
> Plasma NM versions in each of them.
> 
> The old monolithic KNetworkManager and the plasmoid versions share about 80% of
> the source code. That said, all the problems you currently have with the
> plasmoid version would still happen if the monolithic version were still being
> maintained. And there is the infamous isSeparator crash bug in the old
> monolithic version that is in fact a bug in Qt itself (and has never been
> fixed). KNetworkManager used to be stable because several people used to work
> on it, which was not true anymore when I started to work in KNetworkManager
> (yes, I started to work with it before I switched to the plasmoid version).
> 
> I advised you not to use Python plasmoids at all. There are too many of them
> with bugs by what I can see in bugs.kde.org and unfortunately any plasmoid can
> crash or slow down the entire desktop if not properly written.
> 
> There is no plasmoid 0.9.2.0, that is the NetworkManager version. The latest
> Plasma NM version I have released is 0.8.99 (also known as 0.9.0_rc4). Look in
> the kcm (k control module) in the tab called "Other" to see the Plasma NM
> version. OpenSuse uses 0.9.2 as the package version for Plasma NM since before
> I started releasing Plasma NM tar balls. That is one thing that needs to be
> fixed, but I doubt OpenSuse is going to start using the official Plasma NM
> version numbers until we reach the 0.9.2 version. I do not see a official
> Plasma NM 0.9.2 in less than one year.
> 
> Do you have Qt 4.8.0 installed? I have seen some wierd bugs that only happens
> with Qt 4.8.0. There is one such bugs in Plasma NM. I use Gentoo and compile
> all my programs and everything here were rock stable right after I compiled KDE
> SC 4.8.0. I was really surprised with the absolutely zero problems after the
> upgrade. I think maybe your problems is because the programs you mentioned were
> not compiled against KDE SC 4.8.0 (both KMess and Lancelot are not part of KDE
> SC). I do not have problems with kmix, buuuuuut I do not use pulseaudio at all.
> I used to use xine phonon backend with zero problems too, buuuuut again: I do
> not use pulseaudio at all. Today I use vlc phonon backend because the xine
> backend is deprecated for more than one year. OpenSuse should have changed to
> vlc or gstreamer backend and removed the xine backend long ago. If you have the
> vlc backend installed try using it instead of xine.
> 
> I do not have any instabilities like you have, so I not sure if the problems
> are really in KDE software.

Yes, QT 4.8.0 is also installed. It comes with KDE 4.8.0 repository(with QT 4.8.0 included). In OpenSuSE rpms if you delete networkmanager-kde4-libs, all other packages are removed due dependencies, plasmoid as well).
Comment 26 Lamarque V. Souza 2012-02-21 18:00:54 UTC
By what I can see here 
https://build.opensuse.org/package/files?package=NetworkManager-kde4&project=openSUSE%3A12.1

NetworkManager-kde4-libs is required by OpenSuse's Plasma NM package (plasmoid-networkmanagement). Actually the monolithic version is not compiled anymore, which is good.

https://build.opensuse.org/package/files?package=libqt4&project=openSUSE%3A12.1 show 12.1 should be using Qt 4.7.4, not 4.8.0. Where did you get the Qt 4.8.0 from?
Comment 27 Roman 2012-02-22 00:02:38 UTC
Right here : http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/x86_64/ . It's included with KDE 4.8.0 release, as a part of it. It's official OpenSuSE 12.1 KDE repository.

Here is repository list: http://en.opensuse.org/KDE_repositories#Upstream_release_aka._KR48_.28KDE_SC_4.8.29

So, such a story. I didn't search for the nevest Qt, it was installed together with new KDE release
Comment 28 Lamarque V. Souza 2012-02-26 18:00:27 UTC
If OpenSuse guys thinks Qt 4.8.0 is ready for stable update they should have their reasons. I am going to stay in 4.7.4 for a while in my notebook.
Comment 29 Roman 2012-02-26 18:07:26 UTC
Shit... I guess I found out a most awfull bug source - dbus. In OpenSuSE 12.1 it's included unstable version by default. And more over, downgrade is impossible :(
Comment 30 Lamarque V. Souza 2012-02-26 18:33:54 UTC
Which dbus version OpenSuse uses? I use dbus-1.4.16.
Comment 31 Roman 2012-02-26 18:47:27 UTC
yes,that's the version it supposed to be, and that's stable version. OpenSuSE 12.1 comes with dbus 1.5.8. And unfortunaly, no earlier version RPM available...
Comment 32 Lamarque V. Souza 2012-04-18 00:10:27 UTC
Is this problem still happening?
Comment 33 Roman 2012-04-18 19:10:45 UTC
Yes, it does.
Comment 34 Roman 2012-05-31 13:17:27 UTC
Created attachment 71461 [details]
Gui bug

Network manager GUI bug. Text, that networkmanager is down doen't disappear when it's on... Please fix it.
Comment 35 Roman 2012-05-31 13:20:14 UTC
See screenshot for more details. That text should disappear, when network manager is started. It's very annoying, have to restart KDE after networkmanager is being down for 10-15 times.(whole screen is full of that text messages).

Thanks!
Comment 36 Lamarque V. Souza 2012-06-25 22:36:31 UTC
Git commit ec96abe827ab5ac57059a2b4e4b841097e8048f3 by Lamarque V. Souza.
Committed on 26/06/2012 at 00:35.
Pushed by lvsouza into branch 'master'.

Remove warning message once NetworkManager is up and running.

M  +17   -6    applet/nmpopup.cpp
M  +1    -0    applet/nmpopup.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/ec96abe827ab5ac57059a2b4e4b841097e8048f3
Comment 37 Lamarque V. Souza 2012-06-25 22:43:09 UTC
Git commit 26ae174ff53c322e50d7ec0aad02b629e2174b23 by Lamarque V. Souza.
Committed on 26/06/2012 at 00:35.
Pushed by lvsouza into branch 'nm09'.

Remove warning message once NetworkManager is up and running.

M  +17   -6    applet/nmpopup.cpp
M  +1    -0    applet/nmpopup.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/26ae174ff53c322e50d7ec0aad02b629e2174b23
Comment 38 Roman 2012-06-26 12:15:48 UTC
(In reply to comment #37)
> Git commit 26ae174ff53c322e50d7ec0aad02b629e2174b23 by Lamarque V. Souza.
> Committed on 26/06/2012 at 00:35.
> Pushed by lvsouza into branch 'nm09'.
> 
> Remove warning message once NetworkManager is up and running.
> 
> M  +17   -6    applet/nmpopup.cpp
> M  +1    -0    applet/nmpopup.h
> M  +1    -1    plasma_nm_version.h
> 
> http://commits.kde.org/networkmanagement/
> 26ae174ff53c322e50d7ec0aad02b629e2174b23

Does that mean any fixes coming?
Comment 39 Lamarque V. Souza 2012-06-26 13:21:06 UTC
The commit fixes the problem described in comment #34. By the way, auto-connect does not work with 3G connections because NetworkManager lacks support for that, so I cannot do anything about that.

Is the  "No agents were available for this request" still happening? If not then I will close this bug as fixed.
Comment 40 Roman 2012-06-27 11:49:08 UTC
(In reply to comment #39)
> The commit fixes the problem described in comment #34. By the way,
> auto-connect does not work with 3G connections because NetworkManager lacks
> support for that, so I cannot do anything about that.
> 
> Is the  "No agents were available for this request" still happening? If not
> then I will close this bug as fixed.

Yes, you can close it. Thanks a lot for your help!
Comment 41 Lamarque V. Souza 2012-12-17 16:53:49 UTC
*** Bug 311836 has been marked as a duplicate of this bug. ***