Bug 292279 - Amarok crashes with vlc as back-end
Summary: Amarok crashes with vlc as back-end
Status: RESOLVED DUPLICATE of bug 259269
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-23 16:58 UTC by demopley
Modified: 2012-01-24 15:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description demopley 2012-01-23 16:58:43 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.00 (4.8.0 "release 462"
Qt Version: 4.8.0
Operating System: Linux 3.1.6-1-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
Amarok is crashing when using phonon-backend-vlc-0.4.1

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[KCrash Handler]
#6  0x0000000000000a76 in ?? ()
#7  0x00007f4c98d1210c in vlc_entry__1_1_0g (p_module=0xcb87d0) at opencv_example.c:66
#8  0x00007f4cc44210d1 in module_Call (obj=0x951040, p_module=<optimized out>) at modules/os.c:119
#9  0x00007f4cc441ad0f in AllocatePlugin (p_this=0x951040, psz_file=0xcb8760 "/usr/lib64/vlc/plugins/video_filter/libopencv_example_plugin.so") at modules/modules.c:1032
#10 0x00007f4cc441aff4 in AllocatePluginFile (i_file_size=10440, i_file_time=1325856564, psz_file=0xcb8760 "/usr/lib64/vlc/plugins/video_filter/libopencv_example_plugin.so", p_bank=0x94f810, p_this=<optimized out>) at modules/modules.c:960
#11 AllocatePluginDir (p_this=0x951040, p_bank=0x94f810, psz_dir=0xbb4320 "/usr/lib64/vlc/plugins/video_filter", i_maxdepth=<optimized out>) at modules/modules.c:912
#12 0x00007f4cc441af84 in AllocatePluginDir (p_this=0x951040, p_bank=0x94f810, psz_dir=0xbb07a0 "/usr/lib64/vlc/plugins", i_maxdepth=<optimized out>) at modules/modules.c:904
#13 0x00007f4cc441af84 in AllocatePluginDir (p_this=0x951040, p_bank=0x94f810, psz_dir=0x980150 "/usr/lib64/vlc", i_maxdepth=<optimized out>) at modules/modules.c:904
#14 0x00007f4cc441b567 in AllocateAllPlugins (p_bank=0x94f810, p_this=0x951040) at modules/modules.c:854
#15 module_LoadPlugins (p_this=0x951040) at modules/modules.c:217
#16 0x00007f4cc43af1c0 in libvlc_InternalInit (p_libvlc=0x951040, i_argc=11, ppsz_argv=0x7fff6ac5b250) at libvlc.c:453
#17 0x00007f4cc4682661 in libvlc_new (argc=10, argv=<optimized out>) at control/core.c:58
#18 0x00007f4cc48b3212 in LibVLC::init () at /usr/src/debug/phonon-backend-vlc-0.4.1/vlc/libvlc.cpp:111
#19 0x00007f4cc48a572e in Phonon::VLC::Backend::Backend (this=0x94bb00, parent=<optimized out>) at /usr/src/debug/phonon-backend-vlc-0.4.1/vlc/backend.cpp:91
#20 0x00007f4cc48a5d43 in qt_plugin_instance () at /usr/src/debug/phonon-backend-vlc-0.4.1/vlc/backend.cpp:59
#21 0x00007f4cdb1fb79f in QPluginLoader::instance() () from /usr/lib64/libQtCore.so.4
#22 0x00007f4cc503ec86 in ?? () from /usr/lib64/kde4/plugins/phonon_platform/kde.so
#23 0x00007f4cc503f70e in ?? () from /usr/lib64/kde4/plugins/phonon_platform/kde.so
#24 0x00007f4cd69aa239 in Phonon::FactoryPrivate::createBackend (this=0x88f9b0) at /usr/src/debug/phonon-4.6.0/phonon/factory.cpp:130
#25 0x00007f4cd69aaae7 in Phonon::Factory::backend (createWhenNull=<optimized out>) at /usr/src/debug/phonon-4.6.0/phonon/factory.cpp:460
#26 0x00007f4cd69aae95 in Phonon::Factory::createAudioOutput (parent=0x88d560) at /usr/src/debug/phonon-4.6.0/phonon/factory.cpp:356
#27 0x00007f4cd69a383e in createBackendObject (this=0x893180) at /usr/src/debug/phonon-4.6.0/phonon/audiooutput.cpp:138
#28 Phonon::AudioOutputPrivate::createBackendObject (this=0x893180) at /usr/src/debug/phonon-4.6.0/phonon/audiooutput.cpp:133
#29 0x00007f4cd69a08e6 in Phonon::AudioOutputPrivate::init (this=0x893180, c=Phonon::MusicCategory) at /usr/src/debug/phonon-4.6.0/phonon/audiooutput.cpp:111
#30 0x00007f4cdc302bb7 in EngineController::initializePhonon (this=0x88f6e0) at /usr/src/debug/amarok-2.5.0/src/EngineController.cpp:153
#31 0x00007f4cdc3041cd in EngineController::qt_static_metacall (_o=0x88f6e0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/amarok-2.5.0/build/src/EngineController.moc:181
#32 0x00007f4cdb21efb1 in QMetaMethod::invoke(QObject*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) const () from /usr/lib64/libQtCore.so.4
#33 0x00007f4cdb2212c0 in QMetaObject::invokeMethod(QObject*, char const*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) () from /usr/lib64/libQtCore.so.4
#34 0x00007f4cdc40b7e5 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., type=Qt::DirectConnection, member=0x7f4cdc4b4664 "initializePhonon", obj=0x88f6e0) at /usr/include/QtCore/qobjectdefs.h:418
#35 Amarok::DefaultApplicationController::initEngineController (this=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/statemanagement/DefaultApplicationController.cpp:89
#36 0x00007f4cdc40b861 in Amarok::DefaultApplicationController::start (this=0x82ce40) at /usr/src/debug/amarok-2.5.0/src/statemanagement/DefaultApplicationController.cpp:48
#37 0x00007f4cdc2eca0a in App::continueInit (this=0x7fff6ac5ce20) at /usr/src/debug/amarok-2.5.0/src/App.cpp:531
#38 0x00007f4cdc2ee19c in App::App (this=0x7fff6ac5ce20) at /usr/src/debug/amarok-2.5.0/src/App.cpp:185
#39 0x0000000000409085 in main (argc=1, argv=0x7fff6ac5f2a8) at /usr/src/debug/amarok-2.5.0/src/main.cpp:301

This bug may be a duplicate of or related to bug 276287.

Possible duplicates by query: bug 276287.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-01-24 15:06:10 UTC

*** This bug has been marked as a duplicate of bug 259269 ***