Bug 276287 - Apertura di Amarok
Summary: Apertura di Amarok
Status: RESOLVED DUPLICATE of bug 259269
Alias: None
Product: Phonon
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 4.5.1
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-22 21:34 UTC by Alberto
Modified: 2011-06-23 11:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto 2011-06-22 21:34:24 UTC
Application: amarok (2.4.1)
KDE Platform Version: 4.6.4 (4.6.4) "release 8"
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
Esecuzione dell'applicazione da pannello

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[KCrash Handler]
#6  0x00000000000009ee in ?? ()
#7  0x00007f32546c811e in vlc_entry__1_1_0g (p_module=0xd56a40) at avio.c:40
#8  0x00007f32721a9441 in module_Call (obj=0x923b10, p_module=<value optimized out>) at modules/os.c:119
#9  0x00007f32721a2c19 in AllocatePlugin (p_this=0x923b10, psz_file=0xd569d0 "/usr/lib64/vlc/plugins/access/libaccess_avio_plugin.so") at modules/modules.c:1032
#10 0x00007f32721a2ef7 in AllocatePluginFile (p_this=0x923b10, p_bank=0x923590, psz_dir=0xb63220 "/usr/lib64/vlc/plugins/access", i_maxdepth=<value optimized out>) at modules/modules.c:960
#11 AllocatePluginDir (p_this=0x923b10, p_bank=0x923590, psz_dir=0xb63220 "/usr/lib64/vlc/plugins/access", i_maxdepth=<value optimized out>) at modules/modules.c:912
#12 0x00007f32721a2e1c in AllocatePluginDir (p_this=0x923b10, p_bank=0x923590, psz_dir=0xc9baa0 "/usr/lib64/vlc/plugins", i_maxdepth=<value optimized out>) at modules/modules.c:904
#13 0x00007f32721a2e1c in AllocatePluginDir (p_this=0x923b10, p_bank=0x923590, psz_dir=0x936ad0 "/usr/lib64/vlc", i_maxdepth=<value optimized out>) at modules/modules.c:904
#14 0x00007f32721a3453 in AllocateAllPlugins (p_this=0x923b10) at modules/modules.c:854
#15 module_LoadPlugins (p_this=0x923b10) at modules/modules.c:217
#16 0x00007f3272137175 in libvlc_InternalInit (p_libvlc=0x923b10, i_argc=13, ppsz_argv=0x7fffaf325f80) at libvlc.c:453
#17 0x00007f327261662d in libvlc_new () from /usr/lib64/libvlc.so.5
#18 0x00007f327284ae59 in Phonon::VLC::vlcInit (debugLevl=<value optimized out>) at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/vlcloader.cpp:94
#19 0x00007f327283a16d in Phonon::VLC::Backend::Backend (this=0x91bbe0, parent=<value optimized out>) at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/backend.cpp:84
#20 0x00007f327283a6cb in qt_plugin_instance () at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/backend.cpp:49
#21 0x00007f3272f58622 in Phonon::KdePlatformPlugin::createBackend (this=<value optimized out>, newService=...) at /usr/src/debug/kdebase-runtime-4.6.4/phonon/platform_kde/kdeplatformplugin.cpp:149
#22 0x00007f3272f5912b in Phonon::KdePlatformPlugin::createBackend (this=0x880650) at /usr/src/debug/kdebase-runtime-4.6.4/phonon/platform_kde/kdeplatformplugin.cpp:200
#23 0x00007f3286db1046 in ?? () from /usr/lib64/libphonon.so.4
#24 0x00007f3286db198f in Phonon::Factory::backend(bool) () from /usr/lib64/libphonon.so.4
#25 0x00007f3286db1d60 in ?? () from /usr/lib64/libphonon.so.4
#26 0x00007f3286daaa76 in ?? () from /usr/lib64/libphonon.so.4
#27 0x00007f3286da7cf8 in ?? () from /usr/lib64/libphonon.so.4
#28 0x00007f328c9ecf87 in EngineController::initializePhonon (this=0x8bbd30) at /usr/src/debug/amarok-2.4.1/src/EngineController.cpp:153
#29 0x00007f328c9ee466 in EngineController::qt_metacall (this=0x8bbd30, _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0x7fffaf326e80) at /usr/src/debug/amarok-2.4.1/build/src/EngineController.moc:202
#30 0x00007f328b74294f in QMetaMethod::invoke (this=0x7fffaf3270d0, object=0x8bbd30, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1578
#31 0x00007f328b743e00 in QMetaObject::invokeMethod (obj=0x8bbd30, member=<value optimized out>, type=Qt::DirectConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#32 0x00007f328cb2ca65 in invokeMethod (this=<value optimized out>) at /usr/include/QtCore/qobjectdefs.h:408
#33 Amarok::DefaultApplicationController::initEngineController (this=<value optimized out>) at /usr/src/debug/amarok-2.4.1/src/statemanagement/DefaultApplicationController.cpp:89
#34 0x00007f328cb2cae1 in Amarok::DefaultApplicationController::start (this=0x85d690) at /usr/src/debug/amarok-2.4.1/src/statemanagement/DefaultApplicationController.cpp:48
#35 0x00007f328c9c2d3b in App::continueInit (this=0x7fffaf327a00) at /usr/src/debug/amarok-2.4.1/src/App.cpp:601
#36 0x00007f328c9c470d in App::App (this=0x7fffaf327a00) at /usr/src/debug/amarok-2.4.1/src/App.cpp:208
#37 0x00000000004097b0 in main (argc=1, argv=0x7fffaf32a008) at /usr/src/debug/amarok-2.4.1/src/main.cpp:286

Reported using DrKonqi
Comment 1 Harald Sitter 2011-06-23 11:59:29 UTC

*** This bug has been marked as a duplicate of bug 259269 ***