Bug 292089 - Undoing paste with lists crashes
Summary: Undoing paste with lists crashes
Status: RESOLVED DUPLICATE of bug 291858
Alias: None
Product: calligrawords
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Chakra Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-21 03:30 UTC by Kubuntiac
Modified: 2012-03-06 16:58 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kubuntiac 2012-01-21 03:30:06 UTC
Application: calligrawords (2.4 Beta 6)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.1-CHAKRA x86_64
Distribution: "Chakra Linux"

-- Information about the crash:
I have a standard template which has a header, a footer and a an image shape placed over the header on the first page. I had just opened it and pasted a couple of pages of content from another Words document and made 3-4 changes. I decided to undo it all and go back to the empty template. I hit ctrl+z a few times and it undid correctly, but the moment it undid back to just the template, words crashed.

BTW, I've only had this once, but Dr Konqi doesn't let me file a bt unless I say I can replicate it at least "sometimes".

The crash can be reproduced some of the time.

-- Backtrace:
Application: Calligra Words (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7eff88b8b760 (LWP 27552))]

Thread 2 (Thread 0x7eff65dad700 (LWP 27554)):
#0  0x00007eff86210123 in poll () from /lib/libc.so.6
#1  0x00007eff83256c14 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007eff8325714d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007eff877daf7e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007eff877af4f2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007eff877af6f7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007eff876c702f in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007eff8779252f in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007eff876c9a85 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007eff8743fdf0 in start_thread () from /lib/libpthread.so.0
#10 0x00007eff8621839d in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7eff88b8b760 (LWP 27552)):
[KCrash Handler]
#6  KoList::listContinuedFrom (this=0x0) at /home/user/Apps/calligra/calligra-src/libs/kotext/KoList.cpp:235
#7  0x00007eff7289bf93 in ListItemsHelper::recalculateBlock (this=0x7ffffcaca610, block=...) at /home/user/Apps/calligra/calligra-src/libs/textlayout/ListItemsHelper.cpp:263
#8  0x00007eff72881236 in KoTextLayoutArea::layoutBlock (this=0x526ffc0, cursor=0x5f2d260) at /home/user/Apps/calligra/calligra-src/libs/textlayout/KoTextLayoutArea.cpp:761
#9  0x00007eff7288465b in KoTextLayoutArea::layout (this=0x526ffc0, cursor=0x5f2d260) at /home/user/Apps/calligra/calligra-src/libs/textlayout/KoTextLayoutArea.cpp:593
#10 0x00007eff7289521e in KoTextLayoutRootArea::layoutRoot (this=0x526ffc0, cursor=0x5f2d260) at /home/user/Apps/calligra/calligra-src/libs/textlayout/KoTextLayoutRootArea.cpp:63
#11 0x00007eff728974c5 in KoTextDocumentLayout::doLayout (this=0x517d1a0) at /home/user/Apps/calligra/calligra-src/libs/textlayout/KoTextDocumentLayout.cpp:623
#12 0x00007eff72897f18 in layout (this=0x517d1a0) at /home/user/Apps/calligra/calligra-src/libs/textlayout/KoTextDocumentLayout.cpp:572
#13 KoTextDocumentLayout::layout (this=0x517d1a0) at /home/user/Apps/calligra/calligra-src/libs/textlayout/KoTextDocumentLayout.cpp:555
#14 0x00007eff72895c7c in KoTextDocumentLayout::qt_metacall (this=0x517d1a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x57ddcd0) at /home/user/Apps/calligra/calligra-build/libs/textlayout/KoTextDocumentLayout.moc:89
#15 0x00007eff877c6aae in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#16 0x00007eff8698fd94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007eff86994c01 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007eff88569e26 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#19 0x00007eff877b02fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#20 0x00007eff877b366f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#21 0x00007eff877daab3 in ?? () from /usr/lib/libQtCore.so.4
#22 0x00007eff832566d3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007eff83256eb0 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007eff8325714d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007eff877daf16 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007eff86a32cae in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007eff877af4f2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007eff877af6f7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x00007eff877b38eb in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0x00007eff7556e24d in kdemain (argc=<optimized out>, argv=0x24bb9e0) at /home/user/Apps/calligra/calligra-src/words/part/main.cpp:43
#31 0x0000000000408792 in _start ()

Possible duplicates by query: bug 291858, bug 290547, bug 289333.

Reported using DrKonqi
Comment 1 Gopalakrishna Bhat 2012-03-06 16:58:21 UTC

*** This bug has been marked as a duplicate of bug 291858 ***