Bug 289333 - Setting Number List crash
Summary: Setting Number List crash
Status: RESOLVED FIXED
Alias: None
Product: calligrawords
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-19 04:03 UTC by Yeqin
Modified: 2011-12-26 15:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yeqin 2011-12-19 04:03:50 UTC
Application: calligrawords (2.4 Beta 5)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Setting Number List. Has been Selected some number list and type "Tab" the Words crash.

-- Backtrace:
Application: Words (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9f1a845780 (LWP 2502))]

Thread 2 (Thread 0x7f9ef698b700 (LWP 2503)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f9ef698aaf0 in ?? ()
#2  0x00007fff00b947e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f9f1a845780 (LWP 2502)):
[KCrash Handler]
#6  KoList::listContinuedFrom (this=0x0) at /home/hougelangley/kde4/src/calligra/libs/kotext/KoList.cpp:233
#7  0x00007f9f06df9043 in ListItemsHelper::recalculateBlock (this=0x7fff00a6e190, block=...) at /home/hougelangley/kde4/src/calligra/libs/textlayout/ListItemsHelper.cpp:263
#8  0x00007f9f06dde5a0 in KoTextLayoutArea::layoutBlock (this=0x356f050, cursor=0x3e89040) at /home/hougelangley/kde4/src/calligra/libs/textlayout/KoTextLayoutArea.cpp:748
#9  0x00007f9f06de19bb in KoTextLayoutArea::layout (this=0x356f050, cursor=0x3e89040) at /home/hougelangley/kde4/src/calligra/libs/textlayout/KoTextLayoutArea.cpp:580
#10 0x00007f9f06df233e in KoTextLayoutRootArea::layoutRoot (this=0x356f050, cursor=0x3e89040) at /home/hougelangley/kde4/src/calligra/libs/textlayout/KoTextLayoutRootArea.cpp:63
#11 0x00007f9f06df45a5 in KoTextDocumentLayout::doLayout (this=0x1aed130) at /home/hougelangley/kde4/src/calligra/libs/textlayout/KoTextDocumentLayout.cpp:620
#12 0x00007f9f06df4ff8 in layout (this=0x1aed130) at /home/hougelangley/kde4/src/calligra/libs/textlayout/KoTextDocumentLayout.cpp:569
#13 KoTextDocumentLayout::layout (this=0x1aed130) at /home/hougelangley/kde4/src/calligra/libs/textlayout/KoTextDocumentLayout.cpp:552
#14 0x00007f9f06df2d9c in KoTextDocumentLayout::qt_metacall (this=0x1aed130, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x48adf70) at /home/hougelangley/kde4/build/calligra/libs/textlayout/KoTextDocumentLayout.moc:89
#15 0x00007f9f194dea5e in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#16 0x00007f9f18878424 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#17 0x00007f9f1887d291 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#18 0x00007f9f1a235466 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#19 0x00007f9f194c7afc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#20 0x00007f9f194cb51f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#21 0x00007f9f194f2a73 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#22 0x00007f9f152aba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f9f152ac258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f9f152ac429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f9f194f2ed6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#26 0x00007f9f1892007e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#27 0x00007f9f194c6cf2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#28 0x00007f9f194c6ef7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#29 0x00007f9f194cb789 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#30 0x00007f9f07e83cbd in kdemain (argc=<optimized out>, argv=0x1285ce0) at /home/hougelangley/kde4/src/calligra/words/part/main.cpp:43
#31 0x0000000000408547 in _start ()

Reported using DrKonqi
Comment 1 Camilla Boemann 2011-12-26 13:56:31 UTC
Could you please explain a bit more how to reproduce.
Comment 2 Yeqin 2011-12-26 14:49:58 UTC
(In reply to comment #1)
> Could you please explain a bit more how to reproduce.

Er..

For example, I type somethings like this:

At first, setting paragraph is Number List

1.xxx
2.xxx
3.xxx
...

At second, I select
2.xxx
3.xxx
...
and type 'Tab' key. 

;)
Comment 3 Camilla Boemann 2011-12-26 14:59:17 UTC
ok thanks, it appears to be fixed (as i expected), but feel free to reopen if it doesn't work for you in beta 6
Comment 4 Yeqin 2011-12-26 15:10:59 UTC
(In reply to comment #3)
> ok thanks, it appears to be fixed (as i expected), but feel free to reopen if
> it doesn't work for you in beta 6

ok, I using 'git pull' command and testing CalligraWords everyday. If I find new bug and have some suggestions. I will tell my friend Yue.Liu who developing Calligra.

P.S Some bugs and suggestions I could not described so nice by English.

This Office Suite is GREAT ;)
Comment 5 Camilla Boemann 2011-12-26 15:17:50 UTC
Thanks, but if you are really pulling everyday, then maybe it's not fixed after all, but i just can't reproduce.


Anyway, yes just tell Yue. His english is pretty good