Bug 292040 - KMail crash on GPG encrypted message
Summary: KMail crash on GPG encrypted message
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 14:42 UTC by DragonK
Modified: 2012-01-20 14:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DragonK 2012-01-20 14:42:05 UTC
Application: kmail (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

1) Select a GPG encrypted message; a dialog requesting the password should pop up
2) Press cancel in that dialog
3) Warning box appears saying that the password was invalid (???) and two options are presented, Cancel or Retry.
4) Without clicking either Cancel or Retry, select a different message in the message window; nothing will happen, but the selection is possible.
5) Click Cancel in the popup dialog.
6) Kmail crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f68ced58840 (LWP 8202))]

Thread 3 (Thread 0x7f68c20e4700 (LWP 8205)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000038589b86ec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x385937cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000038589b8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003d25807d90 in start_thread (arg=0x7f68c20e4700) at pthread_create.c:309
#4  0x0000003d250ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f68c17db700 (LWP 8206)):
#0  0x0000003d250e6af3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003d27044f88 in g_main_context_poll (n_fds=1, fds=0x7f68bc0013e0, priority=<optimized out>, timeout=5169, context=0x7f68bc0009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7f68bc0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x0000003d2704544c in g_main_context_iteration (context=0x7f68bc0009a0, may_block=1) at gmain.c:3136
#4  0x0000003849da7db6 in QEventDispatcherGlib::processEvents (this=0x7f68bc0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003849d78172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003849d783c7 in QEventLoop::exec (this=0x7f68c17dad40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003849c78b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003849c7bb6b in QThreadPrivate::start (arg=0x1a4af90) at thread/qthread_unix.cpp:298
#9  0x0000003d25807d90 in start_thread (arg=0x7f68c17db700) at pthread_create.c:309
#10 0x0000003d250ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f68ced58840 (LWP 8202)):
[KCrash Handler]
#6  0x0000003854a43eb4 in KMime::Content::parent (this=0x24bcc30) at /usr/src/debug/kdepimlibs-4.7.4/kmime/kmime_content.cpp:927
#7  0x000000385e42e305 in MessageCore::NodeHelper::nextSibling (node=0x24bcc30) at /usr/src/debug/kdepim-4.7.4/messagecore/nodehelper.cpp:32
#8  0x000000385e8832d7 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fff528051a0, node=0x24bcc30) at /usr/src/debug/kdepim-4.7.4/messageviewer/objecttreeparser.cpp:278
#9  0x000000385e8b798f in MessageViewer::ViewerPrivate::parseContent (this=0x1a39de0, content=0x24bcc30) at /usr/src/debug/kdepim-4.7.4/messageviewer/viewer_p.cpp:857
#10 0x000000385e8ba4ba in MessageViewer::ViewerPrivate::displayMessage (this=0x1a39de0) at /usr/src/debug/kdepim-4.7.4/messageviewer/viewer_p.cpp:729
#11 0x000000385e8bad62 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x1a39de0) at /usr/src/debug/kdepim-4.7.4/messageviewer/viewer_p.cpp:1948
#12 0x000000385e8be30a in MessageViewer::ViewerPrivate::qt_static_metacall (_o=0x1a39de0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdepim-4.7.4/x86_64-redhat-linux-gnu/messageviewer/viewer_p.moc:197
#13 0x0000003849d8ccd1 in QMetaObject::activate (sender=0x1a39e68, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#14 0x0000003849d91c39 in QObject::event (this=0x1a39e68, e=<optimized out>) at kernel/qobject.cpp:1157
#15 0x000000384b5c9994 in notify_helper (e=0x7fff52805dc0, receiver=0x1a39e68, this=0x1511210) at kernel/qapplication.cpp:4550
#16 QApplicationPrivate::notify_helper (this=0x1511210, receiver=0x1a39e68, e=0x7fff52805dc0) at kernel/qapplication.cpp:4522
#17 0x000000384b5ce813 in QApplication::notify (this=0x7fff52806180, receiver=0x1a39e68, e=0x7fff52805dc0) at kernel/qapplication.cpp:4411
#18 0x000000384cc50766 in KApplication::notify (this=0x7fff52806180, receiver=0x1a39e68, event=0x7fff52805dc0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#19 0x0000003849d7903c in QCoreApplication::notifyInternal (this=0x7fff52806180, receiver=0x1a39e68, event=0x7fff52805dc0) at kernel/qcoreapplication.cpp:876
#20 0x0000003849da9b42 in sendEvent (event=0x7fff52805dc0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#21 QTimerInfoList::activateTimers (this=0x1514bd0) at kernel/qeventdispatcher_unix.cpp:611
#22 0x0000003849da751d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#23 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#24 0x0000003d27044a7d in g_main_dispatch (context=0x15138e0) at gmain.c:2425
#25 g_main_context_dispatch (context=0x15138e0) at gmain.c:2995
#26 0x0000003d27045278 in g_main_context_iterate (context=0x15138e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#27 0x0000003d2704544c in g_main_context_iteration (context=0x15138e0, may_block=1) at gmain.c:3136
#28 0x0000003849da7d4f in QEventDispatcherGlib::processEvents (this=0x14bdaf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#29 0x000000384b66c61e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#30 0x0000003849d78172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x0000003849d783c7 in QEventLoop::exec (this=0x7fff52806050, flags=...) at kernel/qeventloop.cpp:204
#32 0x0000003849d7cdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.4/kmail/main.cpp:145

Possible duplicates by query: bug 286024.

Reported using DrKonqi
Comment 1 DragonK 2012-01-20 14:47:09 UTC

*** This bug has been marked as a duplicate of bug 279749 ***