Bug 286024 - kmail crashed while decrypting gpg-mail and accessing kwallet at the same time
Summary: kmail crashed while decrypting gpg-mail and accessing kwallet at the same time
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-07 18:02 UTC by MK
Modified: 2011-11-18 23:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MK 2011-11-07 18:02:01 UTC
Application: kmail (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

kmail startet with a GnuPG encrypted mail selected and the passphrase entry dialogue appeared. I left that window open and clicked "fetch new mail" and kwallet asked for the password to unlock the wallet. I entered it, hit return and then kmail crashed immediately.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb73f75b7a0 (LWP 2590))]

Thread 3 (Thread 0x7fb71fb86700 (LWP 2602)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb731a30c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fb731a30d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fb73a67befc in start_thread (arg=0x7fb71fb86700) at pthread_create.c:304
#4  0x00007fb73cad589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb71f285700 (LWP 2603)):
#0  0x00007fb73551e0ff in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb73551edfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb73551f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb73d447f3e in QEventDispatcherGlib::processEvents (this=0x28dfda0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb73d41bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb73d41bef7 in QEventLoop::exec (this=0x7fb71f284de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb73d33327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb73d335d05 in QThreadPrivate::start (arg=0x28df380) at thread/qthread_unix.cpp:331
#8  0x00007fb73a67befc in start_thread (arg=0x7fb71f285700) at pthread_create.c:304
#9  0x00007fb73cad589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb73f75b7a0 (LWP 2590)):
[KCrash Handler]
#6  0x00007fb739b34164 in KMime::Content::parent (this=0x220c150) at ../../kmime/kmime_content.cpp:921
#7  0x00007fb739260995 in MessageCore::NodeHelper::nextSibling (node=0x220c150) at ../../messagecore/nodehelper.cpp:32
#8  0x00007fb73654c067 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fff02323af0, node=0x220c150) at ../../messageviewer/objecttreeparser.cpp:278
#9  0x00007fb7365808df in MessageViewer::ViewerPrivate::parseContent (this=0x28ca3c0, content=0x220c150) at ../../messageviewer/viewer_p.cpp:857
#10 0x00007fb736583434 in MessageViewer::ViewerPrivate::displayMessage (this=0x28ca3c0) at ../../messageviewer/viewer_p.cpp:729
#11 0x00007fb736583ce2 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x28ca3c0) at ../../messageviewer/viewer_p.cpp:1946
#12 0x00007fb73658718d in MessageViewer::ViewerPrivate::qt_metacall (this=0x28ca3c0, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0x7fff02323fb0) at ./viewer_p.moc:220
#13 0x00007fb73d42feba in QMetaObject::activate (sender=0x28ca448, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#14 0x00007fb73d433789 in QObject::event (this=0x28ca448, e=<optimized out>) at kernel/qobject.cpp:1181
#15 0x00007fb73d94d424 in notify_helper (e=0x7fff02324510, receiver=0x28ca448, this=0x1e88700) at kernel/qapplication.cpp:4486
#16 QApplicationPrivate::notify_helper (this=0x1e88700, receiver=0x28ca448, e=0x7fff02324510) at kernel/qapplication.cpp:4458
#17 0x00007fb73d952291 in QApplication::notify (this=0x7fff023248d0, receiver=0x28ca448, e=0x7fff02324510) at kernel/qapplication.cpp:4365
#18 0x00007fb73f16e126 in KApplication::notify (this=0x7fff023248d0, receiver=0x28ca448, event=0x7fff02324510) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007fb73d41cafc in QCoreApplication::notifyInternal (this=0x7fff023248d0, receiver=0x28ca448, event=0x7fff02324510) at kernel/qcoreapplication.cpp:787
#20 0x00007fb73d449d62 in sendEvent (event=0x7fff02324510, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QTimerInfoList::activateTimers (this=0x1e8c270) at kernel/qeventdispatcher_unix.cpp:603
#22 0x00007fb73d447514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#23 0x00007fb73551ea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fb73551f258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fb73551f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fb73d447ed6 in QEventDispatcherGlib::processEvents (this=0x1e3cf70, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#27 0x00007fb73d9f507e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fb73d41bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007fb73d41bef7 in QEventLoop::exec (this=0x7fff023247a0, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007fb73d420789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#31 0x0000000000402bd3 in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:145

Reported using DrKonqi
Comment 1 MK 2011-11-07 18:08:19 UTC
Additional info: I didn't leave the gpg dialogue open, but clicked "cancel" and left the following window open. With message field something like "PGP-warning: passphrase wrong. Do you want to retry?"

Then I went on to kwallet.
Comment 2 Christophe Marin 2011-11-18 23:01:59 UTC

*** This bug has been marked as a duplicate of bug 279749 ***