Bug 291932 - okular error with review
Summary: okular error with review
Status: RESOLVED DUPLICATE of bug 291278
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 09:01 UTC by karl
Modified: 2012-01-19 11:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.11 KB, text/plain)
2012-01-19 10:49 UTC, Germano Massullo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karl 2012-01-19 09:01:32 UTC
Application: okular (0.13.3)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.7-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
i opened the review and it broke down

The crash can be reproduced every time.

-- Backtrace:
Application: Okular (okular), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  row (this=0x0) at /usr/src/debug/okular-4.7.4/ui/annotationproxymodels.cpp:312
#7  AuthorGroupProxyModel::parent (this=0x1a7e380, index=...) at /usr/src/debug/okular-4.7.4/ui/annotationproxymodels.cpp:403
#8  0x0000003c4f32b4ff in parent (this=0x7fffb2cdecb0) at ../../src/corelib/kernel/qabstractitemmodel.h:393
#9  QTreeView::isIndexHidden (this=0x1972cf0, index=...) at itemviews/qtreeview.cpp:2873
#10 0x0000003c4f329f21 in QTreeView::visualRect (this=0x1972cf0, index=...) at itemviews/qtreeview.cpp:1045
#11 0x0000003c4f2e46a7 in QAbstractItemViewPrivate::sendDelegateEvent (this=0x1a48e60, index=..., event=0x7fffb2cdfbb0) at itemviews/qabstractitemview.cpp:4173
#12 0x0000003c4f2eba0c in QAbstractItemView::edit (this=0x1972cf0, index=..., trigger=QAbstractItemView::NoEditTriggers, event=0x7fffb2cdfbb0) at itemviews/qabstractitemview.cpp:2560
#13 0x0000003c4f2e85ca in QAbstractItemView::mousePressEvent (this=0x1972cf0, event=0x7fffb2cdfbb0) at itemviews/qabstractitemview.cpp:1674
#14 0x0000003c4ee1a319 in QWidget::event (this=0x1972cf0, event=0x7fffb2cdfbb0) at kernel/qwidget.cpp:8357
#15 0x0000003c4f1d1b86 in QFrame::event (this=0x1972cf0, e=0x7fffb2cdfbb0) at widgets/qframe.cpp:557
#16 0x0000003c4f2e38bb in QAbstractItemView::viewportEvent (this=0x1972cf0, event=0x7fffb2cdfbb0) at itemviews/qabstractitemview.cpp:1644
#17 0x0000003c4f32b1b5 in QTreeView::viewportEvent (this=0x1972cf0, event=0x7fffb2cdfbb0) at itemviews/qtreeview.cpp:1257
#18 0x00000037fb9791c8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x1a495c0, event=0x7fffb2cdfbb0) at kernel/qcoreapplication.cpp:986
#19 0x0000003c4edc995f in notify_helper (e=0x7fffb2cdfbb0, receiver=0x1a495c0, this=0x17b9fb0) at kernel/qapplication.cpp:4546
#20 QApplicationPrivate::notify_helper (this=0x17b9fb0, receiver=0x1a495c0, e=0x7fffb2cdfbb0) at kernel/qapplication.cpp:4522
#21 0x0000003c4edcf0e3 in QApplication::notify (this=<optimized out>, receiver=0x1a495c0, e=0x7fffb2cdfbb0) at kernel/qapplication.cpp:4093
#22 0x0000003c50450766 in KApplication::notify (this=0x7fffb2ce08b0, receiver=0x1a495c0, event=0x7fffb2cdfbb0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#23 0x00000037fb97903c in QCoreApplication::notifyInternal (this=0x7fffb2ce08b0, receiver=0x1a495c0, event=0x7fffb2cdfbb0) at kernel/qcoreapplication.cpp:876
#24 0x0000003c4edca962 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#25 QApplicationPrivate::sendMouseEvent (receiver=0x1a495c0, event=0x7fffb2cdfbb0, alienWidget=0x1a495c0, nativeWidget=0x1994b70, buttonDown=0x1a495c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3161
#26 0x0000003c4ee462e5 in QETWidget::translateMouseEvent (this=0x1994b70, event=<optimized out>) at kernel/qapplication_x11.cpp:4521
#27 0x0000003c4ee451aa in QApplication::x11ProcessEvent (this=0x7fffb2ce08b0, event=0x7fffb2ce0470) at kernel/qapplication_x11.cpp:3641
#28 0x0000003c4ee6c92c in x11EventSourceDispatch (s=0x17c0f80, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#29 0x00000037f2c44a7d in g_main_dispatch (context=0x17bf5e0) at gmain.c:2425
#30 g_main_context_dispatch (context=0x17bf5e0) at gmain.c:2995
#31 0x00000037f2c45278 in g_main_context_iterate (context=0x17bf5e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#32 0x00000037f2c4544c in g_main_context_iteration (context=0x17bf5e0, may_block=1) at gmain.c:3136
#33 0x00000037fb9a7d4f in QEventDispatcherGlib::processEvents (this=0x1797990, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#34 0x0000003c4ee6c61e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#35 0x00000037fb978172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00000037fb9783c7 in QEventLoop::exec (this=0x7fffb2ce0840, flags=...) at kernel/qeventloop.cpp:204
#37 0x00000037fb97cdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#38 0x0000000000407aa6 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/okular-4.7.4/shell/main.cpp:85

Possible duplicates by query: bug 291278.

Reported using DrKonqi
Comment 1 Germano Massullo 2012-01-19 10:49:15 UTC
Created attachment 67997 [details]
New crash information added by DrKonqi

okular (0.13.3) on KDE Platform 4.7.4 (4.7.4) using Qt 4.8.0

- What I was doing when the application crashed:

I wanted to erase some colored marks that I putted on some phrases. So I opened review menù, opened n page submenu, and when I clicked onto the menu entry, Okular crashed. It happens everytime

-- Backtrace (Reduced):
#8  0x4a9bab0a in parent (this=0xbf910dc0) at ../../src/corelib/kernel/qabstractitemmodel.h:393
#9  QTreeView::isIndexHidden (this=0x87cd108, index=...) at itemviews/qtreeview.cpp:2873
#10 0x4a9b935f in QTreeView::visualRect (this=0x87cd108, index=...) at itemviews/qtreeview.cpp:1045
#11 0x4a96cd7c in QAbstractItemViewPrivate::sendDelegateEvent (this=0x87cd420, index=..., event=0xbf911804) at itemviews/qabstractitemview.cpp:4173
#12 0x4a974aff in QAbstractItemView::edit (this=0x87cd108, index=..., trigger=QAbstractItemView::NoEditTriggers, event=0xbf911804) at itemviews/qabstractitemview.cpp:2560
Comment 2 Albert Astals Cid 2012-01-19 11:00:21 UTC

*** This bug has been marked as a duplicate of bug 291278 ***