Bug 291278 - Okular crashes when annotation author name in the sidebar listing is clicked
Summary: Okular crashes when annotation author name in the sidebar listing is clicked
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 291932 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-11 16:55 UTC by Juhamatti Niemelä
Modified: 2012-01-19 11:00 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments
PDF made with Libre Office Writer for testing. (29.05 KB, application/pdf)
2012-01-11 16:56 UTC, Juhamatti Niemelä
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juhamatti Niemelä 2012-01-11 16:55:25 UTC
Application: okular (0.13.3)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.5-6.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
I was trying to access annotation from Reviews sidebar by clicking annotation author name.

Steps to Reproduce:
1. Open pdf in Okular
2. Press F6 to get review tools
3. Add any review marking. Eg. Note.
4. Select reviews from sidebar
5. Click annotation author name in the annotations list sidebar
6. Okular crashes

The crash can be reproduced every time.

-- Backtrace:
Application: Okular (okular), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  row (this=0x0) at /usr/src/debug/okular-4.7.4/ui/annotationproxymodels.cpp:312
#7  AuthorGroupProxyModel::parent (this=0xf8c0a0, index=...) at /usr/src/debug/okular-4.7.4/ui/annotationproxymodels.cpp:403
#8  0x00007f0d8c0bc4ff in parent (this=0x7fffe15f2410) at ../../src/corelib/kernel/qabstractitemmodel.h:393
#9  QTreeView::isIndexHidden (this=0xe68bf0, index=...) at itemviews/qtreeview.cpp:2873
#10 0x00007f0d8c0baf21 in QTreeView::visualRect (this=0xe68bf0, index=...) at itemviews/qtreeview.cpp:1045
#11 0x00007f0d8c0756a7 in QAbstractItemViewPrivate::sendDelegateEvent (this=0xf56c60, index=..., event=0x7fffe15f3310) at itemviews/qabstractitemview.cpp:4173
#12 0x00007f0d8c07ca0c in QAbstractItemView::edit (this=0xe68bf0, index=..., trigger=QAbstractItemView::NoEditTriggers, event=0x7fffe15f3310) at itemviews/qabstractitemview.cpp:2560
#13 0x00007f0d8c0795ca in QAbstractItemView::mousePressEvent (this=0xe68bf0, event=0x7fffe15f3310) at itemviews/qabstractitemview.cpp:1674
#14 0x00007f0d8bbab319 in QWidget::event (this=0xe68bf0, event=0x7fffe15f3310) at kernel/qwidget.cpp:8357
#15 0x00007f0d8bf62b86 in QFrame::event (this=0xe68bf0, e=0x7fffe15f3310) at widgets/qframe.cpp:557
#16 0x00007f0d8c0748bb in QAbstractItemView::viewportEvent (this=0xe68bf0, event=0x7fffe15f3310) at itemviews/qabstractitemview.cpp:1644
#17 0x00007f0d8c0bc1b5 in QTreeView::viewportEvent (this=0xe68bf0, event=0x7fffe15f3310) at itemviews/qtreeview.cpp:1257
#18 0x00007f0d8af001c8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0xf573c0, event=0x7fffe15f3310) at kernel/qcoreapplication.cpp:986
#19 0x00007f0d8bb5a95f in notify_helper (e=0x7fffe15f3310, receiver=0xf573c0, this=0xc8d590) at kernel/qapplication.cpp:4546
#20 QApplicationPrivate::notify_helper (this=0xc8d590, receiver=0xf573c0, e=0x7fffe15f3310) at kernel/qapplication.cpp:4522
#21 0x00007f0d8bb600e3 in QApplication::notify (this=<optimized out>, receiver=0xf573c0, e=0x7fffe15f3310) at kernel/qapplication.cpp:4093
#22 0x00007f0d8c899766 in KApplication::notify (this=0x7fffe15f4010, receiver=0xf573c0, event=0x7fffe15f3310) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#23 0x00007f0d8af0003c in QCoreApplication::notifyInternal (this=0x7fffe15f4010, receiver=0xf573c0, event=0x7fffe15f3310) at kernel/qcoreapplication.cpp:876
#24 0x00007f0d8bb5b962 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#25 QApplicationPrivate::sendMouseEvent (receiver=0xf573c0, event=0x7fffe15f3310, alienWidget=0xf573c0, nativeWidget=0xe76ab0, buttonDown=0xf573c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3161
#26 0x00007f0d8bbd72e5 in QETWidget::translateMouseEvent (this=0xe76ab0, event=<optimized out>) at kernel/qapplication_x11.cpp:4521
#27 0x00007f0d8bbd61aa in QApplication::x11ProcessEvent (this=0x7fffe15f4010, event=0x7fffe15f3bd0) at kernel/qapplication_x11.cpp:3641
#28 0x00007f0d8bbfd92c in x11EventSourceDispatch (s=0xc92520, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#29 0x00007f0d85befa7d in g_main_dispatch (context=0xc8de00) at gmain.c:2425
#30 g_main_context_dispatch (context=0xc8de00) at gmain.c:2995
#31 0x00007f0d85bf0278 in g_main_context_iterate (context=0xc8de00, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#32 0x00007f0d85bf044c in g_main_context_iteration (context=0xc8de00, may_block=1) at gmain.c:3136
#33 0x00007f0d8af2ed4f in QEventDispatcherGlib::processEvents (this=0xc69990, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#34 0x00007f0d8bbfd61e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#35 0x00007f0d8aeff172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f0d8aeff3c7 in QEventLoop::exec (this=0x7fffe15f3fa0, flags=...) at kernel/qeventloop.cpp:204
#37 0x00007f0d8af03dc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#38 0x0000000000407aa6 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/okular-4.7.4/shell/main.cpp:85

Reported using DrKonqi
Comment 1 Juhamatti Niemelä 2012-01-11 16:56:45 UTC
Created attachment 67702 [details]
PDF made with Libre Office Writer for testing.
Comment 2 Thiago Macieira 2012-01-11 18:00:55 UTC
Confirmed with okular at v4.7.90-31-ga6dba24
Comment 3 Albert Astals Cid 2012-01-16 20:05:48 UTC
Git commit 2c9122192d2995371d1a72700be5e95c41018941 by Albert Astals Cid.
Committed on 16/01/2012 at 21:04.
Pushed by aacid into branch 'KDE/4.8'.

Qt decided to start passing invalid indexes to mapFromSource, do not crash on them
FIXED-IN: 4.8.0

M  +3    -0    ui/annotationproxymodels.cpp

http://commits.kde.org/okular/2c9122192d2995371d1a72700be5e95c41018941
Comment 4 Albert Astals Cid 2012-01-16 20:09:23 UTC
Git commit 7884c879a757384c895ea53ac0301e72efd4c111 by Albert Astals Cid.
Committed on 16/01/2012 at 21:04.
Pushed by aacid into branch 'master'.

Qt decided to start passing invalid indexes to mapFromSource, do not crash on them
FIXED-IN: 4.8.0

M  +3    -0    ui/annotationproxymodels.cpp

http://commits.kde.org/okular/7884c879a757384c895ea53ac0301e72efd4c111
Comment 5 Albert Astals Cid 2012-01-19 11:00:21 UTC
*** Bug 291932 has been marked as a duplicate of this bug. ***