Bug 291899 - Kmail deletes mail marked as ham after new start
Summary: Kmail deletes mail marked as ham after new start
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: filtering (show other bugs)
Version: 4.8
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 21:05 UTC by christian-schaefer
Modified: 2012-04-08 15:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christian-schaefer 2012-01-18 21:05:54 UTC
Version:           4.8 (using Devel) 
OS:                Linux

kmail 4.8rc2 (kubuntu ppa packages)
KDE 4.7.97 (kubuntu ppa packages)

When an e-mail is marked manually as ham some error messages appear (Translated from German: "The Ressource Kmail-Folder is not unfunctional. The Resource is now online" and "Kmail-Folder: messages in the folder inbox can not be modified"). 
After a closing down and opening up KMail again the message is deleted and not available anymore.

Reproducible: Always

Steps to Reproduce:
- Mark message manually as ham. (Error messages appear)
- Close Kmail
- Open Kmail
- Message marked as ham is deleted after a few minutes


Actual Results:  
message is marked as ham but deleted after a few minuts

Expected Results:  
message is marked as ham and not deleted

might be related to Bug 291042 at least the spam filter was also set up using the wizard
Comment 1 eric 2012-01-29 03:23:44 UTC
Yep, same problem here... it has been like this since beta2.

E-mails that are read and marked as HAM manually (not automatically by a filter rule) will be deleted the next time Kmail/Kontact is started.

This is how I can reproduce the behaviour:

1) Read an unread e-mail and then mark it as HAM. Marking the e-mail as HAM without reading will work correctly. Reading and marking should happen within the same session (without a restart of Kmail/Kontact).

2) After reading and marking, quit Kmail/Kontact, wait 10 minutes (or longer) and then start Kmail/Kontact. Starting Kontact/Kmail immediately after quitting may not show the wrong behaviour.

3) After starting Kmail/Kontact you can see the e-mail for a few seconds and then it disappears.

I've experienced the same behaviour with e-mails marked as something else than HAM and also e-mails that I'm going to send located in the outbox (these are very handy for testing).

This bug may be the same as:
https://bugs.kde.org/show_bug.cgi?id=289428
Comment 2 Tobias Koenig 2012-02-11 10:43:28 UTC
Hej,

this indeed looks like a duplicate of bug #289428 which has been fixed a couple of minutes ago in 4.8 branch and master. (see http://commits.kde.org/kdepim-runtime/13a5b94bf6a95e84675de540415877ab0ab212e9).
Can you retest, please?

Ciao,
Tobias
Comment 3 christian-schaefer 2012-04-08 15:35:27 UTC
Hej,

The latest version I have now is 4.8.2. The e-mails don't get deleted anymore but there is also no visual indication in the e-mail list anymore (in the form of the green hook) after having performed the manual filtering. But the visual indication is probably a different bug...