Bug 291042 - kmail2: "failed to change the flag" - error messages on marking mails as ham
Summary: kmail2: "failed to change the flag" - error messages on marking mails as ham
Status: RESOLVED DUPLICATE of bug 289428
Alias: None
Product: kmail2
Classification: Unclassified
Component: filtering (show other bugs)
Version: 4.8
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-09 10:49 UTC by Robby Engelmann
Modified: 2012-02-11 23:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robby Engelmann 2012-01-09 10:49:31 UTC
Version:           4.8
OS:                Linux

If I manually mark mails as ham the error: "Local folders: Failed to change the flags for the mail" appears, but in listview of the mails, the flag has change to ham.

Reproducible: Always

Steps to Reproduce:
-set up filter using "anti-spam wizzard" (using spamassassin)
-manually mark a mail in a local folder as ham


Actual Results:  
error message pops up

Expected Results:  
no error message

using KDE 4.8 RC2

Filter "classify as NOT spam":
mark as: ham
execute command: sa-learn -L --ham --no-sync
pipe through: spamassassin -d
Comment 1 Tobias Koenig 2012-02-11 23:28:27 UTC

*** This bug has been marked as a duplicate of bug 289428 ***