Bug 291857 - KDED crashes at login
Summary: KDED crashes at login
Status: RESOLVED DUPLICATE of bug 287560
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 12:12 UTC by René Serral
Modified: 2012-01-18 15:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Serral 2012-01-18 12:12:02 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.7.98 (4.8 RC2+ (4.7.98) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.2.1 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

Everytime I login to my system KDED crashes. I'm using a recent git pull of the 4.8 branch.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0x7f223dda6760 (LWP 3485))]

Thread 2 (Thread 0x7f222101e700 (LWP 3508)):
#0  0x00007f223a944863 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2236ec35d8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2236ec3a99 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f223c637e96 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f223c60c492 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f223c60c68f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f223c52430f in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f223c5ef35f in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f223c526cf5 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f223c296b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f223a94f4ad in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f223dda6760 (LWP 3485)):
[KCrash Handler]
#6  0x00007f223a8ac405 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#7  0x00007f223a8af680 in abort () from /lib/x86_64-linux-gnu/libc.so.6
#8  0x00007f223c51d571 in qt_message_output(QtMsgType, char const*) () from /usr/lib/libQtCore.so.4
#9  0x00007f223c51d8ef in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f223c51da94 in qFatal(char const*, ...) () from /usr/lib/libQtCore.so.4
#11 0x00007f223cc79915 in KConfigGroup::groupImpl (this=0x7fff90678380, aGroup=...) at /media/kdesvn/kde4svn/src/kdelibs/kdecore/config/kconfiggroup.cpp:516
#12 0x00007f223cc76988 in KConfigBase::group (this=0x7fff90678380, str=...) at /media/kdesvn/kde4svn/src/kdelibs/kdecore/config/kconfigbase.cpp:51
#13 0x00007f222416e2bf in PowerDevil::Core::loadProfile (this=0x1001b40, force=true) at /media/kdesvn/kde4svn/src/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:267
#14 0x00007f222416dee3 in PowerDevil::Core::refreshStatus (this=0x1001b40) at /media/kdesvn/kde4svn/src/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:236
#15 0x00007f222416d45d in PowerDevil::Core::onBackendReady (this=0x1001b40) at /media/kdesvn/kde4svn/src/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:153
#16 0x00007f222417182b in PowerDevil::Core::qt_metacall (this=0x1001b40, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0x7fff90678ea0) at /media/kdesvn/kde4svn/build/kde-workspace/powerdevil/daemon/powerdevilcore.moc:168
#17 0x00007f223c61feba in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#18 0x00007f222416b5df in PowerDevil::BackendInterface::backendReady (this=0xf23880) at /media/kdesvn/kde4svn/build/kde-workspace/powerdevil/daemon/powerdevilbackendinterface.moc:146
#19 0x00007f222416b04a in PowerDevil::BackendInterface::setBackendIsReady (this=0xf23880, availableBrightnessControls=..., supportedSuspendMethods=...) at /media/kdesvn/kde4svn/src/kde-workspace/powerdevil/daemon/powerdevilbackendinterface.cpp:120
#20 0x00007f22243a6ccb in PowerDevilUPowerBackend::init (this=0xf23880) at /media/kdesvn/kde4svn/src/kde-workspace/powerdevil/daemon/backends/upower/powerdevilupowerbackend.cpp:151
#21 0x00007f222416cd6f in PowerDevil::Core::loadCore (this=0x1001b40, backend=0xf23880) at /media/kdesvn/kde4svn/src/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:84
#22 0x00007f22243a27d9 in KDEDPowerDevil::init (this=0xf2dde0) at /media/kdesvn/kde4svn/src/kde-workspace/powerdevil/daemon/kdedpowerdevil.cpp:89
#23 0x00007f22243a2bf8 in KDEDPowerDevil::qt_metacall (this=0xf2dde0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xf2e190) at /media/kdesvn/kde4svn/build/kde-workspace/powerdevil/daemon/kdedpowerdevil.moc:73
#24 0x00007f223c623a6a in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#25 0x00007f223b7c2c64 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0x00007f223b7c7af1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0x00007f223d6df223 in KApplication::notify (this=0x7fff90679f80, receiver=0xf2dde0, event=0xd76260) at /media/kdesvn/kde4svn/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#28 0x00007f223c60d28c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#29 0x00007f223c610648 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#30 0x00007f223c6379d3 in ?? () from /usr/lib/libQtCore.so.4
#31 0x00007f2236ec30cf in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f2236ec38c8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f2236ec3a99 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f223c637e2f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0x00007f223b866eee in ?? () from /usr/lib/libQtGui.so.4
#36 0x00007f223c60c492 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0x00007f223c60c68f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#38 0x00007f223c610837 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#39 0x00007f2229b66735 in kdemain (argc=1, argv=0xd3eea0) at /media/kdesvn/kde4svn/src/kdelibs/kded/kded.cpp:924
#40 0x00000000004072d8 in launch (argc=1, _name=0x40de6c "kded4", args=0x0, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40d737 "0") at /media/kdesvn/kde4svn/src/kdelibs/kinit/kinit.cpp:734
#41 0x000000000040a4b4 in main (argc=4, argv=0x7fff9067a868, envp=0x7fff9067a890) at /media/kdesvn/kde4svn/src/kdelibs/kinit/kinit.cpp:1849

This bug may be a duplicate of or related to bug 287560.

Possible duplicates by query: bug 291369, bug 287560.

Reported using DrKonqi
Comment 1 Thijs 2012-01-18 15:02:23 UTC

*** This bug has been marked as a duplicate of bug 287560 ***