Bug 291709 - Add nick/tab completion to group chat
Summary: Add nick/tab completion to group chat
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: text-ui (show other bugs)
Version: git-latest
Platform: Gentoo Packages Linux
: NOR wishlist
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords: junior-jobs
: 308477 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-16 22:10 UTC by Elias Probst
Modified: 2013-03-05 20:43 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2012-01-16 22:10:39 UTC
Version:           git-latest (using Devel) 
OS:                Linux

Add tab based nick completion to the group chat.
The completion list should simply reflect the chat member names as listed in the chat member panel of the window.

The completion list should not use other identifiers for the members, e.g.
"John Doe" (full/display name) is shown in the list
"johnd" (alias) is used for completion
This would only confuse the user.

Reproducible: Didn't try



Expected Results:  
See initial description
Comment 1 David Edmundson 2012-02-06 14:18:01 UTC
See "src/viewer/ircinput.cpp" from Konversation. Steal relevant code and add to ChatTextEdit.
List of group members is available in the ChannelContactModel.
Comment 2 Elias Probst 2012-02-06 14:23:58 UTC
(In reply to comment #1)
> See "src/viewer/ircinput.cpp" from Konversation. Steal relevant code and add to
> ChatTextEdit.
> List of group members is available in the ChannelContactModel.

While we're at it… here's a link to this file:
https://projects.kde.org/projects/extragear/network/konversation/repository/revisions/master/entry/src/viewer/ircinput.cpp
Comment 3 David Edmundson 2012-10-16 17:43:07 UTC
*** Bug 308477 has been marked as a duplicate of this bug. ***
Comment 4 Martin Holec 2012-12-15 13:56:24 UTC
Hey, what's up with this bug? Nearly all Jabber clients, which supports MUC have TAB completition.
Comment 5 Martin Klapetek 2012-12-15 19:52:29 UTC
Not much. There are currently more important/deeper changes going on "under the hood", most of our developers are otherwise occupied, so there's really noone to take care of the small-and-helpful features for now.

However if anyone feels like, just follow the steps posted by David, should be fairly easy.
Comment 6 Daniel Vrátil 2012-12-17 09:55:53 UTC
Git commit a75ac9592499aab85bdf1be34fb81a913413d709 by Dan Vrátil.
Committed on 17/12/2012 at 10:55.
Pushed by dvratil into branch 'master'.

Nick completion in MUC

Add Konversation-like nick completion on Tab keypress
REVIEW: 107773

M  +10   -0    lib/channel-contact-model.cpp
M  +5    -4    lib/channel-contact-model.h
M  +150  -3    lib/chat-text-edit.cpp
M  +12   -0    lib/chat-text-edit.h
M  +5    -0    lib/chat-widget.cpp

http://commits.kde.org/telepathy-text-ui/a75ac9592499aab85bdf1be34fb81a913413d709
Comment 7 Martin Holec 2012-12-17 14:01:13 UTC
Thank you for your quick response and fix.