Bug 290400 - After configuring toolbar, the "Show Toolbar" action is placed at wrong position under the settings menu
Summary: After configuring toolbar, the "Show Toolbar" action is placed at wrong posit...
Status: RESOLVED DUPLICATE of bug 306258
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 1.99
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-02 14:00 UTC by Jekyll Wu
Modified: 2012-09-24 13:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
show toolbar is placed at the wrong place (251.23 KB, image/png)
2012-01-02 14:00 UTC, Jekyll Wu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jekyll Wu 2012-01-02 14:00:49 UTC
Created attachment 67340 [details]
show toolbar is placed at the wrong place

Version:           1.99 (using Devel) 
OS:                Linux

The attached screenshot shows the problem quite clearly. 

Reproducible: Always

Steps to Reproduce:
1. right click on the toolbar, choose "configure toolbar"
2. add the "Home" action
3. the dolphin window splashes for a short time
4. open the "Settings" menu

Actual Results:  
"Show Toolbar" is placed under "Configure Dolphin"

Expected Results:  
"Show Toolbar" is placed under "Show Menubar", staying at its original place
Comment 1 Sebastian Dörner 2012-01-03 21:55:21 UTC
This is a bug in kdelibs or its usage. It occurs in 4.7.4 as well, but also in Okular (add arbitary button to the tool bar and the "show toolbar" entry in the settings menu moves).

It might be a duplicate of http://bugs.kde.org/show_bug.cgi?id=64754 , but this report here seems more clear.
http://bugs.kde.org/show_bug.cgi?id=180756 might be related as well
Comment 2 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:19:32 UTC
Resetting assignee to default as per bug #305719
Comment 3 Jekyll Wu 2012-09-24 13:22:38 UTC
This problem disappears after http://commits.kde.org/kdelibs/eafa8bf55e87595bf975b0654506b932f4b19a76 for bug 306528.

*** This bug has been marked as a duplicate of bug 306528 ***
Comment 4 Jekyll Wu 2012-09-24 13:25:46 UTC
(In reply to comment #3)
> This problem disappears after
> http://commits.kde.org/kdelibs/eafa8bf55e87595bf975b0654506b932f4b19a76 for
> bug 306528.
> 
> *** This bug has been marked as a duplicate of bug 306528 ***

Typo. should be bug 306258

*** This bug has been marked as a duplicate of bug 306258 ***