Bug 290177 - Changing Master-Control via KMix main menu does not change Master-Control in Tray
Summary: Changing Master-Control via KMix main menu does not change Master-Control in ...
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: 4
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
: 287146 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-30 13:37 UTC by Christian Esken
Modified: 2012-09-11 21:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Esken 2011-12-30 13:37:43 UTC
Version:           4 (using Devel) 
OS:                Linux

Changing the Master control via Tray context menu will change Master-Control in Tray - Good. But changing the Master control via KMix main menu does not change the Master-Control in the Tray - BAD.
This is taken from issue number 1 in bug 247933. 


Reproducible: Always

Steps to Reproduce:
see details

Actual Results:  
see details

Expected Results:  
see details
Comment 1 Christian Esken 2011-12-30 15:44:13 UTC
*** Bug 287146 has been marked as a duplicate of this bug. ***
Comment 2 Christian Esken 2012-07-03 21:21:19 UTC
A possible patch is on https://git.reviewboard.kde.org/r/105422/
Comment 3 Martin Sandsmark 2012-08-06 16:48:55 UTC
Should be fixed by a92a8c1c818f393833dc87d3b6eaaf669038d8c6.

Many thanks to Prasad Murthy.

:D
Comment 4 Martin Sandsmark 2012-09-11 21:55:52 UTC
Git commit 0addbb2d9cea4bef7146ccd35527af6113664fd1 by Martin T. H. Sandsmark.
Committed on 06/08/2012 at 18:42.
Pushed by sandsmark into branch 'KDE/4.9'.

Fix master channel selection via kmix main window issue and fix no global master found issue.

Fixes the issue where changing the master control in the KMix main
window doesn't change the master control in tray.

It also solves a problem with the dock icon appearing blank due to the
mixer not able to find any global master. The device id returns
something like "alsa_output.pci-0000_04_00.0.analog-surround-51" for 5.1
and "alsa_output.pci-0000_04_00.0.analog-stereo" for analog stereo and
hence the issue.

Patch by Prasad Murthy.
REVIEW: 105422

M  +8    -1    core/mixer.cpp
M  +3    -0    gui/kmixerwidget.cpp

http://commits.kde.org/kmix/0addbb2d9cea4bef7146ccd35527af6113664fd1