Bug 289762 - Bookmark editor crashes by moving many bookmarks into a folder
Summary: Bookmark editor crashes by moving many bookmarks into a folder
Status: RESOLVED DUPLICATE of bug 221866
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-25 01:17 UTC by Gatoso
Modified: 2011-12-25 08:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gatoso 2011-12-25 01:17:42 UTC
Application: keditbookmarks (4.7.4 (4.7.4))
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.1.3-1-pae i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

When I take many bookmarks and move them into a folder in the bookmark editor, it crashes.

It doesn't happen whether I move only one or two bookmarks, occurs when I move 6,7,8 and 9 bookmarks.

The crash can be reproduced every time.

-- Backtrace:
Application: Editor de marcadores (keditbookmarks), signal: Aborted
[KCrash Handler]
#7  0xb7873424 in __kernel_vsyscall ()
#8  0xb76b1dbf in raise () from /lib/libc.so.6
#9  0xb76b3765 in abort () from /lib/libc.so.6
#10 0xb5d730d2 in qt_message_output (msgType=QtFatalMsg, buf=0x9a35550 "ASSERT: \"false\" in file /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.4/kio/bookmarks/kbookmark.cc, line 489") at global/qglobal.cpp:2291
#11 0xb5d732ab in qt_message (msgType=QtFatalMsg, msg=0xb5efd798 "ASSERT: \"%s\" in file %s, line %d", ap=0xbfd54cf4 "0OU\267P\323V\267\351\001") at global/qglobal.cpp:2337
#12 0xb5d733c8 in qFatal (msg=0xb5efd798 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2520
#13 0xb5d73455 in qt_assert (assertion=0xb7554f30 "false", file=0xb756d350 "/home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.4/kio/bookmarks/kbookmark.cc", line=489) at global/qglobal.cpp:2036
#14 0xb74c9700 in KBookmark::address (this=0xbfd54db4) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.4/kio/bookmarks/kbookmark.cc:489
#15 0xb7676633 in MoveCommand::redo (this=0x9a2fe30) at /home/zuargo/Paquetes/kdebase/src/kde-baseapps-4.7.4/keditbookmarks/kbookmarkmodel/commands.cpp:376
#16 0xb6b985bb in QUndoCommand::redo (this=0x97bc730) at util/qundostack.cpp:208
#17 0xb6b9a1f5 in QUndoStack::push (this=0x98740bc, cmd=0x97bc730) at util/qundostack.cpp:541
#18 0xb7674008 in CommandHistory::addCommand (this=0x97d65a0, cmd=0x97bc730) at /home/zuargo/Paquetes/kdebase/src/kde-baseapps-4.7.4/keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#19 0xb767ac0b in KBookmarkModel::dropMimeData (this=0x9874f38, data=0x993e7f8, action=Qt::MoveAction, row=4, column=0, parent=...) at /home/zuargo/Paquetes/kdebase/src/kde-baseapps-4.7.4/keditbookmarks/kbookmarkmodel/model.cpp:380
#20 0xb6a0c636 in QAbstractItemView::dropEvent (this=0x9871748, event=0xbfd556d0) at itemviews/qabstractitemview.cpp:1990
#21 0xb645d67c in QWidget::event (this=0x9871748, event=0xbfd556d0) at kernel/qwidget.cpp:8485
#22 0xb68b6ac5 in QFrame::event (this=0x9871748, e=0xbfd556d0) at widgets/qframe.cpp:557
#23 0xb6955511 in QAbstractScrollArea::viewportEvent (this=0x9871748, e=0xbfd556d0) at widgets/qabstractscrollarea.cpp:1043
#24 0xb6a05cfc in QAbstractItemView::viewportEvent (this=0x9871748, event=0xbfd556d0) at itemviews/qabstractitemview.cpp:1628
#25 0xb6a56c26 in QTreeView::viewportEvent (this=0x9871748, event=0xbfd556d0) at itemviews/qtreeview.cpp:1256
#26 0xb6957e16 in viewportEvent (this=<optimized out>, event=0xbfd556d0) at widgets/qabstractscrollarea_p.h:100
#27 eventFilter (e=0xbfd556d0, this=<optimized out>, o=<optimized out>) at widgets/qabstractscrollarea_p.h:116
#28 QAbstractScrollAreaFilter::eventFilter (this=0x98e8bc8, o=0x98b6240, e=0xbfd556d0) at widgets/qabstractscrollarea_p.h:115
#29 0xb5e8bafc in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x97851c8, receiver=0x98b6240, event=0xbfd556d0) at kernel/qcoreapplication.cpp:902
#30 0xb63f8587 in notify_helper (e=0xbfd556d0, receiver=0x98b6240, this=0x97851c8) at kernel/qapplication.cpp:4477
#31 QApplicationPrivate::notify_helper (this=0x97851c8, receiver=0x98b6240, e=0xbfd556d0) at kernel/qapplication.cpp:4453
#32 0xb63feba8 in QApplication::notify (this=0x97851c8, receiver=0x98b6240, e=0xbfd556d0) at kernel/qapplication.cpp:4285
#33 0xb7024058 in KApplication::notify (this=0xbfd574ac, receiver=0x98b6240, event=0xbfd556d0) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#34 0xb5e8b8ce in QCoreApplication::notifyInternal (this=0xbfd574ac, receiver=0x98b6240, event=0xbfd556d0) at kernel/qcoreapplication.cpp:787
#35 0xb649c5c4 in sendEvent (event=0xbfd556d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QX11Data::xdndHandleDrop (this=0x9782b40, xe=0xbfd557a8, passive=false) at kernel/qdnd_x11.cpp:1183
#37 0xb649d888 in QDragManager::drop (this=0x9936340) at kernel/qdnd_x11.cpp:1725
#38 0xb64a096a in QDragManager::eventFilter (this=0x9936340, o=0x99379b0, e=0xbfd55c48) at kernel/qdnd_x11.cpp:1312
#39 0xb5e8b9d8 in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x97851c8, receiver=0x99379b0, event=0xbfd55c48) at kernel/qcoreapplication.cpp:883
#40 0xb63f850a in QApplicationPrivate::notify_helper (this=0x97851c8, receiver=0x99379b0, e=0xbfd55c48) at kernel/qapplication.cpp:4456
#41 0xb63ff56e in QApplication::notify (this=0x97851c8, receiver=0x99379b0, e=0xbfd55c48) at kernel/qapplication.cpp:4042
#42 0xb7024058 in KApplication::notify (this=0xbfd574ac, receiver=0x99379b0, event=0xbfd55c48) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#43 0xb5e8b8ce in QCoreApplication::notifyInternal (this=0xbfd574ac, receiver=0x99379b0, event=0xbfd55c48) at kernel/qcoreapplication.cpp:787
#44 0xb63f9b81 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#45 QApplicationPrivate::sendMouseEvent (receiver=0x99379b0, event=0xbfd55c48, alienWidget=0x0, nativeWidget=0x99379b0, buttonDown=0xb6e28a74, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#46 0xb6490aaf in QETWidget::translateMouseEvent (this=0x99379b0, event=0xbfd56020) at kernel/qapplication_x11.cpp:4461
#47 0xb648f29f in QApplication::x11ProcessEvent (this=0xbfd574ac, event=0xbfd56020) at kernel/qapplication_x11.cpp:3587
#48 0xb64bc7d4 in x11EventSourceDispatch (s=0x9781940, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#49 0xb53abadf in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#50 0xb53ac238 in g_main_context_iterate.isra.19 () from /usr/lib/libglib-2.0.so.0
#51 0xb53ac4ca in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#52 0xb5ebe6fa in QEventDispatcherGlib::processEvents (this=0x974c248, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#53 0xb64bc3ba in QGuiEventDispatcherGlib::processEvents (this=0x974c248, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0xb5e89f7d in QEventLoop::processEvents (this=0x992c258, flags=...) at kernel/qeventloop.cpp:149
#55 0xb5e8a1c9 in QEventLoop::exec (this=0x992c258, flags=...) at kernel/qeventloop.cpp:201
#56 0xb64a05bb in QDragManager::drag (this=0x9936340, o=0x98cdad0) at kernel/qdnd_x11.cpp:1981
#57 0xb640df35 in QDrag::exec (this=0x98cdad0, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#58 0xb6a10acc in QAbstractItemView::startDrag (this=0x9871748, supportedActions=...) at itemviews/qabstractitemview.cpp:3448
#59 0xb6a0f0d5 in QAbstractItemView::mouseMoveEvent (this=0x9871748, event=0xbfd56514) at itemviews/qabstractitemview.cpp:1709
#60 0xb6a54c2c in QTreeView::mouseMoveEvent (this=0x9871748, event=0xbfd56d28) at itemviews/qtreeview.cpp:1902
#61 0xb645da45 in QWidget::event (this=0x9871748, event=0xbfd56d28) at kernel/qwidget.cpp:8280
#62 0xb68b6ac5 in QFrame::event (this=0x9871748, e=0xbfd56d28) at widgets/qframe.cpp:557
#63 0xb6955511 in QAbstractScrollArea::viewportEvent (this=0x9871748, e=0xbfd56d28) at widgets/qabstractscrollarea.cpp:1043
#64 0xb6a05cfc in QAbstractItemView::viewportEvent (this=0x9871748, event=0xbfd56d28) at itemviews/qabstractitemview.cpp:1628
#65 0xb6a56c26 in QTreeView::viewportEvent (this=0x9871748, event=0xbfd56d28) at itemviews/qtreeview.cpp:1256
#66 0xb6957e16 in viewportEvent (this=<optimized out>, event=0xbfd56d28) at widgets/qabstractscrollarea_p.h:100
#67 eventFilter (e=0xbfd56d28, this=<optimized out>, o=<optimized out>) at widgets/qabstractscrollarea_p.h:116
#68 QAbstractScrollAreaFilter::eventFilter (this=0x98e8bc8, o=0x98b6240, e=0xbfd56d28) at widgets/qabstractscrollarea_p.h:115
#69 0xb5e8bafc in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x97851c8, receiver=0x98b6240, event=0xbfd56d28) at kernel/qcoreapplication.cpp:902
#70 0xb63f8587 in notify_helper (e=0xbfd56d28, receiver=0x98b6240, this=0x97851c8) at kernel/qapplication.cpp:4477
#71 QApplicationPrivate::notify_helper (this=0x97851c8, receiver=0x98b6240, e=0xbfd56d28) at kernel/qapplication.cpp:4453
#72 0xb63ff56e in QApplication::notify (this=0x97851c8, receiver=0x98b6240, e=0xbfd56d28) at kernel/qapplication.cpp:4042
#73 0xb7024058 in KApplication::notify (this=0xbfd574ac, receiver=0x98b6240, event=0xbfd56d28) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#74 0xb5e8b8ce in QCoreApplication::notifyInternal (this=0xbfd574ac, receiver=0x98b6240, event=0xbfd56d28) at kernel/qcoreapplication.cpp:787
#75 0xb63f9b81 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#76 QApplicationPrivate::sendMouseEvent (receiver=0x98b6240, event=0xbfd56d28, alienWidget=0x98b6240, nativeWidget=0x977d4d0, buttonDown=0xb6e28a74, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#77 0xb6490aaf in QETWidget::translateMouseEvent (this=0x977d4d0, event=0xbfd57100) at kernel/qapplication_x11.cpp:4461
#78 0xb648f29f in QApplication::x11ProcessEvent (this=0xbfd574ac, event=0xbfd57100) at kernel/qapplication_x11.cpp:3587
#79 0xb64bc7d4 in x11EventSourceDispatch (s=0x9781940, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#80 0xb53abadf in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#81 0xb53ac238 in g_main_context_iterate.isra.19 () from /usr/lib/libglib-2.0.so.0
#82 0xb53ac4ca in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#83 0xb5ebe6fa in QEventDispatcherGlib::processEvents (this=0x974c248, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#84 0xb64bc3ba in QGuiEventDispatcherGlib::processEvents (this=0x974c248, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#85 0xb5e89f7d in QEventLoop::processEvents (this=0xbfd57404, flags=...) at kernel/qeventloop.cpp:149
#86 0xb5e8a1c9 in QEventLoop::exec (this=0xbfd57404, flags=...) at kernel/qeventloop.cpp:201
#87 0xb5e8fead in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#88 0xb63f6384 in QApplication::exec () at kernel/qapplication.cpp:3755
#89 0xb7816b93 in kdemain (argc=6, argv=0xbfd57774) at /home/zuargo/Paquetes/kdebase/src/kde-baseapps-4.7.4/keditbookmarks/main.cpp:212
#90 0x080484bb in main (argc=6, argv=0xbfd57774) at /home/zuargo/Paquetes/kdebase/src/build/keditbookmarks/keditbookmarks_dummy.cpp:3

This bug may be a duplicate of or related to bug 221866.

Possible duplicates by query: bug 221866.

Reported using DrKonqi
Comment 1 Tommi Tervo 2011-12-25 08:51:33 UTC

*** This bug has been marked as a duplicate of bug 221866 ***