Bug 221866 - Moving multiple bookmarks to a folder crashes
Summary: Moving multiple bookmarks to a folder crashes
Status: RESOLVED DUPLICATE of bug 287038
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 289762 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-09 00:15 UTC by Christoph Feck
Modified: 2013-07-07 18:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2010-01-09 00:15:46 UTC
Application: keditbookmarks (4.4.59 (KDE 4.4.59 (KDE 4.5 >= 20100107)))
KDE Platform Version: 4.4.59 (KDE 4.4.59 (KDE 4.5 >= 20100107)) (Compiled from sources)
Qt Version: 4.6.1
Operating System: Linux 2.6.31.8-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

-- Information about the crash:
What I did:
* create a new bookmarks folder at toplevel
* Ctrl+click multiple bookmarks (more than 5?) in toplevel
* drag them to the new folder in the bookmarks view
-> crash
It looks like it works with only a few (3?) but moving many I can produce the crash very often.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Aborted
[KCrash Handler]
#6  0xffffe430 in __kernel_vsyscall ()
#7  0xb5b6d0cf in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb5b6e9e7 in abort () at abort.c:88
#9  0xb68ca724 in qt_message_output (msgType=QtFatalMsg, buf=0x6 <Address 0x6 out of bounds>) at global/qglobal.cpp:2227
#10 0xb68ca943 in qt_message (msgType=QtFatalMsg, msg=0xb6a4531c "ASSERT: \"%s\" in file %s, line %d", ap=0xbfb7b654 "\352qi\267\234pi\267\347\001") at global/qglobal.cpp:2273
#11 0xb68caa68 in qFatal (msg=0xb6a4531c "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2456
#12 0xb68caae5 in qt_assert (assertion=0xb76971ea "false", file=0xb769709c "/local/svn/kde/trunk/KDE/kdelibs/kio/bookmarks/kbookmark.cc", line=487) at global/qglobal.cpp:1990
#13 0xb75e75c4 in KBookmark::address (this=0xbfb7b6e4) at /local/svn/kde/trunk/KDE/kdelibs/kio/bookmarks/kbookmark.cc:487
#14 0xb77cd897 in MoveCommand::redo (this=0x85c52d0) at /local/svn/kde/trunk/KDE/kdebase/apps/keditbookmarks/commands.cpp:457
#15 0xb6620733 in QUndoCommand::redo (this=0x82b17d0) at util/qundostack.cpp:208
#16 0xb6621fd5 in QUndoStack::push (this=0x80f0140, cmd=0x82b17d0) at util/qundostack.cpp:541
#17 0xb77c4983 in CmdHistory::addCommand (this=0x80f0138, cmd=0x82b17d0) at /local/svn/kde/trunk/KDE/kdebase/apps/keditbookmarks/commandhistory.cpp:88
#18 0xb77e0ba5 in KBookmarkModel::dropMimeData (this=0x8155190, data=0x8270290, action=MoveAction, row=-1, column=-1, parent=...)
    at /local/svn/kde/trunk/KDE/kdebase/apps/keditbookmarks/bookmarkmodel.cpp:360
#19 0xb64a658a in QAbstractItemView::dropEvent (this=0x81565d8, event=0xbfb7c170) at itemviews/qabstractitemview.cpp:1962
#20 0xb5f741ef in QWidget::event (this=0x81565d8, event=0xbfb7c170) at kernel/qwidget.cpp:8168
#21 0xb635dee5 in QFrame::event (this=0x81565d8, e=0xbfb7c170) at widgets/qframe.cpp:557
#22 0xb63fac41 in QAbstractScrollArea::viewportEvent (this=0x4ebb, e=0x6) at widgets/qabstractscrollarea.cpp:1036
#23 0xb64b35fc in QAbstractItemView::viewportEvent (this=0x81565d8, event=0xbfb7c170) at itemviews/qabstractitemview.cpp:1603
#24 0xb64f5c11 in QTreeView::viewportEvent (this=0x81565d8, event=0xbfb7c170) at itemviews/qtreeview.cpp:1257
#25 0xb63fd536 in viewportEvent (event=<value optimized out>, this=<value optimized out>) at widgets/qabstractscrollarea_p.h:100
#26 QAbstractScrollAreaFilter::eventFilter (event=<value optimized out>, this=<value optimized out>) at widgets/qabstractscrollarea_p.h:116
#27 0xb69da35e in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8067a38, receiver=0x8157268, event=0xbfb7c170) at kernel/qcoreapplication.cpp:819
#28 0xb5f1365d in QApplicationPrivate::notify_helper (this=0x8067a38, receiver=0x8157268, e=0xbfb7c170) at kernel/qapplication.cpp:4293
#29 0xb5f1a9a6 in QApplication::notify (this=0x8157268, receiver=0x8157268, e=0xbfb7c170) at kernel/qapplication.cpp:4105
#30 0xb71cbd20 in KApplication::notify (this=0xbfb7e358, receiver=0x8157268, event=0xbfb7c170) at /local/svn/kde/trunk/KDE/kdelibs/kdeui/kernel/kapplication.cpp:302
#31 0xb69db08e in QCoreApplication::notifyInternal (this=0xbfb7e358, receiver=0x8157268, event=0xbfb7c170) at kernel/qcoreapplication.cpp:704
#32 0xb5fb5663 in sendEvent (event=<value optimized out>, receiver=0x806b6b0) at ../../src/corelib/kernel/qcoreapplication.h:215
#33 QX11Data::xdndHandleDrop (event=<value optimized out>, receiver=0x806b6b0) at kernel/qdnd_x11.cpp:1164
#34 0xb5fb59a5 in QDragManager::drop (this=0x82803e0) at kernel/qdnd_x11.cpp:1700
#35 0xb5fb7c22 in QDragManager::eventFilter (this=0x82803e0, o=0x838e428, e=0xbfb7c7a0) at kernel/qdnd_x11.cpp:1293
#36 0xb69da41b in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x8067a38, receiver=0x838e428, event=0xbfb7c7a0) at kernel/qcoreapplication.cpp:800
#37 0xb5f1360a in QApplicationPrivate::notify_helper (this=0x8067a38, receiver=0x838e428, e=0xbfb7c7a0) at kernel/qapplication.cpp:4272
#38 0xb5f1ae95 in QApplication::notify (this=0xbfb7c4d4, receiver=0x838e428, e=0xbfb7c7a0) at kernel/qapplication.cpp:3862
#39 0xb71cbd20 in KApplication::notify (this=0xbfb7e358, receiver=0x838e428, event=0xbfb7c7a0) at /local/svn/kde/trunk/KDE/kdelibs/kdeui/kernel/kapplication.cpp:302
#40 0xb69db08e in QCoreApplication::notifyInternal (this=0xbfb7e358, receiver=0x838e428, event=0xbfb7c7a0) at kernel/qcoreapplication.cpp:704
#41 0xb5f19de4 in sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:218
#42 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:2960
#43 0xb5fa73ea in QETWidget::translateMouseEvent (this=0x838e428, event=0xbfb7ccac) at kernel/qapplication_x11.cpp:4368
#44 0xb5fa6994 in QApplication::x11ProcessEvent (this=0xbfb7e358, event=0xbfb7ccac) at kernel/qapplication_x11.cpp:3379
#45 0xb5fd3ce8 in x11EventSourceDispatch (s=0x806aa40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#46 0xb55f44c2 in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#47 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#48 0xb55f7d98 in g_main_context_iterate (context=0x8069318, block=<value optimized out>, dispatch=1, self=0x8067b50) at gmain.c:2591
#49 0xb55f7ebe in IA__g_main_context_iteration (context=0x8069318, may_block=1) at gmain.c:2654
#50 0xb6a07c61 in QEventDispatcherGlib::processEvents (this=0x8067a18, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#51 0xb5fd383a in QGuiEventDispatcherGlib::processEvents (this=0x8067a18, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0xb69d96fd in QEventLoop::processEvents (this=0x82e4788, flags=) at kernel/qeventloop.cpp:149
#53 0xb69d9b49 in QEventLoop::exec (this=0x82e4788, flags=...) at kernel/qeventloop.cpp:201
#54 0xb5fbac13 in QDragManager::drag (this=0x82803e0, o=0x8184248) at kernel/qdnd_x11.cpp:1960
#55 0xb5f2c531 in QDrag::exec (this=0x8184248, supportedActions=) at kernel/qdrag.cpp:282
#56 0xb64b10f0 in QAbstractItemView::startDrag (this=0x81565d8, supportedActions=...) at itemviews/qabstractitemview.cpp:3375
#57 0xb64aedf4 in QAbstractItemView::mouseMoveEvent (this=0x81565d8, event=0xbfb7d18c) at itemviews/qabstractitemview.cpp:1684
#58 0xb64f5a7c in QTreeView::mouseMoveEvent (this=0x81565d8, event=0xbfb7dae0) at itemviews/qtreeview.cpp:1903
#59 0xb5f73e18 in QWidget::event (this=0x81565d8, event=0xbfb7dae0) at kernel/qwidget.cpp:7963
#60 0xb635dee5 in QFrame::event (this=0x81565d8, e=0xbfb7dae0) at widgets/qframe.cpp:557
#61 0xb63fac41 in QAbstractScrollArea::viewportEvent (this=0x4ebb, e=0x6) at widgets/qabstractscrollarea.cpp:1036
#62 0xb64b35fc in QAbstractItemView::viewportEvent (this=0x81565d8, event=0xbfb7dae0) at itemviews/qabstractitemview.cpp:1603
#63 0xb64f5c11 in QTreeView::viewportEvent (this=0x81565d8, event=0xbfb7dae0) at itemviews/qtreeview.cpp:1257
#64 0xb63fd536 in viewportEvent (event=<value optimized out>, this=<value optimized out>) at widgets/qabstractscrollarea_p.h:100
#65 QAbstractScrollAreaFilter::eventFilter (event=<value optimized out>, this=<value optimized out>) at widgets/qabstractscrollarea_p.h:116
#66 0xb69da35e in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8067a38, receiver=0x8157268, event=0xbfb7dae0) at kernel/qcoreapplication.cpp:819
#67 0xb5f1365d in QApplicationPrivate::notify_helper (this=0x8067a38, receiver=0x8157268, e=0xbfb7dae0) at kernel/qapplication.cpp:4293
#68 0xb5f1ae95 in QApplication::notify (this=0xbfb7d814, receiver=0x8157268, e=0xbfb7dae0) at kernel/qapplication.cpp:3862
#69 0xb71cbd20 in KApplication::notify (this=0xbfb7e358, receiver=0x8157268, event=0xbfb7dae0) at /local/svn/kde/trunk/KDE/kdelibs/kdeui/kernel/kapplication.cpp:302
#70 0xb69db08e in QCoreApplication::notifyInternal (this=0xbfb7e358, receiver=0x8157268, event=0xbfb7dae0) at kernel/qcoreapplication.cpp:704
#71 0xb5f19de4 in sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:218
#72 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:2960
#73 0xb5fa73ea in QETWidget::translateMouseEvent (this=0x81bd368, event=0xbfb7dfec) at kernel/qapplication_x11.cpp:4368
#74 0xb5fa6994 in QApplication::x11ProcessEvent (this=0xbfb7e358, event=0xbfb7dfec) at kernel/qapplication_x11.cpp:3379
#75 0xb5fd3ce8 in x11EventSourceDispatch (s=0x806aa40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#76 0xb55f44c2 in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#77 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#78 0xb55f7d98 in g_main_context_iterate (context=0x8069318, block=<value optimized out>, dispatch=1, self=0x8067b50) at gmain.c:2591
#79 0xb55f7ebe in IA__g_main_context_iteration (context=0x8069318, may_block=1) at gmain.c:2654
#80 0xb6a07c61 in QEventDispatcherGlib::processEvents (this=0x8067a18, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#81 0xb5fd383a in QGuiEventDispatcherGlib::processEvents (this=0x8067a18, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0xb69d96fd in QEventLoop::processEvents (this=0xbfb7e2a4, flags=) at kernel/qeventloop.cpp:149
#83 0xb69d9b49 in QEventLoop::exec (this=0xbfb7e2a4, flags=...) at kernel/qeventloop.cpp:201
#84 0xb69ddcc0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#85 0xb5f13734 in QApplication::exec () at kernel/qapplication.cpp:3576
#86 0xb77be0af in kdemain (argc=6, argv=0xbfb7e604) at /local/svn/kde/trunk/KDE/kdebase/apps/keditbookmarks/main.cpp:204
#87 0x08048709 in main (argc=6, argv=0xbfb7e604) at /local/build/KDE/kdebase/apps/keditbookmarks/keditbookmarks_dummy.cpp:3

Reported using DrKonqi
Comment 1 Tommi Tervo 2011-12-25 08:51:33 UTC
*** Bug 289762 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2013-07-07 18:13:42 UTC
This should be fixed with KDE 4.10.4, otherwise please add a comment.

*** This bug has been marked as a duplicate of bug 287038 ***