Bug 288571 - crash in kpasswd
Summary: crash in kpasswd
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kpasswdserver (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: HI crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 288784 290603 290777 291484 292034 292978 293126 293703 294257 294766 295192 295223 295509 297979 302349 302352 317728 318025 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-09 15:09 UTC by Jaime Torres
Modified: 2013-04-08 12:29 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Torres 2011-12-09 15:09:54 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-2-desktop x86_64
Distribution: "openSUSE 12.2 Milestone 0 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Introducing the router passwd in konqueror.

I can tell why it happened....
In kpasswdserver.cpp at line 676 there is:
    delete request;
At line 718 there is:
    m_authPrompted.removeAll(request->key);
(yes, request has been deleted previously).

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6a7fa23780 (LWP 6213))]

Thread 3 (Thread 0x7f6a683f9700 (LWP 6218)):
#0  0x00007f6a7c3293a3 in poll () from /lib64/libc.so.6
#1  0x00007f6a7880ea98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6a7880ef59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6a7e18a9ce in QEventDispatcherGlib::processEvents (this=0x140e040, flags=<optimized out>) at /g/kdegit/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f6a7e15acb2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at /g/kdegit/qt/src/corelib/kernel/qeventloop.cpp:149
#5  0x00007f6a7e15aedf in QEventLoop::exec (this=0x7f6a683f8dc0, flags=...) at /g/kdegit/qt/src/corelib/kernel/qeventloop.cpp:201
#6  0x00007f6a7e064fd9 in QThread::exec (this=<optimized out>) at /g/kdegit/qt/src/corelib/thread/qthread.cpp:498
#7  0x00007f6a7e13b773 in QInotifyFileSystemWatcherEngine::run (this=0xf13190) at /g/kdegit/qt/src/corelib/io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6a7e067e8a in QThreadPrivate::start (arg=0xf13190) at /g/kdegit/qt/src/corelib/thread/qthread_unix.cpp:331
#9  0x00007f6a7ddbdf05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6a7c3324bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f6a66e4c700 (LWP 6227)):
#0  0x00007f6a7c3293a3 in poll () from /lib64/libc.so.6
#1  0x00007f6a7880ea98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6a7880f2c2 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6a67331946 in ?? () from /usr/lib64/libgio-2.0.so.0
#4  0x00007f6a78833db6 in ?? () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f6a7ddbdf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6a7c3324bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f6a7fa23780 (LWP 6213)):
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x5a5a5a5a5a5a5a5a) at /usr/lib/qt4.5/include/QtCore/qatomic_x86_64.h:121
#7  0x00007f6a610bb86b in QList<QString>::removeAll (this=0xf14180, _t=<optimized out>) at /usr/lib/qt4.5/include/QtCore/qlist.h:761
#8  0x00007f6a610b9302 in KPasswdServer::processRequest (this=0xf14140) at /g/kdegit/kde-runtime/kpasswdserver/kpasswdserver.cpp:718
#9  0x00007f6a610b9c10 in KPasswdServer::qt_metacall (this=0xf14140, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0x1121080) at /g/b45/kde-runtime/kpasswdserver/kpasswdserver.moc:114
#10 0x00007f6a7e175a22 in QObject::event (this=0xf14140, e=<optimized out>) at /g/kdegit/qt/src/corelib/kernel/qobject.cpp:1217
#11 0x00007f6a7d1ec8de in notify_helper (e=0x1088a00, receiver=0xf14140, this=0xc358c0) at /g/kdegit/qt/src/gui/kernel/qapplication.cpp:4509
#12 QApplicationPrivate::notify_helper (this=0xc358c0, receiver=0xf14140, e=0x1088a00) at /g/kdegit/qt/src/gui/kernel/qapplication.cpp:4481
#13 0x00007f6a7d1f217a in QApplication::notify (this=0x7fff9aca7a70, receiver=0xf14140, e=0x1088a00) at /g/kdegit/qt/src/gui/kernel/qapplication.cpp:4474
#14 0x00007f6a7f1b67be in KApplication::notify (this=0x7fff9aca7a70, receiver=0xf14140, event=0x1088a00) at /g/kdegit/kdelibs/kdeui/kernel/kapplication.cpp:311
#15 0x00007f6a7e15c42b in QCoreApplication::notifyInternal (this=0x7fff9aca7a70, receiver=0xf14140, event=0x1088a00) at /g/kdegit/qt/src/corelib/kernel/qcoreapplication.cpp:787
#16 0x00007f6a7e1600a5 in QCoreApplication::sendEvent (event=0x1088a00, receiver=0xf14140) at ../../include/QtCore/../../../../kdegit/qt/src/corelib/kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc0a260) at /g/kdegit/qt/src/corelib/kernel/qcoreapplication.cpp:1428
#18 0x00007f6a7e18a513 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../../../kdegit/qt/src/corelib/kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=<optimized out>) at /g/kdegit/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:277
#20 0x00007f6a7880e58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f6a7880ed88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f6a7880ef59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f6a7e18a976 in QEventDispatcherGlib::processEvents (this=0xd1fb90, flags=<optimized out>) at /g/kdegit/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:422
#24 0x00007f6a7d29dac6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at /g/kdegit/qt/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f6a7e15acb2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at /g/kdegit/qt/src/corelib/kernel/qeventloop.cpp:149
#26 0x00007f6a7e15aedf in QEventLoop::exec (this=0x7fff9aca7a00, flags=...) at /g/kdegit/qt/src/corelib/kernel/qeventloop.cpp:201
#27 0x00007f6a7e160367 in QCoreApplication::exec () at /g/kdegit/qt/src/corelib/kernel/qcoreapplication.cpp:1064
#28 0x00007f6a6f21a790 in kdemain (argc=1, argv=0xd1fad0) at /g/kdegit/kdelibs/kded/kded.cpp:924
#29 0x000000000040845a in launch (argc=1, _name=0x40c2c0 "kded4", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40c019 "0") at /g/kdegit/kdelibs/kinit/kinit.cpp:734
#30 0x00000000004053ee in main (argc=4, argv=0x7fff9aca8308, envp=0x7fff9aca8330) at /g/kdegit/kdelibs/kinit/kinit.cpp:1849

Possible duplicates by query: bug 197676, bug 197045, bug 196849, bug 196118, bug 195058.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-12-12 11:17:57 UTC
*** Bug 288784 has been marked as a duplicate of this bug. ***
Comment 2 Dawit Alemayehu 2011-12-12 16:35:43 UTC
Git commit 4e85ba177ee9e9cb7faaf7419db306c391a00bb9 by Dawit Alemayehu.
Committed on 12/12/2011 at 16:41.
Pushed by adawit into branch 'master'.

Use QScopedPointer to hold the request variable so that it does not get deleted
prematurely and cause a crash.

BUG: 288751

M  +3    -4    kpasswdserver/kpasswdserver.cpp

http://commits.kde.org/kde-runtime/4e85ba177ee9e9cb7faaf7419db306c391a00bb9
Comment 3 Christoph Feck 2012-01-04 23:37:42 UTC
*** Bug 290603 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2012-01-06 12:44:29 UTC
*** Bug 290777 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2012-01-13 23:13:40 UTC
*** Bug 291484 has been marked as a duplicate of this bug. ***
Comment 6 Jekyll Wu 2012-01-20 14:02:01 UTC
*** Bug 292034 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2012-02-02 00:32:40 UTC
*** Bug 292978 has been marked as a duplicate of this bug. ***
Comment 8 giacof 2012-02-02 15:58:10 UTC
This is marked as RESOLVED, but the field "Version Fixed In" is blank.
I confirm this bug on KDE 4.7.4, so what version does resolve the bug?
Comment 9 Dawit Alemayehu 2012-02-02 16:06:13 UTC
(In reply to comment #8)
> This is marked as RESOLVED, but the field "Version Fixed In" is blank.
> I confirm this bug on KDE 4.7.4, so what version does resolve the bug?

There was no bug fix release after 4.7.4 ; so the fix was applied to 4.7.95 (4.8 RC1).
Comment 10 Christoph Feck 2012-02-06 01:44:09 UTC
*** Bug 293126 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2012-02-10 17:10:28 UTC
*** Bug 293703 has been marked as a duplicate of this bug. ***
Comment 12 Jekyll Wu 2012-02-16 19:17:05 UTC
*** Bug 294257 has been marked as a duplicate of this bug. ***
Comment 13 Jekyll Wu 2012-02-24 19:59:45 UTC
*** Bug 294766 has been marked as a duplicate of this bug. ***
Comment 14 Jekyll Wu 2012-03-02 10:53:08 UTC
*** Bug 295192 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2012-03-02 17:07:11 UTC
*** Bug 295223 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2012-03-08 10:56:58 UTC
*** Bug 295509 has been marked as a duplicate of this bug. ***
Comment 17 Jekyll Wu 2012-04-12 16:36:50 UTC
*** Bug 297979 has been marked as a duplicate of this bug. ***
Comment 18 Jekyll Wu 2012-06-22 15:13:09 UTC
*** Bug 302349 has been marked as a duplicate of this bug. ***
Comment 19 Jekyll Wu 2012-06-22 16:38:06 UTC
*** Bug 302352 has been marked as a duplicate of this bug. ***
Comment 20 Jekyll Wu 2013-04-02 14:47:58 UTC
*** Bug 317728 has been marked as a duplicate of this bug. ***
Comment 21 Jekyll Wu 2013-04-08 12:29:54 UTC
*** Bug 318025 has been marked as a duplicate of this bug. ***