Bug 196849 - KDE Demon crashed in Dolphin/Samba
Summary: KDE Demon crashed in Dolphin/Samba
Status: RESOLVED DUPLICATE of bug 192525
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-17 08:39 UTC by GK
Modified: 2009-06-17 14:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GK 2009-06-17 08:39:40 UTC
Application that crashed: kded4
Version of the application: $Id: kded.cpp 944898 2009-03-26 13:01:25Z dfaure $
KDE Version: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2))
Qt Version: 4.5.0
Operating System: Linux 2.6.28-13-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
The KDE demon crached while browsing file on the network. When a folder was open, the system crashed (including droped on the network wi-fi connection).

 -- Backtrace:
Application: KDE Daemon (kdeinit), signal: Segmentation fault
[KCrash Handler]
#6  KIO::AuthInfo::operator= (this=0xbfa5eb74, info=@0x9947c3c) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  0xb779ba89 in AuthInfo (this=0xbfa5eb74, info=@0x9947c3c) at /build/buildd/kde4libs-4.2.90/kio/kio/authinfo.cpp:123
#8  0xb2e00c8a in KPasswdServerAdaptor::qt_metacall (this=0x9ad2c68, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa5ec80)
    at /build/buildd/kdebase-runtime-4.2.90/obj-i486-linux-gnu/kpasswdserver/kpasswdserveradaptor.moc:139
#9  0xb7e4bca8 in QMetaObject::activate (sender=0x9b357c0, from_signal_index=8, to_signal_index=8, argv=0xbfa5ec80) at kernel/qobject.cpp:3069
#10 0xb7e4c932 in QMetaObject::activate (sender=0x9b357c0, m=0xb2e03c30, local_signal_index=0, argv=0xbfa5ec80) at kernel/qobject.cpp:3143
#11 0xb2df7687 in KPasswdServer::checkAuthInfoAsyncResult (this=0x9b357c0, _t1=135, _t2=8, _t3=@0x9947c3c)
    at /build/buildd/kdebase-runtime-4.2.90/obj-i486-linux-gnu/kpasswdserver/kpasswdserver.moc:121
#12 0xb2dfe8c7 in KPasswdServer::processRequest (this=0x9b357c0) at /build/buildd/kdebase-runtime-4.2.90/kpasswdserver/kpasswdserver.cpp:687
#13 0xb2dff393 in KPasswdServer::qt_metacall (this=0x9b357c0, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfa5f108)
    at /build/buildd/kdebase-runtime-4.2.90/obj-i486-linux-gnu/kpasswdserver/kpasswdserver.moc:108
#14 0xb7e4bca8 in QMetaObject::activate (sender=0x9a6e1e8, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3069
#15 0xb7e4c932 in QMetaObject::activate (sender=0x9a6e1e8, m=0xb7f27908, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3143
#16 0xb7e510a7 in QSingleShotTimer::timeout (this=0x9a6e1e8) at .moc/release-shared/qtimer.moc:76
#17 0xb7e511cc in QSingleShotTimer::timerEvent (this=0x9a6e1e8) at kernel/qtimer.cpp:298
#18 0xb7e4615f in QObject::event (this=0x9a6e1e8, e=0xbfa5f58c) at kernel/qobject.cpp:1082
#19 0xb68c5e9c in QApplicationPrivate::notify_helper (this=0x9893678, receiver=0x9a6e1e8, e=0xbfa5f58c) at kernel/qapplication.cpp:4084
#20 0xb68ce19e in QApplication::notify (this=0xbfa5f86c, receiver=0x9a6e1e8, e=0xbfa5f58c) at kernel/qapplication.cpp:3631
#21 0xb73ffe8d in KApplication::notify (this=0xbfa5f86c, receiver=0x9a6e1e8, event=0xbfa5f58c) at /build/buildd/kde4libs-4.2.90/kdeui/kernel/kapplication.cpp:302
#22 0xb7e35a3b in QCoreApplication::notifyInternal (this=0xbfa5f86c, receiver=0x9a6e1e8, event=0xbfa5f58c) at kernel/qcoreapplication.cpp:602
#23 0xb7e64d71 in QTimerInfoList::activateTimers (this=0x9896534) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 0xb7e614e0 in timerSourceDispatch (source=0x9896500) at kernel/qeventdispatcher_glib.cpp:164
#25 0xb6458b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0xb645c0eb in ?? () from /usr/lib/libglib-2.0.so.0
#27 0xb645c268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0xb7e61438 in QEventDispatcherGlib::processEvents (this=0x9893658, flags={i = -1079642360}) at kernel/qeventdispatcher_glib.cpp:323
#29 0xb6967365 in QGuiEventDispatcherGlib::processEvents (this=0x9893658, flags={i = -1079642312}) at kernel/qguieventdispatcher_glib.cpp:202
#30 0xb7e3406a in QEventLoop::processEvents (this=0xbfa5f7b0, flags={i = -1079642248}) at kernel/qeventloop.cpp:149
#31 0xb7e344aa in QEventLoop::exec (this=0xbfa5f7b0, flags={i = -1079642184}) at kernel/qeventloop.cpp:200
#32 0xb7e36959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#33 0xb68c5d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#34 0xb5c00d30 in kdemain (argc=1, argv=0x988d318) at /build/buildd/kde4libs-4.2.90/kded/kded.cpp:938
#35 0x0804e1c0 in launch (argc=1, _name=0x80513f2 "kded4", args=0x0, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80512d0 "0")
    at /build/buildd/kde4libs-4.2.90/kinit/kinit.cpp:671
#36 0x0804fd5d in main (argc=2, argv=0xbfa5fd74, envp=0xbfa5fd80) at /build/buildd/kde4libs-4.2.90/kinit/kinit.cpp:1730

Reported using DrKonqi
Comment 1 Dario Andres 2009-06-17 14:28:23 UTC
Thanks

*** This bug has been marked as a duplicate of bug 192525 ***