Bug 288556 - Support multiple file transfer sending from contact-applet
Summary: Support multiple file transfer sending from contact-applet
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: contact-applet (show other bugs)
Version: git-latest
Platform: Unlisted Binaries Linux
: NOR wishlist
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2011-12-09 12:51 UTC by Daniele E. Domenichelli
Modified: 2013-11-29 12:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele E. Domenichelli 2011-12-09 12:51:22 UTC
We could allow multiple file selection from the dialog and request a new channel for each file selected
Comment 1 Francesco Nwokeka 2011-12-09 16:10:05 UTC

*** This bug has been marked as a duplicate of bug 288557 ***
Comment 2 Martin Klapetek 2012-01-09 15:44:21 UTC
Not done in time for 0.3, reassigning it to 0.4.
Comment 3 Elias Probst 2012-02-10 17:42:19 UTC
Also related:
When selecting multiple files in Dolphin and selecting the "Send file to IM contact", a new dialog is shown for each file instead of one single dialog for all files together.

This
- causes way more effort to send a > 1 files to someone
- spams the desktop with useless windows when sending > 1 files
Comment 4 Alexandr Akulich 2013-11-29 12:01:24 UTC
Git commit 53efe04e4185841fbeb6c66bc2c1920e6c7f1fbc by Alexandr Akulich.
Committed on 29/11/2013 at 11:50.
Pushed by akulichalexandr into branch 'master'.

Contact: Implemented files transfer by appropriate button.

Added KIO dependency.
REVIEW: 114196

M  +1    -0    contact/CMakeLists.txt
M  +16   -1    contact/src/contact-wrapper.cpp

http://commits.kde.org/telepathy-contact-applet/53efe04e4185841fbeb6c66bc2c1920e6c7f1fbc