Bug 288057 - KNotify crashed on startup
Summary: KNotify crashed on startup
Status: RESOLVED UPSTREAM
Alias: None
Product: phonon-backend-vlc
Classification: Unclassified
Component: general (show other bugs)
Version: 0.4.1
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
: 299707 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-02 13:05 UTC by Javier Martínez Ortiz
Modified: 2012-05-10 10:38 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.73 KB, text/plain)
2011-12-13 20:26 UTC, Javier Martínez Ortiz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Javier Martínez Ortiz 2011-12-02 13:05:58 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

KNotify crashed on desktop startup. As an additional behavior, Amarok and kcmshell4 crashed too. Reading the traceback info, something is wrong with vlc library. I tried to change the phonon backend to gstreamer, but the control module couldn't be loaded. This error occurred after a distro update on OpenSUSE 12.1 (KDE:Factory repo).

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa36661c760 (LWP 2232))]

Thread 2 (Thread 0x7fa355382700 (LWP 2233)):
#0  0x00007fa363814423 in poll () from /lib64/libc.so.6
#1  0x00007fa360b2ba98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa360b2bf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa363f69576 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007fa363f3da22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007fa363f3dc1f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007fa363e555df in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007fa363f20aef in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007fa363e58025 in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007fa3618b6f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fa36381d53d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fa36661c760 (LWP 2232)):
[KCrash Handler]
#6  0x0000000000000a76 in ?? ()
#7  0x00007fa33b06910c in vlc_entry__1_1_0g (p_module=0xb43e80) at opencv_example.c:66
#8  0x00007fa34fda60d1 in module_Call (obj=0x85ddc0, p_module=<optimized out>) at modules/os.c:119
#9  0x00007fa34fd9fd0f in AllocatePlugin (p_this=0x85ddc0, psz_file=0xb43e10 "/usr/lib64/vlc/plugins/video_filter/libopencv_example_plugin.so") at modules/modules.c:1032
#10 0x00007fa34fd9fff4 in AllocatePluginFile (i_file_size=10440, i_file_time=1322016297, psz_file=0xb43e10 "/usr/lib64/vlc/plugins/video_filter/libopencv_example_plugin.so", p_bank=0x805e80, p_this=<optimized out>) at modules/modules.c:960
#11 AllocatePluginDir (p_this=0x85ddc0, p_bank=0x805e80, psz_dir=0xac9e40 "/usr/lib64/vlc/plugins/video_filter", i_maxdepth=<optimized out>) at modules/modules.c:912
#12 0x00007fa34fd9ff84 in AllocatePluginDir (p_this=0x85ddc0, p_bank=0x805e80, psz_dir=0x873730 "/usr/lib64/vlc/plugins", i_maxdepth=<optimized out>) at modules/modules.c:904
#13 0x00007fa34fd9ff84 in AllocatePluginDir (p_this=0x85ddc0, p_bank=0x805e80, psz_dir=0x873790 "/usr/lib64/vlc", i_maxdepth=<optimized out>) at modules/modules.c:904
#14 0x00007fa34fda0567 in AllocateAllPlugins (p_bank=0x805e80, p_this=0x85ddc0) at modules/modules.c:854
#15 module_LoadPlugins (p_this=0x85ddc0) at modules/modules.c:217
#16 0x00007fa34fd341c0 in libvlc_InternalInit (p_libvlc=0x85ddc0, i_argc=11, ppsz_argv=0x7fff4bf7b6e0) at libvlc.c:453
#17 0x00007fa354144661 in libvlc_new (argc=10, argv=<optimized out>) at control/core.c:58
#18 0x00007fa354394212 in LibVLC::init () at /usr/src/debug/phonon-backend-vlc-0.4.1/vlc/libvlc.cpp:111
#19 0x00007fa35438672e in Phonon::VLC::Backend::Backend (this=0x80cfc0, parent=<optimized out>) at /usr/src/debug/phonon-backend-vlc-0.4.1/vlc/backend.cpp:91
#20 0x00007fa354386d43 in qt_plugin_instance () at /usr/src/debug/phonon-backend-vlc-0.4.1/vlc/backend.cpp:59
#21 0x00007fa354977b56 in ?? () from /usr/lib64/kde4/plugins/phonon_platform/kde.so
#22 0x00007fa35497863e in ?? () from /usr/lib64/kde4/plugins/phonon_platform/kde.so
#23 0x00007fa365b85b86 in ?? () from /usr/lib64/libphonon.so.4
#24 0x00007fa365b864d7 in Phonon::Factory::backend(bool) () from /usr/lib64/libphonon.so.4
#25 0x00007fa365b86885 in ?? () from /usr/lib64/libphonon.so.4
#26 0x00007fa365b7f29e in ?? () from /usr/lib64/libphonon.so.4
#27 0x00007fa365b7c4b6 in ?? () from /usr/lib64/libphonon.so.4
#28 0x000000000040edd9 in _start ()

This bug may be a duplicate of or related to bug 259269.

Possible duplicates by query: bug 276287.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-12-12 09:54:03 UTC
Could you please install the -debuginfo packages for Phonon and phonon-backend-vlc? Your backtrace is not very useful without. Please see also http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 2 Javier Martínez Ortiz 2011-12-13 18:57:48 UTC
(In reply to comment #1)
> Could you please install the -debuginfo packages for Phonon and
> phonon-backend-vlc? Your backtrace is not very useful without. Please see also
> http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

Myriam: i "solved" the issue by uninstalling phonon-backend-vlc. There's no problem after that. I guessed that the traceback was lack of information, but i couldn't to install the -debuginfo packages, even with the debug repo active. I'll try to reproduce the bug, reinstalling the packages to gather some more info.
Comment 3 Javier Martínez Ortiz 2011-12-13 20:26:29 UTC
Created attachment 66708 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.7.2 (4.7.2) "release 5" using Qt 4.7.4

- What I was doing when the application crashed:

This is additional information about the bug 288057. Is the better i could get, because DrKonqui asked me some -debuginfo that is unavailable from OpenSUSE 12.1 debug repos. The list of applications in this situation is the following:

/usr/bin/systemsettings
/usr/lib64/libQtCore.so.4
/usr/lib64/kde4/plugins/phonon_platform/kde.so
/usr/lib64/libkcmutils.so.4
/usr/lib64/libkdecore.so.5
/usr/lib64/libphonon.so.4
/usr/lib64/libkdeui.so.5
/usr/lib64/libQtGui.so.4
/usr/lib64/kde4/kcm_phonon.so

I hope this information will be useful to correct the bug.

-- Backtrace (Reduced):
#7  0x00007f3582b4510c in vlc_entry__1_1_0g (p_module=0xee54b0) at opencv_example.c:66
#8  0x00007f35973000d1 in module_Call (obj=0xc0b3b0, p_module=<optimized out>) at modules/os.c:119
#9  0x00007f35972f9d0f in AllocatePlugin (p_this=0xc0b3b0, psz_file=0xee1890 "/usr/lib64/vlc/plugins/video_filter/libopencv_example_plugin.so") at modules/modules.c:1032
#10 0x00007f35972f9ff4 in AllocatePluginFile (i_file_size=10440, i_file_time=1323724910, psz_file=0xee1890 "/usr/lib64/vlc/plugins/video_filter/libopencv_example_plugin.so", p_bank=0xc01b60, p_this=<optimized out>) at modules/modules.c:960
#11 AllocatePluginDir (p_this=0xc0b3b0, p_bank=0xc01b60, psz_dir=0xe6c9c0 "/usr/lib64/vlc/plugins/video_filter", i_maxdepth=<optimized out>) at modules/modules.c:912
Comment 4 Myriam Schweingruber 2011-12-13 22:39:11 UTC
Please have a look here for the -debuginfo package for the backend: 
https://build.opensuse.org/package/binaries?package=phonon-backend-vlc&project=KDE%3AUnstable%3APlayground&repository=openSUSE_11.4_KDE_Unstable_SC
Comment 5 Harald Sitter 2012-02-12 15:20:48 UTC
That is very much a VLC bug. Best guess from the backtrace is that the plugin versions do not match the VLC version, thus leading to a crash when allocating memory for the plugin.
Comment 6 Myriam Schweingruber 2012-05-10 10:38:14 UTC
*** Bug 299707 has been marked as a duplicate of this bug. ***