Bug 287504 - Use of lirc
Summary: Use of lirc
Status: RESOLVED DUPLICATE of bug 284640
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: System Settings Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-24 22:57 UTC by welzel.joerg
Modified: 2011-11-24 23:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description welzel.joerg 2011-11-24 22:57:12 UTC
Application: kcmshell4 ()
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I wanted to try out the lirc control module. This Module I use with natty and it worked well. Now with oneiric the modul crashes, if I clikc on it. The remote conbtrol  doesn't work with oneiric any more!

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Kontrollmodul (kcmshell4), signal: Segmentation fault
[KCrash Handler]
#6  RemoteControl::buttons (this=<optimized out>) at ../../../kremotecontrol/libkremotecontrol/remotecontrol.cpp:53
#7  0x00007fccb8566c81 in EditActionContainer::EditActionContainer (this=0x7fffba2141a0, action=0x2151c60, remote=..., parent=<optimized out>, flags=<optimized out>) at ../../../kremotecontrol/kcmremotecontrol/editactioncontainer.cpp:43
#8  0x00007fccb8564eff in AddAction::createAction (this=0x7fffba214240, remote=...) at ../../../kremotecontrol/kcmremotecontrol/addaction.cpp:63
#9  0x00007fccb8560c26 in KCMRemoteControl::addAction (this=0x1bbe310) at ../../../kremotecontrol/kcmremotecontrol/kcmremotecontrol.cpp:132
#10 0x00007fccb8562c44 in KCMRemoteControl::qt_metacall (this=0x1bbe310, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffba214440) at ./kcmremotecontrol.moc:98
#11 0x00007fccc6896eba in QMetaObject::activate (sender=0x1b99fd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffba214440) at kernel/qobject.cpp:3278
#12 0x00007fccc62a5582 in QAbstractButton::clicked (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#13 0x00007fccc5feb13e in QAbstractButtonPrivate::emitClicked (this=<optimized out>) at widgets/qabstractbutton.cpp:546
#14 0x00007fccc5fec47b in QAbstractButtonPrivate::click (this=0x1babcb0) at widgets/qabstractbutton.cpp:539
#15 0x00007fccc5fec6ec in QAbstractButton::mouseReleaseEvent (this=0x1b99fd0, e=0x7fffba214b50) at widgets/qabstractbutton.cpp:1121
#16 0x00007fccc5c84c9a in QWidget::event (this=0x1b99fd0, event=0x7fffba214b50) at kernel/qwidget.cpp:8295
#17 0x00007fccc5c34424 in notify_helper (e=0x7fffba214b50, receiver=0x1b99fd0, this=0x1966ec0) at kernel/qapplication.cpp:4486
#18 QApplicationPrivate::notify_helper (this=0x1966ec0, receiver=0x1b99fd0, e=0x7fffba214b50) at kernel/qapplication.cpp:4458
#19 0x00007fccc5c39c6b in QApplication::notify (this=<optimized out>, receiver=0x1b99fd0, e=0x7fffba214b50) at kernel/qapplication.cpp:4047
#20 0x00007fccc7532126 in KApplication::notify (this=0x7fffba2157f0, receiver=0x1b99fd0, event=0x7fffba214b50) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007fccc6883afc in QCoreApplication::notifyInternal (this=0x7fffba2157f0, receiver=0x1b99fd0, event=0x7fffba214b50) at kernel/qcoreapplication.cpp:787
#22 0x00007fccc5c353f2 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QApplicationPrivate::sendMouseEvent (receiver=0x1b99fd0, event=0x7fffba214b50, alienWidget=0x1b99fd0, nativeWidget=0x1a93d50, buttonDown=0x1b99fd0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#24 0x00007fccc5cb4945 in QETWidget::translateMouseEvent (this=0x1a93d50, event=<optimized out>) at kernel/qapplication_x11.cpp:4568
#25 0x00007fccc5cb38be in QApplication::x11ProcessEvent (this=0x7fffba2157f0, event=0x7fffba215370) at kernel/qapplication_x11.cpp:3690
#26 0x00007fccc5cdc412 in x11EventSourceDispatch (s=0x1969c90, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#27 0x00007fccc270aa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fccc270b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fccc270b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fccc68aeed6 in QEventDispatcherGlib::processEvents (this=0x1949cd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#31 0x00007fccc5cdc07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007fccc6882cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fccc6882ef7 in QEventLoop::exec (this=0x7fffba215740, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007fccc60eb216 in QDialog::exec (this=0x1a93d50) at dialogs/qdialog.cpp:552
#35 0x00007fccc7f49c6c in kdemain (_argc=<optimized out>, _argv=<optimized out>) at ../../kcmshell/main.cpp:292
#36 0x00007fccc7bc430d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=2, ubp_av=0x7fffba216008, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffba215ff8) at libc-start.c:226
#37 0x0000000000400671 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-24 23:30:35 UTC

*** This bug has been marked as a duplicate of bug 284640 ***