Bug 284640 - kremotecontrol crash
Summary: kremotecontrol crash
Status: RESOLVED FIXED
Alias: None
Product: kremotecontrol
Classification: Applications
Component: settings (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Zanetti
URL:
Keywords:
: 287504 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-21 19:27 UTC by sauer.f
Modified: 2012-11-05 14:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sauer.f 2011-10-21 19:27:03 UTC
Application: kcmshell4 ()
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

kremotecontrol is running in the systray. when trying to configure the action for devinput the applictation is crashing

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Kontrollmodul (kcmshell4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7814980 (LWP 8561))]

Thread 2 (Thread 0xb5612b70 (LWP 8562)):
#0  0x0021f416 in __kernel_vsyscall ()
#1  0x005ac40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x076b034b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x076a1896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x076a1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x07c28b37 in QEventDispatcherGlib::processEvents (this=0x8748420, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x07bf91dd in QEventLoop::processEvents (this=0xb56122b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x07bf9421 in QEventLoop::exec (this=0xb56122b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x07afc90b in QThread::exec (this=0x8a512c0) at thread/qthread.cpp:498
#9  0x07bd9e2d in QInotifyFileSystemWatcherEngine::run (this=0x8a512c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x07aff7b3 in QThreadPrivate::start (arg=0x8a512c0) at thread/qthread_unix.cpp:331
#11 0x00730d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x005bb0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7814980 (LWP 8561)):
[KCrash Handler]
#7  0x044bc9fb in RemoteControl::buttons (this=0xbfc098d8) at ../../../kremotecontrol/libkremotecontrol/remotecontrol.cpp:53
#8  0x01d80aab in EditActionContainer::EditActionContainer (this=0xbfc099c4, action=0x8a84b68, remote=..., parent=0x0, flags=...) at ../../../kremotecontrol/kcmremotecontrol/editactioncontainer.cpp:43
#9  0x01d7e8fa in AddAction::createAction (this=0xbfc09a3c, remote=...) at ../../../kremotecontrol/kcmremotecontrol/addaction.cpp:63
#10 0x01d79c65 in KCMRemoteControl::addAction (this=0x8763e28) at ../../../kremotecontrol/kcmremotecontrol/kcmremotecontrol.cpp:132
#11 0x01d7c05c in KCMRemoteControl::qt_metacall (this=0x8763e28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc09be8) at ./kcmremotecontrol.moc:98
#12 0x07c00b7d in metacall (argv=0xbfc09be8, idx=36, cl=QMetaObject::InvokeMetaMethod, object=0x8763e28) at kernel/qmetaobject.cpp:237
#13 QMetaObject::metacall (object=0x8763e28, cl=QMetaObject::InvokeMetaMethod, idx=36, argv=0xbfc09be8) at kernel/qmetaobject.cpp:232
#14 0x07c0fa6a in QMetaObject::activate (sender=0x876dd30, m=0x72c1a28, local_signal_index=2, argv=0xbfc09be8) at kernel/qobject.cpp:3278
#15 0x0707ae1d in QAbstractButton::clicked (this=0x876dd30, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#16 0x06d7958d in QAbstractButtonPrivate::emitClicked (this=0x876f750) at widgets/qabstractbutton.cpp:546
#17 0x06d7abfb in QAbstractButtonPrivate::click (this=0x876f750) at widgets/qabstractbutton.cpp:539
#18 0x06d7aeb6 in QAbstractButton::mouseReleaseEvent (this=0x876dd30, e=0xbfc0a19c) at widgets/qabstractbutton.cpp:1121
#19 0x069bff98 in QWidget::event (this=0x876dd30, event=0xbfc0a19c) at kernel/qwidget.cpp:8295
#20 0x06d7a159 in QAbstractButton::event (this=0x876dd30, e=0xbfc0a19c) at widgets/qabstractbutton.cpp:1080
#21 0x06e1c798 in QPushButton::event (this=0x876dd30, e=0xbfc0a19c) at widgets/qpushbutton.cpp:683
#22 0x06965d54 in notify_helper (e=0xbfc0a19c, receiver=0x876dd30, this=0x85b7c38) at kernel/qapplication.cpp:4486
#23 QApplicationPrivate::notify_helper (this=0x85b7c38, receiver=0x876dd30, e=0xbfc0a19c) at kernel/qapplication.cpp:4458
#24 0x0696bdbb in QApplication::notify (this=0x85b7c38, receiver=0x876dd30, e=0xbfc0a19c) at kernel/qapplication.cpp:4047
#25 0x00d28721 in KApplication::notify (this=0xbfc0a9b8, receiver=0x876dd30, event=0xbfc0a19c) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x07bfa19e in QCoreApplication::notifyInternal (this=0xbfc0a9b8, receiver=0x876dd30, event=0xbfc0a19c) at kernel/qcoreapplication.cpp:787
#27 0x06966d15 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QApplicationPrivate::sendMouseEvent (receiver=0x876dd30, event=0xbfc0a19c, alienWidget=0x876dd30, nativeWidget=0x86e9b68, buttonDown=0x72d0eb4, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#29 0x069f32c4 in QETWidget::translateMouseEvent (this=0x86e9b68, event=0xbfc0a61c) at kernel/qapplication_x11.cpp:4568
#30 0x069f1e4d in QApplication::x11ProcessEvent (this=0xbfc0a9b8, event=0xbfc0a61c) at kernel/qapplication_x11.cpp:3690
#31 0x06a1e24c in x11EventSourceDispatch (s=0x85bbea0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#32 0x076a125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0x076a1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0x076a1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0x07c28ada in QEventDispatcherGlib::processEvents (this=0x85a1a00, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#36 0x06a1de3a in QGuiEventDispatcherGlib::processEvents (this=0x85a1a00, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x07bf91dd in QEventLoop::processEvents (this=0xbfc0a920, flags=...) at kernel/qeventloop.cpp:149
#38 0x07bf9421 in QEventLoop::exec (this=0xbfc0a920, flags=...) at kernel/qeventloop.cpp:201
#39 0x06e9d7c9 in QDialog::exec (this=0x86e9b68) at dialogs/qdialog.cpp:552
#40 0x0031ea89 in kdemain (_argc=2, _argv=0xbfc0ac54) at ../../kcmshell/main.cpp:292
#41 0x0804850b in main (argc=2, argv=0xbfc0ac54) at kcmshell4_dummy.cpp:3

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-24 23:30:35 UTC
*** Bug 287504 has been marked as a duplicate of this bug. ***
Comment 2 Michael Zanetti 2012-11-05 14:46:57 UTC
Git commit 94fa064edc5fdef7b6c4243bd719324f53f7891d by Michael Zanetti.
Committed on 05/11/2012 at 14:49.
Pushed by mzanetti into branch 'KDE/4.9'.

Correctly disable buttons in case a remote control is not available.
Make it more obvious when a remote is not available.

Fixes some crash reports when people tried to edit a non existent remote:
Related: bug 287568, bug 287568, bug 301046

M  +6    -4    kcmremotecontrol/kcmremotecontrol.cpp
M  +10   -1    kcmremotecontrol/model.cpp

http://commits.kde.org/kremotecontrol/94fa064edc5fdef7b6c4243bd719324f53f7891d