Bug 286343 - Muon Software Crash
Summary: Muon Software Crash
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-11 15:33 UTC by Alessandro
Modified: 2011-11-12 13:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro 2011-11-11 15:33:23 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: disinstalling web browser or something else regarding a disinstallation

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7782930 (LWP 2042))]

Thread 2 (Thread 0xb5581b70 (LWP 2046)):
#0  0x006bbd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x007a97d5 in do_gettime (frac=0xb5581020, sec=0xb5581018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0087c4b6 in QTimerInfoList::updateCurrentTime (this=0xb4c004dc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0087c80a in QTimerInfoList::timerWait (this=0xb4c004dc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0087b053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb558112c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0087b0ed in timerSourcePrepare (source=0xb4c004a8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x012ec88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x012ed637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x012edc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0087bb37 in QEventDispatcherGlib::processEvents (this=0x9431b58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0084c1dd in QEventLoop::processEvents (this=0xb55812b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x0084c421 in QEventLoop::exec (this=0xb55812b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0074f90b in QThread::exec (this=0x94f6a48) at thread/qthread.cpp:498
#14 0x0082ce2d in QInotifyFileSystemWatcherEngine::run (this=0x94f6a48) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x007527b3 in QThreadPrivate::start (arg=0x94f6a48) at thread/qthread_unix.cpp:331
#16 0x0068ed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x043880ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7782930 (LWP 2042)):
[KCrash Handler]
#7  QApt::Package::controlField (this=0x9ce1f08, name=...) at /build/buildd/qapt-1.2.1/src/package.cpp:1269
#8  0x0805f1c0 in Application::untranslatedName (this=0x9ce1ee8) at /build/buildd/muon-1.2.1/installer/Application.cpp:71
#9  0x0805f29d in Application::name (this=0x9ce1ee8) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#10 0x08083b74 in ReviewsBackend::reviewsFetched (this=0x93bbd60, job=0xa4d9978) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#11 0x0805e465 in ReviewsBackend::qt_metacall (this=0x93bbd60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa08c98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#12 0x00853b7d in metacall (argv=0xbfa08c98, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x93bbd60) at kernel/qmetaobject.cpp:237
#13 QMetaObject::metacall (object=0x93bbd60, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfa08c98) at kernel/qmetaobject.cpp:232
#14 0x00862a6a in QMetaObject::activate (sender=0xa4d9978, m=0x12a258c, local_signal_index=3, argv=0xbfa08c98) at kernel/qobject.cpp:3278
#15 0x010f4eb5 in KJob::result (this=0xa4d9978, _t1=0xa4d9978) at ./kjob.moc:194
#16 0x010f4f08 in KJob::emitResult (this=0xa4d9978) at ../../kdecore/jobs/kjob.cpp:312
#17 0x001d6ffc in KIO::FileCopyJob::slotResult (this=0xa4d9978, job=0xa49bb00) at ../../kio/kio/job.cpp:2440
#18 0x001d6d8d in KIO::FileCopyJob::qt_metacall (this=0xa4d9978, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa08e18) at ./jobclasses.moc:724
#19 0x00853b7d in metacall (argv=0xbfa08e18, idx=32, cl=QMetaObject::InvokeMetaMethod, object=0xa4d9978) at kernel/qmetaobject.cpp:237
#20 QMetaObject::metacall (object=0xa4d9978, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbfa08e18) at kernel/qmetaobject.cpp:232
#21 0x00862a6a in QMetaObject::activate (sender=0xa49bb00, m=0x12a258c, local_signal_index=3, argv=0xbfa08e18) at kernel/qobject.cpp:3278
#22 0x010f4eb5 in KJob::result (this=0xa49bb00, _t1=0xa49bb00) at ./kjob.moc:194
#23 0x010f4f08 in KJob::emitResult (this=0xa49bb00) at ../../kdecore/jobs/kjob.cpp:312
#24 0x001ce6d8 in KIO::SimpleJob::slotFinished (this=0xa49bb00) at ../../kio/kio/job.cpp:494
#25 0x001d725d in KIO::TransferJob::slotFinished (this=0xa49bb00) at ../../kio/kio/job.cpp:1081
#26 0x001d5894 in KIO::TransferJob::qt_metacall (this=0xa49bb00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa090b4) at ./jobclasses.moc:369
#27 0x00853b7d in metacall (argv=0xbfa090b4, idx=47, cl=QMetaObject::InvokeMetaMethod, object=0xa49bb00) at kernel/qmetaobject.cpp:237
#28 QMetaObject::metacall (object=0xa49bb00, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfa090b4) at kernel/qmetaobject.cpp:232
#29 0x00862a6a in QMetaObject::activate (sender=0x93122a8, m=0x3aa6a0, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3278
#30 0x0028a675 in KIO::SlaveInterface::finished (this=0x93122a8) at ./slaveinterface.moc:171
#31 0x0028d4f9 in KIO::SlaveInterface::dispatch (this=0x93122a8, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#32 0x00289c5a in KIO::SlaveInterface::dispatch (this=0x93122a8) at ../../kio/kio/slaveinterface.cpp:88
#33 0x0027b348 in KIO::Slave::gotInput (this=0x93122a8) at ../../kio/kio/slave.cpp:344
#34 0x0027bbbc in KIO::Slave::qt_metacall (this=0x93122a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa09394) at ./slave.moc:82
#35 0x00853b7d in metacall (argv=0xbfa09394, idx=30, cl=QMetaObject::InvokeMetaMethod, object=0x93122a8) at kernel/qmetaobject.cpp:237
#36 QMetaObject::metacall (object=0x93122a8, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbfa09394) at kernel/qmetaobject.cpp:232
#37 0x00862a6a in QMetaObject::activate (sender=0x93947a8, m=0x3a7508, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#38 0x00199f65 in KIO::Connection::readyRead (this=0x93947a8) at ./connection.moc:92
#39 0x0019a79a in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#40 KIO::ConnectionPrivate::dequeue (this=0x9439910) at ../../kio/kio/connection.cpp:71
#41 0x0019a86f in KIO::Connection::qt_metacall (this=0x93947a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x9b40b10) at ./connection.moc:79
#42 0x00853b7d in metacall (argv=0x9b40b10, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x93947a8) at kernel/qmetaobject.cpp:237
#43 QMetaObject::metacall (object=0x93947a8, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0x9b40b10) at kernel/qmetaobject.cpp:232
#44 0x0085e685 in QMetaCallEvent::placeMetaCall (this=0xa4a6778, object=0x93947a8) at kernel/qobject.cpp:535
#45 0x00865b52 in QObject::event (this=0x93947a8, e=0xa4a6778) at kernel/qobject.cpp:1217
#46 0x02e10d54 in notify_helper (e=0xa4a6778, receiver=0x93947a8, this=0x92b7948) at kernel/qapplication.cpp:4486
#47 QApplicationPrivate::notify_helper (this=0x92b7948, receiver=0x93947a8, e=0xa4a6778) at kernel/qapplication.cpp:4458
#48 0x02e16103 in QApplication::notify (this=0xa4a6778, receiver=0x93947a8, e=0xa4a6778) at kernel/qapplication.cpp:3886
#49 0x00c0d681 in KApplication::notify (this=0xbfa09b60, receiver=0x93947a8, event=0xa4a6778) at ../../kdeui/kernel/kapplication.cpp:311
#50 0x0084d19e in QCoreApplication::notifyInternal (this=0xbfa09b60, receiver=0x93947a8, event=0xa4a6778) at kernel/qcoreapplication.cpp:787
#51 0x00850f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9294300) at kernel/qcoreapplication.cpp:1428
#53 0x008510ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#54 0x0087b6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#55 postEventSourceDispatch (s=0x92b4090) at kernel/qeventdispatcher_glib.cpp:277
#56 0x012ed25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#57 0x012ed990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0x012edc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0x0087bada in QEventDispatcherGlib::processEvents (this=0x9295250, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#60 0x02ec8e3a in QGuiEventDispatcherGlib::processEvents (this=0x9295250, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x0084c1dd in QEventLoop::processEvents (this=0xbfa09ac4, flags=...) at kernel/qeventloop.cpp:149
#62 0x0084c421 in QEventLoop::exec (this=0xbfa09ac4, flags=...) at kernel/qeventloop.cpp:201
#63 0x0085119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#64 0x02e0e8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#65 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 286176, bug 284499, bug 284147.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-12 13:39:00 UTC

*** This bug has been marked as a duplicate of bug 283728 ***