Bug 286176 - Muon crashed when performing actions duing installation
Summary: Muon crashed when performing actions duing installation
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-09 11:12 UTC by underline
Modified: 2011-11-09 11:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description underline 2011-11-09 11:12:45 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I selected another application while installing X11VNCServer in Muon.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f08fb061780 (LWP 3601))]

Thread 2 (Thread 0x7f08e610f700 (LWP 3605)):
#0  0x00007f08f44b4f3f in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f08f44b5dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f08f44b6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f08f9dfdf3e in QEventDispatcherGlib::processEvents (this=0x268a150, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f08f9dd1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f08f9dd1ef7 in QEventLoop::exec (this=0x7f08e610edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f08f9ce927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f08f9db4cbf in QInotifyFileSystemWatcherEngine::run (this=0x263ad00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f08f9cebd05 in QThreadPrivate::start (arg=0x263ad00) at thread/qthread_unix.cpp:331
#9  0x00007f08f4f97efc in start_thread (arg=0x7f08e610f700) at pthread_create.c:304
#10 0x00007f08f7c4c89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f08fb061780 (LWP 3601)):
[KCrash Handler]
#6  GetCandidateVer (Pkg=<optimized out>, this=<optimized out>) at /usr/include/apt-pkg/depcache.h:349
#7  QApt::Package::controlField (this=0x2acc7a0, name=...) at /build/buildd/qapt-1.2.1/src/package.cpp:643
#8  0x000000000041d1ab in Application::untranslatedName (this=0x32e61f0) at /build/buildd/muon-1.2.1/installer/Application.cpp:71
#9  0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#10 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x265cfc0, job=0x40983a0) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#11 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x265cfc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff569bd70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#12 0x00007f08f9de5eba in QMetaObject::activate (sender=0x40983a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff569bd70) at kernel/qobject.cpp:3278
#13 0x00007f08f90215b2 in KJob::result (this=<optimized out>, _t1=0x40983a0) at ./kjob.moc:194
#14 0x00007f08f90215f0 in KJob::emitResult (this=0x40983a0) at ../../kdecore/jobs/kjob.cpp:312
#15 0x00007f08fa877a4a in KIO::FileCopyJob::slotResult (this=0x40983a0, job=0x407da70) at ../../kio/kio/job.cpp:2440
#16 0x00007f08fa8777f0 in KIO::FileCopyJob::qt_metacall (this=0x40983a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff569bee0) at ./jobclasses.moc:724
#17 0x00007f08f9de5eba in QMetaObject::activate (sender=0x407da70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff569bee0) at kernel/qobject.cpp:3278
#18 0x00007f08f90215b2 in KJob::result (this=<optimized out>, _t1=0x407da70) at ./kjob.moc:194
#19 0x00007f08f90215f0 in KJob::emitResult (this=0x407da70) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00007f08fa8702c4 in KIO::SimpleJob::slotFinished (this=0x407da70) at ../../kio/kio/job.cpp:494
#21 0x00007f08fa877c9d in KIO::TransferJob::slotFinished (this=0x407da70) at ../../kio/kio/job.cpp:1081
#22 0x00007f08fa876601 in KIO::TransferJob::qt_metacall (this=0x407da70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff569c290) at ./jobclasses.moc:369
#23 0x00007f08f9de5eba in QMetaObject::activate (sender=0x3e44500, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#24 0x00007f08fa91c9c1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#25 0x00007f08fa919875 in KIO::SlaveInterface::dispatch (this=0x3e44500) at ../../kio/kio/slaveinterface.cpp:88
#26 0x00007f08fa90cace in KIO::Slave::gotInput (this=0x3e44500) at ../../kio/kio/slave.cpp:344
#27 0x00007f08fa90d22c in KIO::Slave::qt_metacall (this=0x3e44500, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff569c6c0) at ./slave.moc:82
#28 0x00007f08f9de5eba in QMetaObject::activate (sender=0x3c60e90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#29 0x00007f08fa8413a7 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#30 KIO::ConnectionPrivate::dequeue (this=0x3e85710) at ../../kio/kio/connection.cpp:71
#31 0x00007f08fa84144d in KIO::Connection::qt_metacall (this=0x3c60e90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x331ca70) at ./connection.moc:79
#32 0x00007f08f9de9a5e in QObject::event (this=0x3c60e90, e=<optimized out>) at kernel/qobject.cpp:1217
#33 0x00007f08f840d424 in notify_helper (e=0x3e9db30, receiver=0x3c60e90, this=0x24b1bc0) at kernel/qapplication.cpp:4486
#34 QApplicationPrivate::notify_helper (this=0x24b1bc0, receiver=0x3c60e90, e=0x3e9db30) at kernel/qapplication.cpp:4458
#35 0x00007f08f8412291 in QApplication::notify (this=0x7ffff569ec50, receiver=0x3c60e90, e=0x3e9db30) at kernel/qapplication.cpp:4365
#36 0x00007f08f95f1126 in KApplication::notify (this=0x7ffff569ec50, receiver=0x3c60e90, event=0x3e9db30) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f08f9dd2afc in QCoreApplication::notifyInternal (this=0x7ffff569ec50, receiver=0x3c60e90, event=0x3e9db30) at kernel/qcoreapplication.cpp:787
#38 0x00007f08f9dd651f in sendEvent (event=0x3e9db30, receiver=0x3c60e90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2486be0) at kernel/qcoreapplication.cpp:1428
#40 0x00007f08f9dfda73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007f08f44b5a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f08f44b6258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f08f44b6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f08f9dfded6 in QEventDispatcherGlib::processEvents (this=0x24886f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007f08f84b507e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f08f9dd692f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:979
#48 0x00007f08fa55fcf3 in QApt::CacheBuildProgress::Update (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:36
#49 0x00007f08f5a16020 in pkgDepCache::Update(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#50 0x00007f08f5a1b23e in pkgDepCache::Init(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#51 0x00007f08f5a451fd in pkgCacheFile::BuildDepCache(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#52 0x00007f08f5a4527a in pkgCacheFile::Open(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
#53 0x00007f08fa55fab7 in QApt::Cache::open (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:85
#54 0x00007f08fa55ae22 in QApt::Backend::reloadCache (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/backend.cpp:184
#55 0x0000000000420dbb in ApplicationBackend::reload (this=0x26b9760) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:118
#56 0x0000000000420ff5 in ApplicationBackend::workerEvent (this=0x26b9760, event=<optimized out>) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:179
#57 0x000000000041c383 in ApplicationBackend::qt_metacall (this=0x26b9760, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff569ddd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:113
#58 0x00007f08f9de5eba in QMetaObject::activate (sender=0x25ddd00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff569ddd0) at kernel/qobject.cpp:3278
#59 0x00007f08fa575f41 in QApt::Backend::workerEvent (this=<optimized out>, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:244
#60 0x00007f08fa57619c in QApt::Backend::qt_metacall (this=0x25ddd00, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0x7ffff569dee0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:204
#61 0x00007f08f9de5eba in QMetaObject::activate (sender=0x2656040, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff569dee0) at kernel/qobject.cpp:3278
#62 0x00007f08fa576ae1 in OrgKubuntuQaptworkerInterface::workerEvent (this=<optimized out>, _t1=6) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:228
#63 0x00007f08fa576ee5 in OrgKubuntuQaptworkerInterface::qt_metacall (this=0x2656040, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7ffff569e3c0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:131
#64 0x00007f08f5f880e9 in QDBusConnectionPrivate::deliverCall (this=0x2649db0, object=0x2656040, msg=..., metaTypes=..., slotIdx=13) at qdbusintegrator.cpp:942
#65 0x00007f08f5f9138f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#66 0x00007f08f9de9a5e in QObject::event (this=0x2656040, e=<optimized out>) at kernel/qobject.cpp:1217
#67 0x00007f08f840d424 in notify_helper (e=0x3fd2660, receiver=0x2656040, this=0x24b1bc0) at kernel/qapplication.cpp:4486
#68 QApplicationPrivate::notify_helper (this=0x24b1bc0, receiver=0x2656040, e=0x3fd2660) at kernel/qapplication.cpp:4458
#69 0x00007f08f8412291 in QApplication::notify (this=0x7ffff569ec50, receiver=0x2656040, e=0x3fd2660) at kernel/qapplication.cpp:4365
#70 0x00007f08f95f1126 in KApplication::notify (this=0x7ffff569ec50, receiver=0x2656040, event=0x3fd2660) at ../../kdeui/kernel/kapplication.cpp:311
#71 0x00007f08f9dd2afc in QCoreApplication::notifyInternal (this=0x7ffff569ec50, receiver=0x2656040, event=0x3fd2660) at kernel/qcoreapplication.cpp:787
#72 0x00007f08f9dd651f in sendEvent (event=0x3fd2660, receiver=0x2656040) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2486be0) at kernel/qcoreapplication.cpp:1428
#74 0x00007f08f9dfda73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#75 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#76 0x00007f08f44b5a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#77 0x00007f08f44b6258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#78 0x00007f08f44b6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#79 0x00007f08f9dfded6 in QEventDispatcherGlib::processEvents (this=0x24886f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#80 0x00007f08f84b507e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#81 0x00007f08f9dd1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#82 0x00007f08f9dd1ef7 in QEventLoop::exec (this=0x7ffff569ebe0, flags=...) at kernel/qeventloop.cpp:201
#83 0x00007f08f9dd6789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#84 0x000000000041bd67 in main (argc=5, argv=0x7ffff569eec8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-09 11:26:29 UTC

*** This bug has been marked as a duplicate of bug 283728 ***