Bug 286235 - confusing error-message when there is no mail-address specified for the identity
Summary: confusing error-message when there is no mail-address specified for the identity
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Unclassified
Component: config dialog (show other bugs)
Version: 4.7
Platform: openSUSE RPMs Linux
: NOR minor with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-10 00:22 UTC by MuH4hA
Modified: 2017-01-07 21:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MuH4hA 2011-11-10 00:22:49 UTC
Version:           4.7 (using KDE 4.7.2) 
OS:                Linux

When there is no valid mail-address specified in configure->identity->general->email-address field, the following error-message appears:

"The email address you entered is not valid because it does not seem to contain an actual email address, i.e. something of the form joe@example.org."

This is confusing, cause some people when setting up kmail for the first time on a system, just skip the 'general'-section to specify a reply-to-address in 'advanced'. They get the message, that their mail-address is not valid, which can be quit confusing.

Admittedly, it doesn't take much to figure out the real problem, but this behavior has confused at least a handful of people. (See bugs 237646 and 280151 for example).

Reproducible: Always

Steps to Reproduce:
Open the big configure dialog -> Modify/Edit an Identity -> klick "OK" while the 'email address' field in the 'general'-section does not contain a valid mail-addy.

Actual Results:  
kmail prints the following error-message:

"The email address you entered is not valid because it does not seem to contain an actual email address, i.e. something of the form joe@example.org."

Expected Results:  
It would be great, if either the error-message contained the information about what field actually causes the problem, or if there would just be no error-message at all.
(you will be reminded of entering a mail-address at some point anyway - if I am not mistaken..)
Comment 1 Bernd Oliver Sünderhauf 2011-12-14 13:57:00 UTC
I can confirm this bug.
Actually there are two bugs:
1. The input for BCC and Reply-To is not validated at all - it should be valid or empty.
2. The identity's email address is correctly validated when hitting OK. However the error message gives no clue about which input is considered invalid, which is very confusing if another tab is active.

Proposed solution:
ad 1. Validate the input for BCC and Reply-To as well.
ad 2. When validation fails, jump to the appropriate tab and highlight the respective field. (Isn't there something like a red error marking in the libs?).

Please mark this one confirmed and http://bugs.kde.org/show_bug.cgi?id=280151 a duplicate. THX
Comment 2 Laurent Montel 2013-09-19 11:51:56 UTC
Git commit eaae5e2bf72a2092801fcf76d4d4668eff619ace by Montel Laurent.
Committed on 19/09/2013 at 11:51.
Pushed by mlaurent into branch 'master'.

Start to fix Bug 286235 - confusing error-message when there is no mail-address specified for the identity
Now we validate correctly email

M  +32   -3    kpimutils/email.cpp
M  +2    -1    kpimutils/email.h

http://commits.kde.org/kdepimlibs/eaae5e2bf72a2092801fcf76d4d4668eff619ace
Comment 3 Denis Kurz 2016-09-24 17:57:15 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 4 Denis Kurz 2017-01-07 21:56:56 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.