Bug 285420 - Selecting and editing multiple layers (feature request for texturing)
Summary: Selecting and editing multiple layers (feature request for texturing)
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: 2.4-snapshots
Platform: unspecified Linux
: NOR wishlist
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 317957 323269 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-31 19:43 UTC by Anna Celarek
Modified: 2014-06-20 08:50 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anna Celarek 2011-10-31 19:43:00 UTC
Version:           2.4-snapshots (using KDE 4.7.2) 
OS:                Linux

More than one layer should be selectable from the list by Shift or Ctrl, like in a file browser (Shift to select all from here to there, Ctrl to select one by one). 
There should be the possibility to merge all selected layers, or move them into a layer group, or move them down or up in the list.  
Turning all selected on or off by clicking on the eye of one of them would be a nice addition (but not so vital, as it's currently possible to turn off grouped layers all at once). 
There should be the possibility to merge (flatten) a layer group. 



Reproducible: Didn't try


Actual Results:  
Only one layer can be selected at a time. 

Expected Results:  
1.) Multiple layers selectable by Shift (should select all layers from klicked layer to klicked layer) or Ctrl (select one by one each klicked layer)
2.) Merge selected layers
3.) Move all selected up or down in the layer list by drag-and-drop
4.) Move all selected into a layer group by drag-and-drop. 
((5.) would be nice, but not vital: turn on or off all selected by clicking on one of their eyes)
Comment 1 Anna Celarek 2011-10-31 19:44:42 UTC
Expected Results: 
6.) Flatten (merge) a layer group.
Comment 2 Halla Rempt 2011-11-01 07:40:57 UTC
Hi Anna,

Yes, these are good points. I'm not yet sure about the implementation, though, but we'll have to think about it... I haven't seen selecting multiple layers as a possibility in other apps yet, like Gimp or Photoshop, but maybe I just don't know how it's done there :-). I think we've seen this request before, though.

Maybe we could add an extra toggle or checkbox to create the temporary group the user wants to act on.
Comment 3 Anna Celarek 2011-11-01 10:27:05 UTC
Multiple layers are selectable in Corel Photopaint (which is the program I mostly use for texturing), both by klicking them on the workspace or in the list. On the other hand CPP has not grouping of layers, so perhaps it's either this or that. 

If in Krita I could flatten all layers inside a group, I think it would do almost the same in terms of a quick workflow. If this is easier to implement.

I'm not sure what you mean exactly by temporary group, but I think working with the "real" groups as there are should be sufficient if I could do more with them, additional temporary groups could be confusing.
Comment 5 Halla Rempt 2013-10-29 18:25:06 UTC
*** Bug 317957 has been marked as a duplicate of this bug. ***
Comment 6 Halla Rempt 2013-10-29 18:25:13 UTC
*** Bug 323269 has been marked as a duplicate of this bug. ***
Comment 7 Halla Rempt 2014-06-19 12:07:04 UTC
Git commit 628e341d3c99b49d38b1b88e2cb73003e9494c2a by Boudewijn Rempt.
Committed on 18/06/2014 at 14:55.
Pushed by rempt into branch 'master'.

Layerbox multi-selection

Make it possible to delete multiple layers.

M  +11   -0    krita/plugins/extensions/dockers/defaultdockers/kis_layer_box.cpp
M  +2    -0    krita/plugins/extensions/dockers/defaultdockers/kis_layer_box.h
M  +46   -4    krita/ui/kis_node_manager.cpp
M  +8    -0    krita/ui/kis_node_manager.h
M  +7    -0    libs/main/KoDocumentSectionView.cpp
M  +4    -1    libs/main/KoDocumentSectionView.h

http://commits.kde.org/calligra/628e341d3c99b49d38b1b88e2cb73003e9494c2a
Comment 8 Halla Rempt 2014-06-19 14:19:50 UTC
Git commit 8e40dff985e5e9db21c5e29226ce591f2d22f6e6 by Boudewijn Rempt.
Committed on 19/06/2014 at 14:10.
Pushed by rempt into branch 'master'.

Add an action to merge the selected layers

M  +2    -1    krita/krita.rc
M  +0    -2    krita/ui/kis_layer_manager.cc
M  +85   -6    krita/ui/kis_node_manager.cpp
M  +4    -2    krita/ui/kis_node_manager.h

http://commits.kde.org/calligra/8e40dff985e5e9db21c5e29226ce591f2d22f6e6
Comment 9 Halla Rempt 2014-06-20 08:42:58 UTC
Git commit 051f359dbc498c78c701857a67e9d14a2146f452 by Boudewijn Rempt.
Committed on 20/06/2014 at 08:40.
Pushed by rempt into branch 'master'.

Multilayer selection: implement drag & drop of multiple layers

This changes KisMimeData to handle a list of layers. If you try to drag a
complex selection with groups and so on, it will check whether the group
that contains a selected layer is selected and then drag the group; otherwise
it will drag all the layers in a flat list, instead of trying to keep
the group hierarchy with the unselected layers discarded.

This is the behaviour that Photoshop shows for me as well.

M  +0    -2    krita/plugins/extensions/dockers/defaultdockers/CMakeLists.txt
D  +0    -99   krita/plugins/extensions/dockers/defaultdockers/kis_drop_button.cpp
D  +0    -52   krita/plugins/extensions/dockers/defaultdockers/kis_drop_button.h
M  +3    -3    krita/plugins/extensions/dockers/defaultdockers/wdglayerbox.ui
M  +123  -79   krita/ui/kis_mimedata.cpp
M  +16   -16   krita/ui/kis_mimedata.h
M  +70   -31   krita/ui/kis_node_model.cpp
M  +12   -10   krita/ui/kis_view2.cpp

http://commits.kde.org/calligra/051f359dbc498c78c701857a67e9d14a2146f452
Comment 10 Halla Rempt 2014-06-20 08:43:44 UTC
Everything but "((5.) would be nice, but not vital: turn on or off all selected by clicking on one of their eyes)" is done now.
Comment 11 Halla Rempt 2014-06-20 08:50:19 UTC
Okay, that one isn't going to happen -- it doesn't work that way in Ps either, and it's really, really tricky. So I guess I can close this bug :-)