Bug 285330 - No contours when setting the countries in the map
Summary: No contours when setting the countries in the map
Alias: None
Product: kgeography
Classification: Applications
Component: general (show other bugs)
Version: 0.3
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Albert Astals Cid
: 313476 (view as bug list)
Depends on:
Reported: 2011-10-30 16:48 UTC by Norbert Lederbauer
Modified: 2013-11-12 19:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12

Screenshot germany (54.81 KB, image/jpeg)
2011-10-30 20:27 UTC, Norbert Lederbauer

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Lederbauer 2011-10-30 16:48:11 UTC
Version:           0.3 (using KDE 4.7.2) 
OS:                Linux

When you try to place countries in a map, for example you want to place Ecuador in South America, you can't see the contours of the country, you only see a non defined Area. This isn't the sense of the game and in the previous version this bug didn't exist.

Reproducible: Always

Steps to Reproduce:
Start the application and try to place countries in a map.

Actual Results:  
No contours, but after placing the country in the map you can see the good results but you have no chance to place it right, because whil placing it you only see a coloured area.

Expected Results:  
Should work as prevously

OS: Linux (i686) release 3.0.0-12-generic
Compiler: gcc
Comment 1 Albert Astals Cid 2011-10-30 18:11:13 UTC
Which map? Please attach a screenshot to show the problem.
Comment 2 Norbert Lederbauer 2011-10-30 20:27:51 UTC
Created attachment 65049 [details]
Screenshot germany
Comment 3 Norbert Lederbauer 2011-10-30 20:33:43 UTC
Can't make any sceenshot with Ksnapshot. If I choose "whole image" the I see nothing, when I choose "under the mouse arrow" I see the right contours. (but only on the snapshot)
This occures since KDE 4.7.2
The map doesn matter.
Perhaps is it due to  a bad upgrade from Natty to Oneiric. (Kubuntu)
Comment 4 Albert Astals Cid 2011-10-30 20:49:52 UTC
That is a weird behaviour and the fact that ksnapshot + under mouse works makes me guess it is actually something else in your system that is "broken". Can you try disabling kwin effects if you use them?
Comment 5 Norbert Lederbauer 2011-10-30 22:41:39 UTC
no kwin effects.
Comment 6 Albert Astals Cid 2011-10-30 22:50:50 UTC
Can you try ktuberling/potato guy and see if you have the same kind of problem with the cursor not turning into what it should when clicking on things there?
Comment 7 Norbert Lederbauer 2011-10-30 23:04:56 UTC
I jnstalled Ktuberling, there are no problems
Comment 8 Norbert Lederbauer 2011-11-07 18:30:14 UTC
I did a new installation of my Kubuntu 10.11. 
I kept the ~/home folder (to preserve settings and my files)
I tryed the new installed Kgeography - same result as before
I deleted ~/.kde/share/config/kgeographyrc  no changes
Comment 9 Albert Astals Cid 2011-11-11 10:07:00 UTC
Do you know what graphics card do you have? Which X version?
Comment 10 Norbert Lederbauer 2011-11-11 10:28:03 UTC
This is an ASUS K51AC with an AMD CPU and an onboard ATI graphic card. (Number??)
I use the (k)ubuntu radeon driver
The X-version ..shipped with KDE 4.7.2
Comment 11 Laurent G. 2011-11-11 10:40:19 UTC
Hum, I got a weird behaviour when playing while zoomed. Investigating.
Comment 12 Laurent G. 2011-11-11 10:50:33 UTC
When we start a game and the cursor was "zoom" we never get another one back.
This is a bug.
May be that is what causes the bug you report, Norbert ? Have you the "zoom" (straight cross) mouse cursor set ?
Comment 13 Laurent G. 2011-11-11 11:29:26 UTC
Hum, after seeing your screen shot, I guess the bug I described is not your bug. As Albert, I think it is a probably a problem on a lower layer (video card driver / X11 / qt). Did you try to continue to play even though you can not really see what you do (you have the division name on the left ;-) )? Does it happen even with small area divisions ?
Comment 14 Norbert Lederbauer 2011-11-11 14:36:01 UTC
First of all I inform you about my graphic card: Radeon HD 3200
X server version 11.0

2. Yes, with small area divisions there are no problems (f.ex Berlin in the Map of Germany)
The behaviour of the software is the same: It registers if I place the country there where it should be and also the fails (which are more often now because I can't see what I do.)

3. This problem only exists since Oneiric. In the distribution before (Natty) all worked fine.
(But I have also problems wit the network (too slow) and with some programs (openbve f.ex))
Could be a bug only for my computer ...

I retried with the cursor on zoom. The map did'nt zoom but with every tap on the touchpad all coutries/states/provinces where placed automatically one by one.
Strange, isn't it ?
Comment 15 Albert Astals Cid 2013-01-20 16:38:43 UTC
*** Bug 313476 has been marked as a duplicate of this bug. ***
Comment 16 Norbert Lederbauer 2013-01-21 14:44:12 UTC
Back from Bug 313476 
Albert Astals Cid explaind me that the bug still isn't resolved. Maybe I should try the frgl driver but unfortunately I can't install it with "jockey" and I do not know how to edit the Xorg.conf.
Comment 17 Norbert Lederbauer 2013-03-21 14:17:17 UTC
Today I tryed one more time to place the 50 states of the US in the map. No problem with Delaware and west-Virgina, the other 48 have no contours. Imagine: I'm not able to place Hawaii though it's on a separated map.
My computer is still the same: Asus K51 AC, onBoard Radeon HD3200
Os Kubuntu 12.10 Quantal, kernel 3.5.0-26,
Comment 18 Norbert Lederbauer 2013-08-13 12:00:42 UTC
Now using KDE 4.10.5 and Kubuntu 13.04 and there are no changes in the behaviour.
I'm not able to place regions or states in the map, because i can't see the contour. When I make a screenshot, all is visible as it should be  and so I added some photographs to se the result. 
Since october 2011 (nearly two years) I told you about this bug and my impression is that's not really bothering you. Please try to find an explain or give me some hints what to do.
The computer is still the same so you know the facts.

Comment 19 Albert Astals Cid 2013-08-13 12:50:34 UTC
Stop acting like i should obey your wishes. It works for me, so i can't easily fix it. If you want you can send me your computer and i'll make sure it works.
Comment 20 Norbert Lederbauer 2013-08-14 12:40:13 UTC
I'm very surprised hearing you argue like this. 
My problem is that it worked with the natty distribution and later on it did'nt work. My wish was to find the reason why. But you offered me to to this on my computer so I'll ship it to you if you give me your address. Or you come to me and I'll make you a sandwich while working in my computer. Seriously !

But perhaps it's only a package missing but I don't know which one.

Comment 21 Albert Astals Cid 2013-08-14 21:04:24 UTC
Yes, i told you, i did not change anything in years, so if it worked in natty and doesn't work later, it is most probably a problem somewhere else in the stack, given i do use ubuntu as you do and it works for me, it'd seem even more probable that is the graphics driver.
Comment 22 Jaime Torres 2013-10-22 18:30:24 UTC
I've reproduced this bug (never happened to me before).
In my case, with Portugal Map, having to place Beira Baixa.
When I move the mouse with the region to place, it blinks the region, and the borders opposite to the move (if you move up left, then right bottom) are filled with the color of the region.

@Albert, I'll try to fix it, as I can reproduce it.
Comment 23 Norbert Lederbauer 2013-10-22 18:46:42 UTC
Meanwhile I tryed to instrall the ATI fglrx driver for my graphic card. The resolution on my screen was bad but kgeography worked. Unfortunately I had to remove this driver and go to the radeon driver again, but I told the developers about this bug and maybe they can fix it from this side. I'm waiting for the 13.10 release. (Kubuntu)
Comment 24 Jaime Torres 2013-11-12 19:55:33 UTC
Git commit c4b0e15a73c7b01052f573c6bc85c8418fb3a463 by Jaime Torres.
Committed on 12/11/2013 at 19:35.
Pushed by jtamate into branch 'KDE/4.12'.

qgraphicsview handles the map and divisions

Using addPixmap to a QGraphicsView, just let the view handle the zoom,
moves.... Just handling all the view events to move the division
FIXED-IN: 4.12
REVIEW: 113425

M  +13   -19   src/placeasker.cpp
M  +2    -5    src/placeasker.h
M  +80   -53   src/placemapwidget.cpp
M  +7    -4    src/placemapwidget.h

Comment 25 Jaime Torres 2013-11-12 19:56:40 UTC
Git commit cb4705ac1ed8cf205fd9ddbbad86a093b85ce9a8 by Jaime Torres.
Committed on 12/11/2013 at 19:35.
Pushed by jtamate into branch 'master'.

qgraphicsview handles the map and divisions

Using addPixmap to a QGraphicsView, just let the view handle the zoom,
moves.... Just handling all the view events to move the division
FIXED-IN: 4.12
REVIEW: 113425

M  +13   -19   src/placeasker.cpp
M  +2    -5    src/placeasker.h
M  +80   -53   src/placemapwidget.cpp
M  +7    -4    src/placemapwidget.h