Bug 284721 - Rekonq crahes on page reload
Summary: Rekonq crahes on page reload
Status: RESOLVED DUPLICATE of bug 281865
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.7.90
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-22 18:00 UTC by Stanislav Sidorenko
Modified: 2011-10-25 09:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Sidorenko 2011-10-22 18:00:49 UTC
Application: rekonq (0.7.90)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

1) Open rekonq.
2) Go to http://rutracker.org/
3) Wait until page is completely loaded
4) Refresh the page and again wait until page is completely loaded

Refreshing the page (step 4) always causes rekonq crash on second of third time. It is a bit strange that stack trace contains lines related to flash pluging because the crash occurs if manual plugings loading enabled. It never occurs if plugins are disabled.


- Custom settings of the application:
Manual pluging load is set.

The crash can be reproduced every time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f432ed2d780 (LWP 9919))]

Thread 12 (Thread 0x7f430b767700 (LWP 9920)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f432d612c2c in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f432dfc9220) at wtf/FastMalloc.cpp:2495
#2  0x00007f432d612d59 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f4328d47efc in start_thread (arg=0x7f430b767700) at pthread_create.c:304
#4  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f430ae66700 (LWP 9921)):
#0  0xffffffffff600147 in ?? ()
#1  0x00007f430ae65b40 in ?? ()
#2  0x00007fff02dff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 10 (Thread 0x7f4309fee700 (LWP 9922)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f432e173fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f432e174019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f4328d47efc in start_thread (arg=0x7f4309fee700) at pthread_create.c:304
#4  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f4308ad9700 (LWP 9923)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f43292ea1ab in wait (time=18446744073709551615, this=0x1d97f00) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1def390, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f432b2fa864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1db6dd0, th=0x23b5960) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f432b2fce0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1dfe850, th=0x23b5960) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f432b2fbccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f4308ad8e20, parent=0x1db6dd0, th=0x23b5960) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f432b2fbd5b in ThreadWeaver::Thread::run (this=0x23b5960) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f43292e9d05 in QThreadPrivate::start (arg=0x23b5960) at thread/qthread_unix.cpp:331
#8  0x00007f4328d47efc in start_thread (arg=0x7f4308ad9700) at pthread_create.c:304
#9  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f42c1e85700 (LWP 9924)):
#0  0x00007f432e565773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f432717af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f432717b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f43293fbf3e in QEventDispatcherGlib::processEvents (this=0x203b300, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f43293cfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f43293cfef7 in QEventLoop::exec (this=0x7f42c1e84dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f43292e727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f43293b2cbf in QInotifyFileSystemWatcherEngine::run (this=0x26981f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f43292e9d05 in QThreadPrivate::start (arg=0x26981f0) at thread/qthread_unix.cpp:331
#9  0x00007f4328d47efc in start_thread (arg=0x7f42c1e85700) at pthread_create.c:304
#10 0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f42bdccb700 (LWP 9930)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f43292ea1ab in wait (time=18446744073709551615, this=0x1d97f00) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1def390, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f432b2fa864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1db6dd0, th=0x2cb92f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f432b2fce0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1dfe850, th=0x2cb92f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f432b2fbccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f42bdccae20, parent=0x1db6dd0, th=0x2cb92f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f432b2fbd5b in ThreadWeaver::Thread::run (this=0x2cb92f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f43292e9d05 in QThreadPrivate::start (arg=0x2cb92f0) at thread/qthread_unix.cpp:331
#8  0x00007f4328d47efc in start_thread (arg=0x7f42bdccb700) at pthread_create.c:304
#9  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f42bd4ca700 (LWP 9931)):
#0  __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:89
#1  0x00007f432717af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f432717b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f43293fbf3e in QEventDispatcherGlib::processEvents (this=0x2aeee20, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f43293cfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f43293cfef7 in QEventLoop::exec (this=0x7f42bd4c9dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f43292e727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f432b8f97ce in KIO::NameLookUpThread::run (this=0x7f430400f8c0) at ../../kio/kio/hostinfo.cpp:226
#8  0x00007f43292e9d05 in QThreadPrivate::start (arg=0x7f430400f8c0) at thread/qthread_unix.cpp:331
#9  0x00007f4328d47efc in start_thread (arg=0x7f42bd4ca700) at pthread_create.c:304
#10 0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f42b6570700 (LWP 9975)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f42baf95dac in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2  0x00007f42bb0b3d00 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3  0x00007f42baf9600c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4  0x00007f42baf9645e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5  0x00007f4328d47efc in start_thread (arg=0x7f42b6570700) at pthread_create.c:304
#6  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f42b5d6f700 (LWP 9976)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f42baf95dac in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2  0x00007f42bb0b3d00 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3  0x00007f42baf9600c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4  0x00007f42baf9645e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5  0x00007f4328d47efc in start_thread (arg=0x7f42b5d6f700) at pthread_create.c:304
#6  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f42b556e700 (LWP 9977)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f42baf95dac in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2  0x00007f42bb0b3d00 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3  0x00007f42baf9600c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4  0x00007f42baf9645e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5  0x00007f4328d47efc in start_thread (arg=0x7f42b556e700) at pthread_create.c:304
#6  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f42b4d6d700 (LWP 9978)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f42baf95dac in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2  0x00007f42bb0b3d00 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3  0x00007f42baf9600c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4  0x00007f42baf9645e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5  0x00007f4328d47efc in start_thread (arg=0x7f42b4d6d700) at pthread_create.c:304
#6  0x00007f432e57189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f432ed2d780 (LWP 9919)):
[KCrash Handler]
#6  0x00007f43271960b5 in g_slice_alloc () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f43271966e6 in g_slice_alloc0 () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f432745def9 in g_type_create_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#9  0x00007f432743e5ac in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#10 0x00007f4327440e94 in g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007f432744208c in g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007f42ba90818a in gtk_plug_new_for_display () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#13 0x00007f42baf9157a in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#14 0x00007f42baf88f2f in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#15 0x00007f432d30b74c in WebCore::PluginView::setNPWindowIfNeeded (this=0x7f42b127a9c0) at plugins/qt/PluginViewQt.cpp:701
#16 0x00007f432d30c842 in WebCore::PluginView::platformStart (this=0x7f42b127a9c0) at plugins/qt/PluginViewQt.cpp:1008
#17 0x00007f432d1d22c2 in WebCore::PluginView::start (this=0x7f42b127a9c0) at plugins/PluginView.cpp:268
#18 0x00007f432d1d25bb in WebCore::PluginView::init (this=0x7f42b127a9c0) at plugins/PluginView.cpp:201
#19 0x00007f432d1b8a3a in WebCore::ScrollView::addChild (this=0x7f42bdf59dc0, prpChild=...) at platform/ScrollView.cpp:74
#20 0x00007f432d2bc5de in WebCore::moveWidgetToParentSoon (child=0x7f42b127a9c0, parent=0x7f42bdf59dc0) at rendering/RenderWidget.cpp:90
#21 0x00007f432d2bd147 in WebCore::RenderWidget::setWidget (this=0x7f42bde6f938, widget=<optimized out>) at rendering/RenderWidget.cpp:224
#22 0x00007f432d283097 in WebCore::RenderPart::setWidget (this=<optimized out>, widget=<optimized out>) at rendering/RenderPart.cpp:51
#23 0x00007f432d0fc831 in WebCore::SubframeLoader::loadPlugin (this=0x7f430ae7fb10, pluginElement=<optimized out>, url=..., mimeType=..., paramNames=..., paramValues=..., useFallback=false) at loader/SubframeLoader.cpp:370
#24 0x00007f432d0fd299 in WebCore::SubframeLoader::requestObject (this=0x7f430ae7fb10, ownerElement=0x2bc0400, url=<optimized out>, frameName=..., mimeType=..., paramNames=..., paramValues=...) at loader/SubframeLoader.cpp:142
#25 0x00007f432cfef90f in WebCore::HTMLObjectElement::updateWidget (this=0x2bc0400, pluginCreationOption=<optimized out>) at html/HTMLObjectElement.cpp:330
#26 0x00007f432d14178f in WebCore::FrameView::updateWidget (this=<optimized out>, object=0x7f42bde6f938) at page/FrameView.cpp:1938
#27 0x00007f432d144986 in WebCore::FrameView::updateWidgets (this=0x7f42bdf59dc0) at page/FrameView.cpp:1970
#28 0x00007f432d144b59 in WebCore::FrameView::performPostLayoutTasks (this=0x7f42bdf59dc0) at page/FrameView.cpp:2014
#29 0x00007f432d1458bf in WebCore::FrameView::layout (this=0x7f42bdf59dc0, allowSubtree=<optimized out>) at page/FrameView.cpp:1022
#30 0x00007f432cec3788 in WebCore::Document::updateLayoutIgnorePendingStylesheets (this=0x7f430805ac00) at dom/Document.cpp:1611
#31 0x00007f432cfeb7bd in WebCore::HTMLObjectElement::renderWidgetForJSBindings (this=0x5c9df80) at html/HTMLObjectElement.cpp:79
#32 0x00007f432cff3745 in WebCore::HTMLPlugInElement::pluginWidget (this=<optimized out>) at html/HTMLPlugInElement.cpp:109
#33 0x00007f432cdf2496 in WebCore::pluginScriptObjectFromPluginViewBase (pluginElement=<optimized out>, globalObject=0x7f43159a4150) at bindings/js/JSPluginElementFunctions.cpp:60
#34 0x00007f432cdf268f in WebCore::pluginScriptObject (exec=0x7f42c3c00100, jsHTMLElement=<optimized out>) at bindings/js/JSPluginElementFunctions.cpp:90
#35 0x00007f432cdf2a14 in WebCore::runtimeObjectCustomGetOwnPropertySlot (exec=0x7f42c3c00100, propertyName=..., slot=..., element=0x7f431571da40) at bindings/js/JSPluginElementFunctions.cpp:115
#36 0x00007f432ca925f9 in WebCore::JSHTMLObjectElement::getOwnPropertySlot (this=0x7f431571da40, exec=0x7f42c3c00100, propertyName=..., slot=...) at ../../WebCore/generated/JSHTMLObjectElement.cpp:181
#37 0x00007f432d6448ed in fastGetOwnPropertySlot (this=0x7f431571da40, slot=..., propertyName=..., exec=0x7f42c3c00100) at runtime/JSObject.h:512
#38 JSC::JSValue::get (this=<optimized out>, exec=0x7f42c3c00100, propertyName=..., slot=...) at runtime/JSObject.h:764
#39 0x00007f432d646372 in JSC::cti_op_get_by_id_method_check (args=<optimized out>) at jit/JITStubs.cpp:1520
#40 0x00007f42c402d6a4 in ?? ()
#41 0x00007f4200000008 in ?? ()
#42 0x00007f431571da40 in ?? ()
#43 0x00007f4308097740 in ?? ()
#44 0x00007f42b126a000 in ?? ()
#45 0x0000000000000c7a in ?? ()
#46 0x00007f430804a000 in ?? ()
#47 0x0000000000000000 in ?? ()

This bug may be a duplicate of or related to bug 284692.

Possible duplicates by query: bug 284693, bug 284692, bug 284580, bug 284575, bug 284498.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-25 09:36:51 UTC

*** This bug has been marked as a duplicate of bug 281865 ***