Bug 284692 - Rekonq error in the browser after entering into a forum and on another page
Summary: Rekonq error in the browser after entering into a forum and on another page
Status: RESOLVED DUPLICATE of bug 281865
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.7.90
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-22 10:59 UTC by Edson
Modified: 2011-10-25 09:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edson 2011-10-22 10:59:49 UTC
Application: rekonq (0.7.90)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
I was reading a site that contained a page following this page simply by entering the error occurred closing all my windows open in the browser

The crash can be reproduced every time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0xb770a710 (LWP 4045))]

Thread 6 (Thread 0xac829b70 (LWP 4046)):
#0  0x009e6416 in __kernel_vsyscall ()
#1  0x00aa5a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0072bcfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x01fb8883 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x26d4340) at wtf/FastMalloc.cpp:2495
#4  0x01fb899f in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x26d4340) at wtf/FastMalloc.cpp:1618
#5  0x00aa1d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x0071e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 5 (Thread 0xac028b70 (LWP 4047)):
#0  0x027a77f5 in qt_gettime () at tools/qelapsedtimer_unix.cpp:146
#1  0x0287a4b6 in QTimerInfoList::updateCurrentTime (this=0x9b2b644) at kernel/qeventdispatcher_unix.cpp:339
#2  0x0287a80a in QTimerInfoList::timerWait (this=0x9b2b644, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#3  0x02879053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xac02815c) at kernel/qeventdispatcher_glib.cpp:136
#4  0x0780a88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0780b637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x0780bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x02879b37 in QEventDispatcherGlib::processEvents (this=0x9b39cf0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#8  0x0284a1dd in QEventLoop::processEvents (this=0xac0282e0, flags=...) at kernel/qeventloop.cpp:149
#9  0x0284a421 in QEventLoop::exec (this=0xac0282e0, flags=...) at kernel/qeventloop.cpp:201
#10 0x0274d90b in QThread::exec (this=0x9ac2370) at thread/qthread.cpp:498
#11 0x0274d9fb in QThread::run (this=0x9ac2370) at thread/qthread.cpp:565
#12 0x027507b3 in QThreadPrivate::start (arg=0x9ac2370) at thread/qthread_unix.cpp:331
#13 0x00aa1d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x0071e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xab827b70 (LWP 4048)):
#0  0x009e6416 in __kernel_vsyscall ()
#1  0x00aa5a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0072bcfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x002849a9 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0x002849ef in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0x00aa1d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x0071e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xaaea1b70 (LWP 4049)):
#0  0x009e6416 in __kernel_vsyscall ()
#1  0x00aa5a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0072bcfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x02750cc0 in wait (time=4294967295, this=0x992c298) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x993c740, mutex=0x993f020, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00d9d406 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x993c728, th=0x9d23f98) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x00d9fecb in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x992e400, th=0x9d23f98) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x00d9d03a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x993c728, th=0x9d23f98) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x00d9ffcc in ThreadWeaver::WorkingHardState::applyForWork (this=0x992e400, th=0x9d23f98) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00d9cf93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x993c728, th=0x9d23f98, previous=0xa25c0f8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x00d9eb14 in ThreadWeaver::ThreadRunHelper::run (this=0xaaea1314, parent=0x993c728, th=0x9d23f98) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x00d9ebca in ThreadWeaver::Thread::run (this=0x9d23f98) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x027507b3 in QThreadPrivate::start (arg=0x9d23f98) at thread/qthread_unix.cpp:331
#13 0x00aa1d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x0071e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa4ec3b70 (LWP 4060)):
#0  0x009e6416 in __kernel_vsyscall ()
#1  0x00aa5a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0072bcfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x02750cc0 in wait (time=4294967295, this=0x992c298) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x993c740, mutex=0x993f020, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00d9d406 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x993c728, th=0xa26a980) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x00d9fecb in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x992e400, th=0xa26a980) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x00d9d03a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x993c728, th=0xa26a980) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x00d9ffcc in ThreadWeaver::WorkingHardState::applyForWork (this=0x992e400, th=0xa26a980) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00d9cf93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x993c728, th=0xa26a980, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x00d9eb14 in ThreadWeaver::ThreadRunHelper::run (this=0xa4ec3314, parent=0x993c728, th=0xa26a980) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x00d9ebca in ThreadWeaver::Thread::run (this=0xa26a980) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x027507b3 in QThreadPrivate::start (arg=0xa26a980) at thread/qthread_unix.cpp:331
#13 0x00aa1d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x0071e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb770a710 (LWP 4045)):
[KCrash Handler]
#7  0x078279cd in g_slice_alloc () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x07827fe6 in g_slice_alloc0 () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x00d63b56 in g_type_create_instance () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#10 0x00d433cb in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#11 0x00d45e79 in g_object_newv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#12 0x00d47068 in g_object_new () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#13 0x05f1d5eb in gtk_plug_new_for_display () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#14 0x05f1d644 in gtk_plug_new () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#15 0xa5477968 in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#16 0xa546dbbb in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#17 0xa5473f44 in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#18 0x01c7fd00 in WebCore::PluginView::setNPWindowIfNeeded (this=0xa7e37844) at plugins/qt/PluginViewQt.cpp:701
#19 0x01c80541 in WebCore::PluginView::updatePluginWidget (this=0xa7e376c0) at plugins/qt/PluginViewQt.cpp:183
#20 0x01c80e45 in WebCore::PluginView::platformStart (this=0xa7e376c0) at plugins/qt/PluginViewQt.cpp:1007
#21 0x01b2db9b in WebCore::PluginView::start (this=0xa7e376c0) at plugins/PluginView.cpp:268
#22 0x01b2dee9 in WebCore::PluginView::init (this=0xa7e376c0) at plugins/PluginView.cpp:201
#23 0x01c7fb7a in WebCore::PluginView::setParent (this=0xa7e376c0, parent=0xb6665400) at plugins/qt/PluginViewQt.cpp:616
#24 0x01b12fb0 in WebCore::ScrollView::addChild (this=0xb6665400, prpChild=...) at platform/ScrollView.cpp:74
#25 0x01c290ca in WebCore::moveWidgetToParentSoon (child=0xa7e376c0, parent=0xb6665400) at rendering/RenderWidget.cpp:90
#26 0x01c29b55 in WebCore::RenderWidget::setWidget (this=0xa7ef5590, widget=...) at rendering/RenderWidget.cpp:224
#27 0x01bebd4f in WebCore::RenderPart::setWidget (this=0xa7ef5590, widget=...) at rendering/RenderPart.cpp:51
#28 0x01a4c775 in WebCore::SubframeLoader::loadPlugin (this=0xb65d9764, pluginElement=0xa0d8320, url=..., mimeType=..., paramNames=..., paramValues=..., useFallback=false) at loader/SubframeLoader.cpp:370
#29 0x01a4d200 in WebCore::SubframeLoader::requestObject (this=0xb65d9764, ownerElement=0xa0d8320, url=..., frameName=..., mimeType=..., paramNames=..., paramValues=...) at loader/SubframeLoader.cpp:142
#30 0x0190a1e4 in WebCore::HTMLEmbedElement::updateWidget (this=0xa0d8320, pluginCreationOption=WebCore::CreateAnyWidgetType) at html/HTMLEmbedElement.cpp:183
#31 0x01a95ecb in WebCore::FrameView::updateWidget (this=0xb6665400, object=0xa7ef5590) at page/FrameView.cpp:1938
#32 0x01a993be in WebCore::FrameView::updateWidgets (this=0xb6665400) at page/FrameView.cpp:1970
#33 0x01a995a4 in WebCore::FrameView::performPostLayoutTasks (this=0xb6665400) at page/FrameView.cpp:2014
#34 0x01a92115 in WebCore::Timer<WebCore::FrameView>::fired (this=0xb6665534) at platform/Timer.h:100
#35 0x01b1b2c2 in WebCore::ThreadTimers::sharedTimerFiredInternal (this=0xb65eb120) at platform/ThreadTimers.cpp:112
#36 0x01b1b33d in WebCore::ThreadTimers::sharedTimerFired () at platform/ThreadTimers.cpp:90
#37 0x01c79f9e in timerEvent (this=0x9cf9028, ev=<optimized out>) at platform/qt/SharedTimerQt.cpp:120
#38 WebCore::SharedTimerQt::timerEvent (this=0x9cf9028, ev=0xbf9b59ac) at platform/qt/SharedTimerQt.cpp:114
#39 0x02863994 in QObject::event (this=0x9cf9028, e=0xbf9b59ac) at kernel/qobject.cpp:1181
#40 0x03276d54 in notify_helper (e=0xbf9b59ac, receiver=0x9cf9028, this=0x983a520) at kernel/qapplication.cpp:4486
#41 QApplicationPrivate::notify_helper (this=0x983a520, receiver=0x9cf9028, e=0xbf9b59ac) at kernel/qapplication.cpp:4458
#42 0x0327c103 in QApplication::notify (this=0xbf9b59ac, receiver=0x9cf9028, e=0xbf9b59ac) at kernel/qapplication.cpp:3886
#43 0x02ecd721 in KApplication::notify (this=0xbf9b5cc8, receiver=0x9cf9028, event=0xbf9b59ac) at ../../kdeui/kernel/kapplication.cpp:311
#44 0x0284b19e in QCoreApplication::notifyInternal (this=0xbf9b5cc8, receiver=0x9cf9028, event=0xbf9b59ac) at kernel/qcoreapplication.cpp:787
#45 0x0287bc10 in sendEvent (event=0xbf9b59ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#46 QTimerInfoList::activateTimers (this=0x9836b54) at kernel/qeventdispatcher_unix.cpp:603
#47 0x02879122 in timerSourceDispatch (source=0x9836b20) at kernel/qeventdispatcher_glib.cpp:184
#48 0x0780b25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#49 0x0780b990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#50 0x0780bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#51 0x02879ada in QEventDispatcherGlib::processEvents (this=0x9815218, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#52 0x0332ee3a in QGuiEventDispatcherGlib::processEvents (this=0x9815218, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x0284a1dd in QEventLoop::processEvents (this=0xbf9b5c24, flags=...) at kernel/qeventloop.cpp:149
#54 0x0284a421 in QEventLoop::exec (this=0xbf9b5c24, flags=...) at kernel/qeventloop.cpp:201
#55 0x0284f19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#56 0x032748f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#57 0x00f5f89e in kdemain (argc=1, argv=0xbf9b5fe4) at /build/buildd/rekonq-0.7.90/src/main.cpp:215
#58 0x0804850b in main (argc=1, argv=0xbf9b5fe4) at /build/buildd/rekonq-0.7.90/obj-i686-linux-gnu/src/rekonq_dummy.cpp:3

Possible duplicates by query: bug 284580, bug 284575, bug 284498, bug 284487, bug 284301.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-25 09:37:50 UTC

*** This bug has been marked as a duplicate of bug 281865 ***