Bug 284105 - Akonadi spams systray (knotify) with "item cannot be retrieved" messages
Summary: Akonadi spams systray (knotify) with "item cannot be retrieved" messages
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Unclassified
Component: general (show other bugs)
Version: 1.6.0
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-15 15:40 UTC by S. Burmeister
Modified: 2016-09-28 16:44 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2011-10-15 15:40:28 UTC
Version:           1.6.0 (using KDE 4.7.2) 
OS:                Linux

If one goes offline while akonadi hangs retrieving emails from an imap account (akonaditry enabled) the notification area is spammed with notifications about "the item cannot be retrieved while in offline mode".

To display this info for each message with the same non-specific text is useless and causes CPU and speaker noise. The notifications cover each other thus one cannot even read the text.

In case this is a kmail2 issue, please feel free to re-assing.

Reproducible: Didn't try

Steps to Reproduce:
As one can read above:
Enable the akonaditray icon
Go offline with kmail2 while akonadi retrieves emails from an imap account

Actual Results:  
Hundreds of unreadable and useless notifications

Expected Results:  
One notification that emails cannot be retrieved while kmail2 is in offline mode
Comment 1 S. Burmeister 2011-10-16 11:04:12 UTC
It seems akonadi and kmail2 share this bug and add an entry each to .xsession-errors:

akonaditray(8769)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
akonaditray(8769)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
akonaditray(8769)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
kmail2(11125): 103 "Unbekannter Fehler. (Unable to fetch item from backend)" 
kmail2(11125): 103 "Unbekannter Fehler. (Unable to fetch item from backend)" 
akonaditray(8769)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
kmail2(11125): 103 "Unbekannter Fehler. (Unable to fetch item from backend)" 
akonaditray(8769)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
kmail2(11125): 103 "Unbekannter Fehler. (Unable to fetch item from backend)"
Comment 2 Ricardo Brisighelli 2012-01-28 15:14:34 UTC
Vesion: knotify-4.7.4, akonadi-server-1.6.2-r1, akonadiconsole-4.7.4
OS: Linux  Gentoo x86  and Gentoo amd64

Same problem 

When akonadi cant connect to IMAP server "akonadi spam notify" and knotify4 CPU 100%, some times knotify crash.

If stop akonadi server, knotify cpu 100%, then kill knotify everything returns to normal, but akonadi server ar stoped. 

Reproducible: starts again akonadi (and imap server down)
Comment 3 Ricardo Brisighelli 2012-01-28 15:36:37 UTC
The bug occurs when akonadi are conected to imap server (days) and then cant longer connect.
Comment 4 Dennis Schridde 2012-10-04 23:16:21 UTC
I am using KDE 4.9.2 and I once experienced a similar problem (see bug #197367 or bug #222595). However, I have *not* seen this problem anymore since quite a while.
Comment 5 Denis Kurz 2016-09-24 20:36:54 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 6 Ricardo Brisighelli 2016-09-27 11:38:31 UTC
(In reply to Denis Kurz from comment #5)
> This bug has only been reported for versions older than KDEPIM 4.14 (at most
> akonadi-1.3). Can anyone tell if this bug still present?
> 
> If noone confirms this bug for a recent version of akonadi (part of KDE
> Applications 15.08 or later), it gets closed in about three months.

I am not see this problem in  kdepimlibs-4.14.11 and akonadi-server-1.13.1
Comment 7 Denis Kurz 2016-09-28 16:44:55 UTC
Then let's hope it's fixed. Thanks for your feedback.