Bug 282854 - akonadi_nepomuk_feeder always crashes on startup
Summary: akonadi_nepomuk_feeder always crashes on startup
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Nepomuk Feeder Agents (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-26 19:19 UTC by András Manţia
Modified: 2011-11-19 15:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.83 KB, text/plain)
2011-09-26 23:04 UTC, Valentin Rusu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description András Manţia 2011-09-26 19:19:43 UTC
Application: akonadi_nepomuk_feeder (4.7)
KDE Platform Version: 4.7.41 (4.7.41 (KDE 4.8 >= 20110807) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 2.6.37.6-0.7-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
Just started akonadiserver with kdepim code from master and I always get this crash. As soon as the crash dialog is closed, the feeder agent is restarted and crashes again. This goes on until I remove the agent.
The crash location is weird though I don't have a real idea why it crashes at plugin loading.

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Nepomuk Feeder (akonadi_nepomuk_feeder), signal: Segmentation fault
[KCrash Handler]
#6  0x000000000000557e in ?? ()
#7  0x00007f21fc293feb in Akonadi::qt_plugin_instance () at /home/andris/development/sources/kde-trunk/kdepim/nepomuk_email_feeder/nepomukmailfeeder.cpp:249
#8  0x00007f220ce87810 in kde4Factory (lib=0x7ceed0) at /home/andris/development/sources/kde-trunk/kdelibs/kdecore/util/klibrary.cpp:149
#9  0x00007f220ce87a4b in KLibrary::factory (this=0x7ceed0, factoryname=0x82f1a8 "akonadi_nepomuk_email_feeder") at /home/andris/development/sources/kde-trunk/kdelibs/kdecore/util/klibrary.cpp:169
#10 0x00007f220ce8dd49 in KPluginLoader::factory (this=0x7fff65bca3b0) at /home/andris/development/sources/kde-trunk/kdelibs/kdecore/util/kpluginloader.cpp:197
#11 0x000000000040b6cf in createInstance<Akonadi::NepomukFeederPlugin> (this=0x61e780, mimetype=...) at /opt/kde4/include/kservice.h:549
#12 createInstance<Akonadi::NepomukFeederPlugin> (this=0x61e780, mimetype=...) at /opt/kde4/include/kservice.h:528
#13 FeederPluginloader::feederPluginsForMimeType (this=0x61e780, mimetype=...) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/pluginloader.cpp:43
#14 0x0000000000410880 in NepomukHelpers::addItemToGraph (item=..., graph=...) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/nepomukhelpers.cpp:104
#15 0x000000000040e9d1 in ItemQueue::processItem (this=0x7e2218) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:321
#16 0x000000000040eb75 in FeederQueue::processItemQueue (this=0x7e21b8) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:229
#17 0x000000000040f658 in FeederQueue::qt_metacall (this=0x7e21b8, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff65bca910) at /home/andris/development/build/kde-trunk/kdepim-runtime/agents/nepomukfeeder/feederqueue.moc:181
#18 0x00007f220c439cb3 in QMetaObject::metacall (object=0x7e21b8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0x7fff65bca910) at kernel/qmetaobject.cpp:237
#19 0x00007f220c44ed8f in QMetaObject::activate (sender=0x7e21f8, m=0x7f220c7bbba0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#20 0x00007f220c4ae1a1 in QTimer::timeout (this=0x7e21f8) at .moc/debug-shared/moc_qtimer.cpp:134
#21 0x00007f220c457d8b in QTimer::timerEvent (this=0x7e21f8, e=0x7fff65bcb310) at kernel/qtimer.cpp:271
#22 0x00007f220c44a5bb in QObject::event (this=0x7e21f8, e=0x7fff65bcb310) at kernel/qobject.cpp:1181
#23 0x00007f220a535bae in QApplicationPrivate::notify_helper (this=0x649eb0, receiver=0x7e21f8, e=0x7fff65bcb310) at kernel/qapplication.cpp:4481
#24 0x00007f220a5331d2 in QApplication::notify (this=0x7fff65bcb700, receiver=0x7e21f8, e=0x7fff65bcb310) at kernel/qapplication.cpp:3881
#25 0x00007f220d414f5d in KApplication::notify (this=0x7fff65bcb700, receiver=0x7e21f8, event=0x7fff65bcb310) at /home/andris/development/sources/kde-trunk/kdelibs/kdeui/kernel/kapplication.cpp:311
#26 0x00007f220c431adf in QCoreApplication::notifyInternal (this=0x7fff65bcb700, receiver=0x7e21f8, event=0x7fff65bcb310) at kernel/qcoreapplication.cpp:787
#27 0x00007f220c435811 in QCoreApplication::sendEvent (receiver=0x7e21f8, event=0x7fff65bcb310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 0x00007f220c46e133 in QTimerInfoList::activateTimers (this=0x64d5d0) at kernel/qeventdispatcher_unix.cpp:603
#29 0x00007f220c46a392 in timerSourceDispatch (source=0x64d570) at kernel/qeventdispatcher_glib.cpp:184
#30 0x00007f2205079bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#31 0x00007f220507a3b0 in ?? () from /lib64/libglib-2.0.so.0
#32 0x00007f220507a650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#33 0x00007f220c46ae5f in QEventDispatcherGlib::processEvents (this=0x62c010, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#34 0x00007f220a60eb2e in QGuiEventDispatcherGlib::processEvents (this=0x62c010, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f220c42f642 in QEventLoop::processEvents (this=0x7fff65bcb660, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f220c42f796 in QEventLoop::exec (this=0x7fff65bcb660, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f220c4321d2 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#38 0x00007f220a532d4a in QApplication::exec () at kernel/qapplication.cpp:3755
#39 0x00007f220c8710ee in Akonadi::AgentBase::init (r=0x7e2160) at /home/andris/development/sources/kde-trunk/kdepimlibs/akonadi/agentbase.cpp:554
#40 0x0000000000409678 in init<Akonadi::NepomukFeederAgent> (argc=<value optimized out>, argv=<value optimized out>) at /opt/kde4/include/akonadi/agentbase.h:342
#41 main (argc=<value optimized out>, argv=<value optimized out>) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/nepomukfeederagent.cpp:318

Possible duplicates by query: bug 282489.

Reported using DrKonqi
Comment 1 András Manţia 2011-09-26 20:13:45 UTC
Cleaned my install dirs and disabled the old feeders to not autostart and no crash since.
Comment 2 András Manţia 2011-09-26 20:17:08 UTC
Aargh, I was too fast. As soon as I closed the report, it crashed.
Comment 3 Valentin Rusu 2011-09-26 23:04:02 UTC
Created attachment 63998 [details]
New crash information added by DrKonqi

akonadi_nepomuk_feeder (4.7) on KDE Platform 4.7.2 (4.7.2) using Qt 4.8.0

- What I was doing when the application crashed:

I just compiled sources (git pull done 3 hours ago) the restarted the session to get this crash.

-- Backtrace (Reduced):
#7  0x00007f3be5ecafd0 in Akonadi::qt_plugin_instance () at /home/kde/src/kdepim/nepomuk_email_feeder/nepomukmailfeeder.cpp:249
#8  0x00007f3bf6ac9a20 in kde4Factory (lib=0x823c80) at /home/kde/work/kdelibs/kdecore/util/klibrary.cpp:149
#9  0x00007f3bf6ac9c5b in KLibrary::factory (this=0x823c80, factoryname=0x8d1008 "akonadi_nepomuk_email_feeder") at /home/kde/work/kdelibs/kdecore/util/klibrary.cpp:169
#10 0x00007f3bf6acffc1 in KPluginLoader::factory (this=0x7fff1dc4e4d0) at /home/kde/work/kdelibs/kdecore/util/kpluginloader.cpp:197
#11 0x000000000040d0ac in KService::createInstance<Akonadi::NepomukFeederPlugin> (this=0x82f900, parentWidget=0x0, parent=0x0, args=..., error=0x7fff1dc4e610) at /home/kde/include/kservice.h:549
Comment 4 Christian Mollekopf 2011-10-20 15:14:46 UTC
I moved the emailfeeder to kdepim-runtime now, which removes the ugly unknown symbols hack. Since it seems to always crash in the emailfeeder that could be the reason for the crash (otherwise I don't really get whats happening).
So please retry.
Comment 5 András Manţia 2011-10-21 07:46:48 UTC
Thanks, the crash seems to be gone. Now virtuoso-t is using a lot of CPU (183%, 4 cores), but at least the agent does not crash.
Comment 6 Christian Mollekopf 2011-10-21 10:52:47 UTC
Yes, that is due to all attemps to store something failing, due to duplicates in the SimpleResourceGraph.
This is an issue being worked on, so I suggest to disable the feeder for now.
Comment 7 Allen Winter 2011-11-17 14:19:52 UTC
Christian, what's the status of the fix for SimpleResourceGraph?  can we close this?
Comment 8 Christian Mollekopf 2011-11-19 15:08:43 UTC
The merging was mostly fixed this week, for the remaining problem I just pushed to patches to master. The feeder work for me like this. In either case the original bug has been resolved, therefore I close this bug.