Bug 282489 - akonadi_nepomuk_feeder crashed during first run after instalation
Summary: akonadi_nepomuk_feeder crashed during first run after instalation
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Nepomuk Feeder Agents (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-21 17:32 UTC by Luis Silva
Modified: 2011-09-26 16:47 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Silva 2011-09-21 17:32:00 UTC
Application: akonadi_nepomuk_feeder (4.7)
KDE Platform Version: 4.7.1 (4.7.1) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-11-generic i686
Distribution: Ubuntu oneiric (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I compiled master of kdepim and installed. After nearly half an our of hi cpu usage where loads of things were being added and removed from nepomuk,  akonadi_nepomuk_feeder crashed without apparent reason.

- Custom settings of the application:
I am compiling kdepim kdepimlibs and kdepim-runtime from master.

-- Backtrace:
Application: Akonadi Agent (akonadi_nepomuk_feeder), signal: Segmentation fault
[KCrash Handler]
#7  0x0142cbfc in NoteMessageWrapperPrivate (msg=<optimized out>, this=<optimized out>) at /home/lacsilva/Development/kdepim.d/kdepimlibs/akonadi/notes/noteutils.cpp:46
#8  Akonadi::NoteUtils::NoteMessageWrapper::NoteMessageWrapper (this=0x0, msg=...) at /home/lacsilva/Development/kdepim.d/kdepimlibs/akonadi/notes/noteutils.cpp:69
#9  0x0142340f in Akonadi::NepomukNoteFeeder::updateItem (this=0x95a0200, item=..., res=..., graph=...) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/agents/nepomukfeeder/plugins/nepomuknotefeeder.cpp:46
#10 0x080573a0 in NepomukHelpers::addItemToGraph (item=..., graph=...) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/agents/nepomukfeeder/nepomukhelpers.cpp:105
#11 0x08055122 in ItemQueue::processItem (this=0x927cb1c) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:321
#12 0x080552de in FeederQueue::processItemQueue (this=0x927cae0) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:229
#13 0x08055e68 in FeederQueue::qt_metacall (this=0x927cae0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfc91574) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/BUILD/agents/nepomukfeeder/feederqueue.moc:181
#14 0x0100eb7d in metacall (argv=0xbfc91574, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x927cae0) at kernel/qmetaobject.cpp:237
#15 QMetaObject::metacall (object=0x927cae0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc91574) at kernel/qmetaobject.cpp:232
#16 0x0101da6a in QMetaObject::activate (sender=0x927cb04, m=0x113f5f8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#17 0x0106c7d5 in QTimer::timeout (this=0x927cb04) at .moc/release-shared/moc_qtimer.cpp:134
#18 0x01025286 in QTimer::timerEvent (this=0x927cb04, e=0xbfc9196c) at kernel/qtimer.cpp:271
#19 0x01020994 in QObject::event (this=0x927cb04, e=0xbfc9196c) at kernel/qobject.cpp:1181
#20 0x053f3d14 in notify_helper (e=0xbfc9196c, receiver=0x927cb04, this=0x9163648) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x9163648, receiver=0x927cb04, e=0xbfc9196c) at kernel/qapplication.cpp:4458
#22 0x053f90c3 in QApplication::notify (this=0xbfc9196c, receiver=0x927cb04, e=0xbfc9196c) at kernel/qapplication.cpp:3886
#23 0x009b3791 in KApplication::notify (this=0xbfc91c80, receiver=0x927cb04, event=0xbfc9196c) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x0100819e in QCoreApplication::notifyInternal (this=0xbfc91c80, receiver=0x927cb04, event=0xbfc9196c) at kernel/qcoreapplication.cpp:787
#25 0x01038c10 in sendEvent (event=0xbfc9196c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x916569c) at kernel/qeventdispatcher_unix.cpp:603
#27 0x01036122 in timerSourceDispatch (source=0x9165668) at kernel/qeventdispatcher_glib.cpp:184
#28 0x014ef2ef in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0x014efa20 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0x014efcba in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x01036ada in QEventDispatcherGlib::processEvents (this=0x914cbb0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#32 0x054abada in QGuiEventDispatcherGlib::processEvents (this=0x914cbb0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x010071dd in QEventLoop::processEvents (this=0xbfc91be4, flags=...) at kernel/qeventloop.cpp:149
#34 0x01007421 in QEventLoop::exec (this=0xbfc91be4, flags=...) at kernel/qeventloop.cpp:201
#35 0x0100c19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x053f18b4 in QApplication::exec () at kernel/qapplication.cpp:3760
#37 0x00cb8c61 in Akonadi::AgentBase::init (r=0x927caa8) at /home/lacsilva/Development/kdepim.d/kdepimlibs/akonadi/agentbase.cpp:539
#38 0x08050f16 in Akonadi::AgentBase::init<Akonadi::NepomukFeederAgent> (argc=3, argv=0xbfc91d64) at /usr/include/akonadi/agentbase.h:342
#39 0x0804d2d7 in main (argc=3, argv=0xbfc91d64) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/agents/nepomukfeeder/nepomukfeederagent.cpp:318

Reported using DrKonqi
Comment 1 Luis Silva 2011-09-22 18:29:33 UTC
After some time I tracked the issue to a crash in virtuoso. That is, the feeder puts the system under heavy load (mostly sorting out the data the old feeders generated in nepomuk, I suspect) and this seems to crash virtuoso. Without virtuoso the feeder crashes. The feeder restarts automatically when virtuoso comes back online.
Comment 2 Luis Silva 2011-09-26 01:56:28 UTC
Some updates. After some days of testing the nepomuk feeder is still crashing every 15 minutes with no relation to virtuoso crashes. That one seemed to be a one off.
However, deleting all my notes resources allowed for a successful and crashless indexing.
Comment 3 András Manţia 2011-09-26 07:24:32 UTC
Since yesterday I also got crashes from akonadi_nepomuk_feeder, different one though:

Application: Akonadi Nepomuk Feeder (akonadi_nepomuk_feeder), signal: Segmentation fault
[KCrash Handler]
#6  0x000000000000557e in ?? ()
#7  0x00007f5e396a5feb in Akonadi::qt_plugin_instance () at /home/andris/development/sources/kde-trunk/kdepim/nepomuk_email_feeder/nepomukmailfeeder.cpp:249
#8  0x00007f5e4a299810 in kde4Factory (lib=0x9f9350) at /home/andris/development/sources/kde-trunk/kdelibs/kdecore/util/klibrary.cpp:149
#9  0x00007f5e4a299a4b in KLibrary::factory (this=0x9f9350, factoryname=0xa02998 "akonadi_nepomuk_email_feeder") at /home/andris/development/sources/kde-trunk/kdelibs/kdecore/util/klibrary.cpp:169
#10 0x00007f5e4a29fd49 in KPluginLoader::factory (this=0x7fff4927cca0) at /home/andris/development/sources/kde-trunk/kdelibs/kdecore/util/kpluginloader.cpp:197
#11 0x000000000040b6cf in createInstance<Akonadi::NepomukFeederPlugin> (this=0x61e780, mimetype=...) at /opt/kde4/include/kservice.h:549
#12 createInstance<Akonadi::NepomukFeederPlugin> (this=0x61e780, mimetype=...) at /opt/kde4/include/kservice.h:528
#13 FeederPluginloader::feederPluginsForMimeType (this=0x61e780, mimetype=...) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/pluginloader.cpp:43
#14 0x0000000000410880 in NepomukHelpers::addItemToGraph (item=..., graph=...) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/nepomukhelpers.cpp:104
#15 0x000000000040e9d1 in ItemQueue::processItem (this=0x7e61f0) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:321
#16 0x000000000040eb31 in FeederQueue::processItemQueue (this=0x7e6158) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:224
#17 0x000000000040f658 in FeederQueue::qt_metacall (this=0x7e6158, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff4927d200) at /home/andris/development/build/kde-trunk/kdepim-runtime/agents/nepomukfeeder/feederqueue.moc:181
#18 0x00007f5e4984bcb3 in QMetaObject::metacall (object=0x7e6158, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0x7fff4927d200) at kernel/qmetaobject.cpp:237
#19 0x00007f5e49860d8f in QMetaObject::activate (sender=0x7e6198, m=0x7f5e49bcdba0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#20 0x00007f5e498c01a1 in QTimer::timeout (this=0x7e6198) at .moc/debug-shared/moc_qtimer.cpp:134
#21 0x00007f5e49869d8b in QTimer::timerEvent (this=0x7e6198, e=0x7fff4927dc00) at kernel/qtimer.cpp:271
#22 0x00007f5e4985c5bb in QObject::event (this=0x7e6198, e=0x7fff4927dc00) at kernel/qobject.cpp:1181
#23 0x00007f5e47947bae in QApplicationPrivate::notify_helper (this=0x649d70, receiver=0x7e6198, e=0x7fff4927dc00) at kernel/qapplication.cpp:4481
#24 0x00007f5e479451d2 in QApplication::notify (this=0x7fff4927dff0, receiver=0x7e6198, e=0x7fff4927dc00) at kernel/qapplication.cpp:3881
#25 0x00007f5e4a826f5d in KApplication::notify (this=0x7fff4927dff0, receiver=0x7e6198, event=0x7fff4927dc00) at /home/andris/development/sources/kde-trunk/kdelibs/kdeui/kernel/kapplication.cpp:311
#26 0x00007f5e49843adf in QCoreApplication::notifyInternal (this=0x7fff4927dff0, receiver=0x7e6198, event=0x7fff4927dc00) at kernel/qcoreapplication.cpp:787
#27 0x00007f5e49847811 in QCoreApplication::sendEvent (receiver=0x7e6198, event=0x7fff4927dc00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 0x00007f5e49880133 in QTimerInfoList::activateTimers (this=0x64d470) at kernel/qeventdispatcher_unix.cpp:603
#29 0x00007f5e4987c392 in timerSourceDispatch (source=0x64d410) at kernel/qeventdispatcher_glib.cpp:184
#30 0x00007f5e4248bbd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#31 0x00007f5e4248c3b0 in ?? () from /lib64/libglib-2.0.so.0
#32 0x00007f5e4248c650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#33 0x00007f5e4987ce5f in QEventDispatcherGlib::processEvents (this=0x62c010, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#34 0x00007f5e47a20b2e in QGuiEventDispatcherGlib::processEvents (this=0x62c010, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f5e49841642 in QEventLoop::processEvents (this=0x7fff4927df50, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f5e49841796 in QEventLoop::exec (this=0x7fff4927df50, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f5e498441d2 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#38 0x00007f5e47944d4a in QApplication::exec () at kernel/qapplication.cpp:3755
#39 0x00007f5e49c830ee in Akonadi::AgentBase::init (r=0x7e6100) at /home/andris/development/sources/kde-trunk/kdepimlibs/akonadi/agentbase.cpp:554
#40 0x0000000000409678 in init<Akonadi::NepomukFeederAgent> (argc=<value optimized out>, argv=<value optimized out>) at /opt/kde4/include/akonadi/agentbase.h:342
#41 main (argc=<value optimized out>, argv=<value optimized out>) at /home/andris/development/sources/kde-trunk/kdepim-runtime/agents/nepomukfeeder/nepomukfeederagent.cpp:318
Comment 4 Christophe Giboudeaux 2011-09-26 08:31:52 UTC
Confirmed in master: 

Thread 1 (Thread 0x7f31e64a5760 (LWP 5689)):
#0  0x00007f31e64f68cf in Akonadi::NoteUtils::NoteMessageWrapper::NoteMessageWrapperPrivate::NoteMessageWrapperPrivate (this=0x610d50, msg=...) at /kde/src/kdepimlibs/akonadi/notes/noteutils.cpp:46
#1  0x00007f31e64f55c5 in Akonadi::NoteUtils::NoteMessageWrapper::NoteMessageWrapper (this=0x7fffa66c5d00, msg=...) at /kde/src/kdepimlibs/akonadi/notes/noteutils.cpp:69
#2  0x00007f31e6356f8e in Akonadi::NepomukNoteFeeder::updateItem (this=0x6d99a0, item=..., res=..., graph=...) at /kde/src/kdepim-runtime/agents/nepomukfeeder/plugins/nepomuknotefeeder.cpp:46
#3  0x0000000000412e1a in NepomukHelpers::addItemToGraph (item=..., graph=...) at /kde/src/kdepim-runtime/agents/nepomukfeeder/nepomukhelpers.cpp:105
#4  0x000000000040ff49 in ItemQueue::processItem (this=0x5e6b70) at /kde/src/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:321
#5  0x000000000040f92c in FeederQueue::processItemQueue (this=0x5e6ad8) at /kde/src/kdepim-runtime/agents/nepomukfeeder/feederqueue.cpp:224
#6  0x0000000000410706 in FeederQueue::qt_metacall (this=0x5e6ad8, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fffa66c6160) at /kde/build/kdepim-runtime/agents/nepomukfeeder/feederqueue.moc:181
#7  0x00007f31e4f0f3fa in QMetaObject::activate (sender=0x5e6b18, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3287
#8  0x00007f31e4f12cd9 in QObject::event (this=0x5e6b18, e=<optimized out>) at kernel/qobject.cpp:1190
#9  0x00007f31e2b5ebe4 in notify_helper (e=0x7fffa66c6860, receiver=0x5e6b18, this=0x4522e0) at kernel/qapplication.cpp:4481
Comment 5 Christian Mollekopf 2011-09-26 09:18:52 UTC
This crash has been fixed with commit 9a58b32c59dc4b012646a3b608ac1e171ac3c844
Comment 6 András Manţia 2011-09-26 09:46:45 UTC
That probably fixes the original crash, but not the one with my BT. Do you want a new report for that?
Comment 7 Christian Mollekopf 2011-09-26 16:47:29 UTC
(In reply to comment #6)
> That probably fixes the original crash, but not the one with my BT. Do you want
> a new report for that?

Since it seems completely unrelated, yes please =)
Although I don't know what happened there or how to debug this.
Your crash looks rather weird.