Bug 282413 - plasms crash
Summary: plasms crash
Status: RESOLVED DUPLICATE of bug 251871
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-20 15:38 UTC by Andrew Patterson
Modified: 2011-09-29 12:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Patterson 2011-09-20 15:38:54 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: error was proportionate after closing an application, additional steps are performed, in this case was opened by the control panel.

-- Backtrace:
Application: Оболочка Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe7219ae7a0 (LWP 1580))]

Thread 6 (Thread 0x7fe709421700 (LWP 1581)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe71b8fb2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fe71bc14180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fe71b8fb2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fe71bc22254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fe716585d8c in start_thread (arg=0x7fe709421700) at pthread_create.c:304
#4  0x00007fe7212ad04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fe706ed3700 (LWP 1582)):
#0  0x00007fe72129ff03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe715c82104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe715c82639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe71e4ae446 in QEventDispatcherGlib::processEvents (this=0x182fb70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe71e482882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe71e482abc in QEventLoop::exec (this=0x7fe706ed2db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe71e399924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fe71e464c2f in QInotifyFileSystemWatcherEngine::run (this=0x182f330) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe71e39c175 in QThreadPrivate::start (arg=0x182f330) at thread/qthread_unix.cpp:320
#9  0x00007fe716585d8c in start_thread (arg=0x7fe706ed3700) at pthread_create.c:304
#10 0x00007fe7212ad04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fe704880700 (LWP 1583)):
#0  0x00007fe72129ff03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe715c82104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe715c82639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe71e4ae446 in QEventDispatcherGlib::processEvents (this=0x153dc90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe71e482882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe71e482abc in QEventLoop::exec (this=0x7fe70487fdb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe71e399924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fe71e464c2f in QInotifyFileSystemWatcherEngine::run (this=0x1544cd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe71e39c175 in QThreadPrivate::start (arg=0x1544cd0) at thread/qthread_unix.cpp:320
#9  0x00007fe716585d8c in start_thread (arg=0x7fe704880700) at pthread_create.c:304
#10 0x00007fe7212ad04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe6f2787700 (LWP 1588)):
#0  0x00007fe72129ff03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe715c82104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe715c829f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe6f3ab9c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fe715ca93e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe716585d8c in start_thread (arg=0x7fe6f2787700) at pthread_create.c:304
#6  0x00007fe7212ad04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe6f192b700 (LWP 2709)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe71cb3a832 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007fe716585d8c in start_thread (arg=0x7fe6f192b700) at pthread_create.c:304
#3  0x00007fe7212ad04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe7219ae7a0 (LWP 1580)):
[KCrash Handler]
#6  0x00007fe717245068 in Attica::BaseJob::abort() () from /usr/lib/libattica.so.0
#7  0x00007fe71f7bb7e5 in KNS3::AtticaProvider::loadEntries (this=0x4b9a460, request=...) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:138
#8  0x00007fe71f7974cb in KNS3::Engine::reloadEntries (this=0x541a920) at ../../../knewstuff/knewstuff3/core/engine.cpp:310
#9  0x00007fe71f797a5c in slotSearchTimerExpired (this=0x541a920, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff465ef60) at ../../../knewstuff/knewstuff3/core/engine.cpp:349
#10 KNS3::Engine::qt_metacall (this=0x541a920, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff465ef60) at ./engine.moc:155
#11 0x00007fe71e4985f8 in QMetaObject::activate (sender=0x3f23480, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3287
#12 0x00007fe71e4971c9 in QObject::event (this=0x3f23480, e=<value optimized out>) at kernel/qobject.cpp:1190
#13 0x00007fe71d8449e4 in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4465
#14 0x00000000014de6a0 in ?? ()
#15 0x00000000014de6a0 in ?? ()
#16 0x00007ffff465f660 in ?? ()
#17 0x00000000014de6a0 in ?? ()
#18 0x00007ffff465f660 in ?? ()
#19 0x00007fe71d8493aa in QApplication::notify (this=0x3f23480, receiver=0x3f23480, e=0x7ffff465f660) at kernel/qapplication.cpp:3861
#20 0x00007fe71f13b866 in KApplication::notify (this=0x14de6a0, receiver=0x3f23480, event=0x7ffff465f660) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007fe71e48349c in QCoreApplication::notifyInternal (this=0x14de6a0, receiver=0x3f23480, event=0x7ffff465f660) at kernel/qcoreapplication.cpp:731
#22 0x00007fe71e4b0f12 in sendEvent (this=0x1502f30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QTimerInfoList::activateTimers (this=0x1502f30) at kernel/qeventdispatcher_unix.cpp:604
#24 0x00007fe71e4add18 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#25 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#26 0x00007fe715c81bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fe715c823a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fe715c82639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fe71e4ae3ef in QEventDispatcherGlib::processEvents (this=0x1483340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007fe71d8ebdfe in QKeyMapperPrivate::possibleKeysCore (this=0x7fe71e4827e2, event=<value optimized out>) at kernel/qkeymapper_x11.cpp:386
#31 0x0000000000000000 in ?? ()

Possible duplicates by query: bug 282276, bug 281973, bug 281648, bug 280578, bug 275943.

Reported using DrKonqi
Comment 1 Dario Andres 2011-09-29 12:44:01 UTC
[Comment from a bug triager]
This issue is being tracked at bug 251871, merging.
Thanks

*** This bug has been marked as a duplicate of bug 251871 ***