Bug 281929 - Presence should be restored at boot
Summary: Presence should be restored at boot
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: kded-module (show other bugs)
Version: git-latest
Platform: Unlisted Binaries Linux
: NOR wishlist
Target Milestone: 0.4.0
Assignee: Telepathy Bugs
URL:
Keywords:
: 279154 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-13 11:11 UTC by Daniele E. Domenichelli
Modified: 2012-07-06 12:47 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele E. Domenichelli 2011-09-13 11:11:11 UTC
Version:           git-latest
OS:                Linux

Most IM clients restore the last presence set by the user when started, or at least go online

I don't know who should handle this if the user doesn't have the presence-applet or if he has it, but in an activity that is not running

Reproducible: Always

Steps to Reproduce:
Connect accounts
Reboot

Actual Results:  
Status is disconnected

Expected Results:  
Should be online or better the last status set by user
Comment 1 Alin M Elena 2011-09-13 12:52:45 UTC
probably the last used message should be restored too... the presence and the message are in a bundle.
Comment 2 Martin Klapetek 2011-12-21 13:36:33 UTC
The presence is currently saved when the kded module is destroyed (which should happen only on logout). Pretty much all that is missing is loading it from config and setting it as presence. It also needs config option.

But it's not so straightforward, I wouldn't want to see it connecting without the presence plasmoid active - ie. log in, be connected and have no idea about it until you run contact list. Maybe could be worth merging this issue with bug 284779? Connect only when you activate some of the presence controls and restore the last presence.
Comment 3 Martin Klapetek 2012-01-19 09:17:05 UTC
*** Bug 279154 has been marked as a duplicate of this bug. ***
Comment 4 Daniele E. Domenichelli 2012-04-17 17:48:34 UTC
Fixed by xerdomii with commit cc65c8b9cf823a9e3011c2bc1e235618bddd3fe3