Bug 281862 - KDM restarts when interacting with XDMCP chooser
Summary: KDM restarts when interacting with XDMCP chooser
Status: RESOLVED FIXED
Alias: None
Product: kdm
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash with 147 votes (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
: 283919 287265 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-12 09:36 UTC by paalsteek
Modified: 2012-09-06 13:56 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paalsteek 2011-09-12 09:36:08 UTC
Version:           unspecified (using KDE 4.7.1) 
OS:                Linux

When selecting 'remote login' in kdm and moving the mouse above the chooser window the X server restarts, showing the login screen again.

/var/log/everything.log showed:

Sep 12 11:28:21 (none) kdm: :0[1399]: Received unknown command 4 from greeter

Reproducible: Always

Steps to Reproduce:
Start KDM
Select "remote login"
Move the mouse in the chooser window

Actual Results:  
X server/kdm restarts

Expected Results:  
selecting remote host possible
Comment 1 jef_pera 2011-09-25 08:15:06 UTC
Version:           KDE 4.7.0 and 4.7.1
OS:                Linux

 I have the same issue:

...
Sep 25 09:35:26 kdm: :0[6496] error: Received unknown command 4 from greeter
Sep 25 09:35:26 kdm: :0[6496] debug: closed greeter for display :0
Sep 25 09:35:26 kdm: :0[6496] debug: greeter for :0 stopped
Sep 25 09:35:26 kdm: :0[6496] debug: starting greeter for display :0
....

So XDMCP is broken in KDE.
Comment 2 mateusz-lists 2011-10-10 14:47:49 UTC
Same here, for 4.7.1:
Oct 10 16:45:07 foo kdm: :0[6532]: Received unknown command 4 from greeter
Oct 10 16:45:07 foo kdm_greet[6775]: Data directory "/var/lib/kdm" not accessible: Permission denied
Oct 10 16:45:08 foo kdm_greet[6775]: Cannot load /etc/X11/kdm/faces/.default.face: No such file or directory
Comment 3 Oswald Buddenhagen 2011-10-23 12:56:44 UTC
*** Bug 283919 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Thiemel 2011-10-31 07:18:29 UTC
Hi, I've got same problem... :-(  
OS: ArchLinux 32bit 
KDE version: 4.7.2-1 KDM
default behavior: Show XDMCP host menu (LoginMode=DefaultRemote)  
Errors in /var/log/kdm.log (DBUS IS RUNNING!): 
> klauncher(5355) kdemain: No DBUS session-bus found. Check if you have started the DBUS server. 
> kdeinit4: Communication error with launcher. Exiting! 
> kdmgreet(5349)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: "Not connected to D-Bus server" 
>
>kdmgreet(5349)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned 
>Server terminated successfully (0). Closing log file.  

Syslog error(s): 
>Oct 30 07:11:25 localhost kdm_greet[3071]: Cannot load /usr/share/apps/kdm/faces/.default.face: No such file or directory 
>Oct 30 07:17:11 localhost kdm: :0[3165]: Received unknown command 4 from greeter
>Oct 30 07:17:58 localhost kdm: :0[3256]: Received unknown command 4 from greeter
>Oct 30 07:22:17 localhost kdm: :0[3432]: Received unknown command 4 from greeter
Comment 5 Andreas K. Huettel 2011-11-06 21:10:07 UTC
Same problem observed in Gentoo, KDE 4.7.3
https://bugs.gentoo.org/show_bug.cgi?id=389757
Comment 6 T Bubeck 2011-11-11 15:18:51 UTC
This also happens with Fedora 16/4.7.2

See https://bugzilla.redhat.com/show_bug.cgi?id=753196
Comment 7 Norman Back 2011-11-18 22:31:06 UTC
Even though I am still running kde-7.3, reverting to kde-base/kdm-4.6.5-r2
seems to fix this.
Comment 8 Oswald Buddenhagen 2011-11-22 19:34:10 UTC
*** Bug 287265 has been marked as a duplicate of this bug. ***
Comment 9 steveb 2011-11-26 07:32:52 UTC
I have 2 systems affected. Both amd64 kubuntu 11.10 (KDE 4.7.3)

The error message from kdm_greet:
> Cannot load /usr/share/kde4/apps/kdm/faces/.default.face: No such file or directory
can be removed by choosing a default user image:
 (System Settings - Login Screen - Users - User images - User: default)

After setting a default image, I still get the kdm error:
> kdm: :1[4010]: Received unknown command 4 from greeter
Comment 10 hemathor 2012-01-24 21:38:58 UTC
same here with all opensuse 12.1 and latest kde 4.7.4 from upstream repo...
Comment 11 mateusz-lists 2012-01-25 08:55:47 UTC
Still present in 4.8.0 :(
Comment 12 Andreas K. Huettel 2012-01-25 09:35:08 UTC
FYI Gentoo has resolved this successfully by reverting kdm commit 720b0bfe5fab7142b9683f329b75cf2951b95c8e

This basically changes the logic back to as it was in kdm-4.6.5
Comment 13 mateusz-lists 2012-01-25 14:55:04 UTC
> FYI Gentoo has resolved this successfully by reverting kdm commit
> 720b0bfe5fab7142b9683f329b75cf2951b95c8e
> 
> This basically changes the logic back to as it was in kdm-4.6.5

Thanks for hint Andreas !
Revert seems to work for 4.8.0 too.
Comment 14 Chris 2012-02-27 15:30:29 UTC
Is there anything going on with this? It still appears to be broken in Kubuntu Oneiric. Has KDE actually been fixed, or are individual distributions just doing reverts? I'm currently running KDE 4.7.4 but will upgrade to whatever ships with precise.
Comment 15 Blindauer Emmanuel 2012-04-11 12:43:33 UTC
I confirm the bug, will somone fix the commit ?
Comment 16 Oswald Buddenhagen 2012-06-10 09:03:16 UTC
Git commit a4ef19c9491e7c5b3ff5a7e18915b6b14f71fe3f by Oswald Buddenhagen.
Committed on 10/06/2012 at 10:57.
Pushed by ossi into branch 'master'.

centralize interaction notification handling

that way we don't have to handle it all over the place (which we didn't,
which made the chooser dysfunctional).

M  +3    -3    kdm/backend/choose.c
M  +2    -2    kdm/backend/dm.h
M  +10   -10   kdm/backend/session.c

http://commits.kde.org/kde-workspace/a4ef19c9491e7c5b3ff5a7e18915b6b14f71fe3f
Comment 17 Oswald Buddenhagen 2012-06-10 09:04:42 UTC
please test this a bit, so i can backport it.
Comment 18 jef_pera 2012-06-12 13:47:24 UTC
Version: KDE 4.8.4 
OS: Linux

It works!
Thank to Oswald.
Comment 19 Oswald Buddenhagen 2012-06-16 09:22:01 UTC
Git commit da6e2b49fd2a30aca167ae37ef3e3fd1c7d3bc58 by Oswald Buddenhagen.
Committed on 10/06/2012 at 10:57.
Pushed by ossi into branch 'KDE/4.8'.

centralize interaction notification handling

that way we don't have to handle it all over the place (which we didn't,
which made the chooser dysfunctional).

(cherry picked from commit a4ef19c9491e7c5b3ff5a7e18915b6b14f71fe3f)

M  +3    -3    kdm/backend/choose.c
M  +2    -2    kdm/backend/dm.h
M  +10   -10   kdm/backend/session.c

http://commits.kde.org/kde-workspace/da6e2b49fd2a30aca167ae37ef3e3fd1c7d3bc58
Comment 20 petej 2012-09-05 16:20:42 UTC
Hi there,

I have Kubuntu Precise, which comes with KDE 4.8.4, and exactly this bug is still there. Why?
Comment 21 cmcgrath5035 2012-09-06 02:00:44 UTC
I am delighted to report that after not having the feature for over a year, Remote Login from the Greeter is now working again on Suse 12.1/KDE 4.9
Thanks!
Comment 22 petej 2012-09-06 13:56:31 UTC
I'm very happy to confirm that this feature is working in KDE 4.8.5 installed from

https://launchpad.net/~kubuntu-ppa/+archive/ppa

in Kubuntu 12.04 Precise LTS. Let's hope this version of KDE moves into 'precise-updates' fast.